summaryrefslogtreecommitdiff
path: root/bindings/corba/java
diff options
context:
space:
mode:
Diffstat (limited to 'bindings/corba/java')
-rw-r--r--bindings/corba/java/Makefile12
-rw-r--r--bindings/corba/java/src/org/crosswire/sword/orb/SwordOrb.java9
2 files changed, 15 insertions, 6 deletions
diff --git a/bindings/corba/java/Makefile b/bindings/corba/java/Makefile
index e342a9c..c4ae46c 100644
--- a/bindings/corba/java/Makefile
+++ b/bindings/corba/java/Makefile
@@ -1,9 +1,17 @@
+#CHANGE THESE TO MATCH YOUR SYSTEM
TOMCAT_HOME=/opt/tomcat
-#SERVLET_LIB=${TOMCAT_HOME}/common/lib/servlet-api.jar
-SERVLET_LIB=${TOMCAT_HOME}/lib/servlet-api.jar
instdir=${TOMCAT_HOME}/webapps/swordweb
+
+# Typically you'll point this to your home directory, e.g.
#instdir=/home/swordweb/livehtml/webapp
#instdir=/home/scribe/src/swordweb/webapp
+
+SERVLET_LIB=${TOMCAT_HOME}/lib/servlet-api.jar
+
+# Older tomcat uses this path
+#SERVLET_LIB=${TOMCAT_HOME}/common/lib/servlet-api.jar
+
+
all: src/org/crosswire/sword/orb/SWMgr.java classes/org/crosswire/sword/orb/SwordOrb.class
src/org/crosswire/sword/orb/SWMgr.java: ../swordorb.idl
diff --git a/bindings/corba/java/src/org/crosswire/sword/orb/SwordOrb.java b/bindings/corba/java/src/org/crosswire/sword/orb/SwordOrb.java
index d6987e9..1816c77 100644
--- a/bindings/corba/java/src/org/crosswire/sword/orb/SwordOrb.java
+++ b/bindings/corba/java/src/org/crosswire/sword/orb/SwordOrb.java
@@ -249,17 +249,18 @@ System.out.println("ORB found in session");
ModInfo[] modInfoList = mgr.getModInfoList();
System.out.println("sequence size: " + modInfoList.length);
SWModule module;
-/*
for (int i = 0; i < modInfoList.length; i++) {
- System.out.println(modInfoList[i].name + ": " + modInfoList[i].category + ": " + modInfoList[i].language);
+ System.out.println(modInfoList[i].name + ": " + modInfoList[i].category + ": " + modInfoList[i].language + ": " + modInfoList[i].description);
+/*
module = mgr.getModuleByName(modInfoList[i].name);
module.setKeyText("jas1:19");
System.out.println(module.getRenderText());
- }
*/
+ }
+/*
module = mgr.getModuleByName("WHNU");
module.setKeyText("rev.22.21");
- System.out.println(new String(module.getRawEntry().getBytes("iso8859-1"), "UTF-8"));
+ System.out.println(module.getRawEntry());
/*
boolean lucene = module.hasSearchFramework();
SearchHit[] searchResults = module.search("God love world", (lucene)?SearchType.LUCENE:SearchType.MULTIWORD, 0, "");