summaryrefslogtreecommitdiff
path: root/bindings/swig/package/README
diff options
context:
space:
mode:
Diffstat (limited to 'bindings/swig/package/README')
-rw-r--r--bindings/swig/package/README28
1 files changed, 28 insertions, 0 deletions
diff --git a/bindings/swig/package/README b/bindings/swig/package/README
new file mode 100644
index 0000000..90caf83
--- /dev/null
+++ b/bindings/swig/package/README
@@ -0,0 +1,28 @@
+README
+------
+
+To build the sword bindings for Sword you require
+
+SWIG 1.3 (see http://www.swig.org)
+one of perl, python, tcl, php
+Sword 1.5.8 or newer
+
+First run
+./autogen.sh
+./configure
+
+Then, e.g.,:
+
+make perlswig
+make perl_make
+cd perl
+sudo make install
+
+or
+
+make pythonswig
+make python_make
+cd python
+sudo python setup.py install
+
+