summaryrefslogtreecommitdiff
path: root/examples/X11/gtk--/simplefrontend/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'examples/X11/gtk--/simplefrontend/Makefile')
-rw-r--r--examples/X11/gtk--/simplefrontend/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/examples/X11/gtk--/simplefrontend/Makefile b/examples/X11/gtk--/simplefrontend/Makefile
new file mode 100644
index 0000000..ca4a167
--- /dev/null
+++ b/examples/X11/gtk--/simplefrontend/Makefile
@@ -0,0 +1,22 @@
+root := ../../../..
+subdirs :=
+pre-targets :=
+targets := simplefrontend
+bin := simplefrontend
+include ${root}/Makefile.cfg
+
+cpp += simplefrontend.cpp
+
+s = $(c) $(cpp)
+d = $(c:%.c=%.d) $(cpp:%.cpp=%.d)
+o = $(c:%.c=%.o) $(cpp:%.cpp=%.o)
+l = -lsword -lgtkmm-1.1
+
+
+simplefrontend: $(o)
+ $(CC) $(LFLAGS) -o $@ simplefrontend.o $(l) $(l)
+
+
+ifneq ($(nodeps),yes)
+-include $(d)
+endif