summaryrefslogtreecommitdiff
path: root/examples/classes
diff options
context:
space:
mode:
Diffstat (limited to 'examples/classes')
-rw-r--r--examples/classes/Makefile2
-rw-r--r--examples/classes/ciphercng.cpp17
-rw-r--r--examples/classes/swmgrex.cpp16
3 files changed, 34 insertions, 1 deletions
diff --git a/examples/classes/Makefile b/examples/classes/Makefile
index 882d9b8..38920d2 100644
--- a/examples/classes/Makefile
+++ b/examples/classes/Makefile
@@ -5,6 +5,6 @@ clean:
rm $(TARGETS)
.cpp:
- g++ -g `pkg-config --cflags sword` $< -o $@ `pkg-config --libs sword`
+ g++ -O3 `pkg-config --cflags sword` $< -o $@ `pkg-config --libs sword`
diff --git a/examples/classes/ciphercng.cpp b/examples/classes/ciphercng.cpp
index e1cd042..bf85cc7 100644
--- a/examples/classes/ciphercng.cpp
+++ b/examples/classes/ciphercng.cpp
@@ -4,6 +4,23 @@
* The change is only in effect for this run. This DOES NOT change the
* cipherkey in the module's .conf file.
*
+ *
+ * $Id: ciphercng.cpp 2327 2009-04-22 11:42:33Z scribe $
+ *
+ * Copyright 1998-2009 CrossWire Bible Society (http://www.crosswire.org)
+ * CrossWire Bible Society
+ * P. O. Box 2528
+ * Tempe, AZ 85280-2528
+ *
+ * This program is free software; you can redistribute it and/or modify it
+ * under the terms of the GNU General Public License as published by the
+ * Free Software Foundation version 2.
+ *
+ * This program is distributed in the hope that it will be useful, but
+ * WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+ * General Public License for more details.
+ *
*/
#include <iostream>
diff --git a/examples/classes/swmgrex.cpp b/examples/classes/swmgrex.cpp
index a3d6591..9978a7b 100644
--- a/examples/classes/swmgrex.cpp
+++ b/examples/classes/swmgrex.cpp
@@ -11,6 +11,22 @@
* ModMap consists of: FIRST : SWBuf moduleName
* SECOND: SWModule *module
*
+ * $Id: swmgrex.cpp 2327 2009-04-22 11:42:33Z scribe $
+ *
+ * Copyright 1998-2009 CrossWire Bible Society (http://www.crosswire.org)
+ * CrossWire Bible Society
+ * P. O. Box 2528
+ * Tempe, AZ 85280-2528
+ *
+ * This program is free software; you can redistribute it and/or modify it
+ * under the terms of the GNU General Public License as published by the
+ * Free Software Foundation version 2.
+ *
+ * This program is distributed in the hope that it will be useful, but
+ * WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+ * General Public License for more details.
+ *
*/
#include <iostream>