summaryrefslogtreecommitdiff
path: root/scripts/mkswordtar
diff options
context:
space:
mode:
Diffstat (limited to 'scripts/mkswordtar')
-rwxr-xr-xscripts/mkswordtar3
1 files changed, 2 insertions, 1 deletions
diff --git a/scripts/mkswordtar b/scripts/mkswordtar
index 6d422b3..4afb672 100755
--- a/scripts/mkswordtar
+++ b/scripts/mkswordtar
@@ -9,8 +9,9 @@ REV=`cd ..;basename \`pwd ..\`|cut -d\- -f2`
SWORDVER=`grep "define VERSI" ../include/config.h |cut -f2 -d"\""`
sed -i "s/^\(PROJECT_NUMBER\).*/\1 = \"$SWORDVER\"/" ../doc/Doxyfile
+sed -i "s/^SET(SWORD_VERSION.*/SET(SWORD_VERSION $SWORDVER)/" ../CMakeLists.txt
-if test `echo $REV` == `echo $SWORDVER`; then
+if [ "$REV" = "$SWORDVER" ]; then
chmod +x *
echo