summaryrefslogtreecommitdiff
path: root/src/frontend/framework
diff options
context:
space:
mode:
Diffstat (limited to 'src/frontend/framework')
-rw-r--r--src/frontend/framework/Makefile4
-rw-r--r--src/frontend/framework/femain.cpp34
2 files changed, 38 insertions, 0 deletions
diff --git a/src/frontend/framework/Makefile b/src/frontend/framework/Makefile
new file mode 100644
index 0000000..81f7721
--- /dev/null
+++ b/src/frontend/framework/Makefile
@@ -0,0 +1,4 @@
+root := ../../..
+
+all:
+ make -C ${root}
diff --git a/src/frontend/framework/femain.cpp b/src/frontend/framework/femain.cpp
new file mode 100644
index 0000000..11bf565
--- /dev/null
+++ b/src/frontend/framework/femain.cpp
@@ -0,0 +1,34 @@
+/******************************************************************************
+ *
+ * femain.cpp - FEMain class definition
+ *
+ * $Id: femain.cpp 2833 2013-06-29 06:40:28Z chrislit $
+ *
+ * Copyright 1998-2013 CrossWire Bible Society (http://www.crosswire.org)
+ * CrossWire Bible Society
+ * P. O. Box 2528
+ * Tempe, AZ 85280-2528
+ *
+ * This program is free software; you can redistribute it and/or modify it
+ * under the terms of the GNU General Public License as published by the
+ * Free Software Foundation version 2.
+ *
+ * This program is distributed in the hope that it will be useful, but
+ * WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+ * General Public License for more details.
+ *
+ */
+
+#include <femain.h>
+
+FEMain::FEMain() {
+}
+
+FEMain::~FEMain() {
+ list <SWDisplay *>::iterator it;
+
+ for (it = displays.begin(); it != displays.end(); ++it)
+ delete *it;
+
+}