summaryrefslogtreecommitdiff
path: root/src/modules/comments/zcom
diff options
context:
space:
mode:
Diffstat (limited to 'src/modules/comments/zcom')
-rw-r--r--src/modules/comments/zcom/Makefile5
-rw-r--r--src/modules/comments/zcom/Makefile.am4
-rw-r--r--src/modules/comments/zcom/makeidx.c146
-rw-r--r--src/modules/comments/zcom/rawtxt2z.cpp83
-rw-r--r--src/modules/comments/zcom/zcom.cpp216
5 files changed, 0 insertions, 454 deletions
diff --git a/src/modules/comments/zcom/Makefile b/src/modules/comments/zcom/Makefile
deleted file mode 100644
index 35d6648..0000000
--- a/src/modules/comments/zcom/Makefile
+++ /dev/null
@@ -1,5 +0,0 @@
-
-root := ../../../..
-
-all:
- make -C ${root}
diff --git a/src/modules/comments/zcom/Makefile.am b/src/modules/comments/zcom/Makefile.am
deleted file mode 100644
index ad1ef6a..0000000
--- a/src/modules/comments/zcom/Makefile.am
+++ /dev/null
@@ -1,4 +0,0 @@
-zcomdir = $(top_srcdir)/src/modules/comments/zcom
-
-libsword_la_SOURCES += $(zcomdir)/zcom.cpp
-
diff --git a/src/modules/comments/zcom/makeidx.c b/src/modules/comments/zcom/makeidx.c
deleted file mode 100644
index 311103e..0000000
--- a/src/modules/comments/zcom/makeidx.c
+++ /dev/null
@@ -1,146 +0,0 @@
-#include <stdio.h>
-#include <fcntl.h>
-
-
-char findbreak(int fp, int *offset, int *num1, int *num2, short *size);
-
-
-main(int argc, char **argv)
-{
- int fp, vfp, cfp, bfp;
- long pos;
- short size, tmp;
- int num1, num2, offset, curbook = 0, curchap = 0, curverse = 0;
- char buf[127];
-
- if (argc != 2) {
- fprintf(stderr, "usage: %s <file to process>\n", argv[0]);
- exit(1);
- }
-
- if ((fp = open(argv[1], O_RDONLY)) == -1) {
- fprintf(stderr, "Couldn't open file: %s\n", argv[1]);
- exit(1);
- }
-
- sprintf(buf, "%s.vss", argv[1]);
- if ((vfp = open(buf, O_CREAT|O_WRONLY)) == -1) {
- fprintf(stderr, "Couldn't open file: %s\n", buf);
- exit(1);
- }
-
- sprintf(buf, "%s.cps", argv[1]);
- if ((cfp = open(buf, O_CREAT|O_WRONLY)) == -1) {
- fprintf(stderr, "Couldn't open file: %s\n", buf);
- exit(1);
- }
-
- sprintf(buf, "%s.bks", argv[1]);
- if ((bfp = open(buf, O_CREAT|O_WRONLY)) == -1) {
- fprintf(stderr, "Couldn't open file: %s\n", buf);
- exit(1);
- }
-
- pos = 0;
- write(bfp, &pos, 4); /* Book offset for testament intros */
- pos = 4;
- write(cfp, &pos, 4); /* Chapter offset for testament intro */
-
-
-/* Right now just zero out intros until parsing correctly */
- pos = 0;
- size = 0;
- write(vfp, &pos, 4); /* Module intro */
- write(vfp, &size, 2);
- write(vfp, &pos, 4); /* Testament intro */
- write(vfp, &size, 2);
-
- while (!findbreak(fp, &offset, &num1, &num2, &size)) {
-
- if (num2 == 1) { /* if we're at a new chapter */
- if (num1 == 1) { /* if we're at a new book */
- pos = lseek(cfp, 0, SEEK_CUR);
- write(bfp, &pos, 4);
- pos = lseek(vfp, 0, SEEK_CUR); /* Book intro (cps) */
- write(cfp, &pos, 4);
- pos = 0;
- tmp = 0;
- write(vfp, &pos, 4); /* Book intro (vss) */
- write(vfp, &tmp, 2);
- curbook++;
- curchap = 0;
- }
- pos = lseek(vfp, 0, SEEK_CUR);
- write(cfp, &pos, 4);
- curverse = 1;
- pos = 0;
- tmp = 0;
- write(vfp, &pos, 4); /* Chapter intro */
- write(vfp, &tmp, 2);
- curchap++;
- }
- else curverse++;
-
- printf("%2d:%3d:%3d found at offset: %7d\n", curbook, num1, num2, offset);
-
- if (num1 != curchap) {
- fprintf(stderr, "Error: Found chaptures out of sequence\n", buf);
- break;
- }
- if (num2 != curverse) {
- fprintf(stderr, "Error: Found verses out of sequence\n", buf);
- break;
- }
- write(vfp, &offset, 4);
- write(vfp, &size, 2);
- }
-
- close(vfp);
- close(cfp);
- close(bfp);
- close(fp);
-}
-
-
-char findbreak(int fp, int *offset, int *num1, int *num2, short *size)
-{
- char buf[7];
- char buf2[7];
- char loop;
- int offset2, ch2, vs2;
-
- memset(buf, ' ', 7);
-
- while (1) {
- if (buf[3] == ':') {
- memcpy(buf2, buf, 7);
- for (loop = 0; loop < 7; loop++) {
- if (!isdigit(buf2[loop]))
- buf2[loop] = ' ';
- }
- buf2[3] = 0;
- *num1 = atoi(buf2);
- *num2 = atoi(&buf2[4]);
- if (*num1 && *num2) {
- *offset = lseek(fp, 0, SEEK_CUR);
- sprintf(buf2, "%d", *num2);
- *offset -= 2 - strlen(buf2);
- if (size) {
- if (findbreak(fp, &offset2, &ch2, &vs2, 0)) {
- *size = (short) (lseek(fp, 0, SEEK_END) - (*offset));
- }
- else {
- sprintf(buf2, "%d:%d", ch2, vs2);
- *size = (offset2 - (*offset)) - (strlen(buf2) + 2);
- }
- lseek(fp, *offset, SEEK_SET);
- }
- return 0;
- }
- }
- memmove(buf, &buf[1], 6);
- if (read(fp, &buf[6], 1) != 1)
- return 1;
- }
-}
-
diff --git a/src/modules/comments/zcom/rawtxt2z.cpp b/src/modules/comments/zcom/rawtxt2z.cpp
deleted file mode 100644
index f8c18d0..0000000
--- a/src/modules/comments/zcom/rawtxt2z.cpp
+++ /dev/null
@@ -1,83 +0,0 @@
-#include <ctype.h>
-#include <stdio.h>
-#include <fcntl.h>
-#include <errno.h>
-#include <stdlib.h>
-
-#ifndef __GNUC__
-#include <io.h>
-#else
-#include <unistd.h>
-#endif
-
-#include <swcomprs.h>
-
-
-main(int argc, char **argv)
-{
- SWCompress *zobj;
- int ifd, ofd, ixfd, oxfd;
- long offset, loffset, lzoffset;
- short size, lsize, lzsize;
- char *tmpbuf;
-
- if (argc != 2) {
- fprintf(stderr, "usage: %s <datafilename>\n", argv[0]);
- exit(1);
- }
-
- zobj = new SWCompress();
-
-#ifndef O_BINARY
-#define O_BINARY 0
-#endif
-
- tmpbuf = new char [ strlen(argv[1]) + 9 ];
- ifd = open(argv[1], O_RDONLY|O_BINARY);
- sprintf(tmpbuf, "%s.vss", argv[1]);
- ixfd = open(tmpbuf, O_RDONLY|O_BINARY);
- sprintf(tmpbuf, "%s.zzz", argv[1]);
- ofd = open(tmpbuf, O_WRONLY|O_BINARY|O_CREAT);
- sprintf(tmpbuf, "%s.zzz.vss", argv[1]);
- oxfd = open(tmpbuf, O_WRONLY|O_BINARY|O_CREAT);
-
- delete [] tmpbuf;
-
- printf("\n");
-
- while (1) {
- if (read(ixfd, &offset, 4) != 4)
- break;
- if (read(ixfd, &size, 2) != 2)
- break;
-
- if ((offset == loffset) && (size == lsize)) {
- printf("using previous offset,size\n", size);
- write(oxfd, &lzoffset, 4);
- write(oxfd, &lzsize, 2);
- }
- else {
- printf("%d -> ", size);
- lsize = size;
- loffset = offset;
-
- if (size) {
- tmpbuf = (char *) calloc(size + 1, 1);
- lseek(ifd, offset, SEEK_SET);
- read(ifd, tmpbuf, size);
- zobj->Buf(tmpbuf);
- zobj->zBuf(&size);
- free(tmpbuf);
- }
- offset = lseek(ofd, 0, SEEK_END);
- write(oxfd, &offset, 4);
- if (size)
- write(ofd, zobj->zBuf(&size), size);
- lzoffset = offset;
- write(oxfd, &size, 2);
- lzsize = size;
- printf("%d \n", size);
- }
- }
- delete zobj;
-}
diff --git a/src/modules/comments/zcom/zcom.cpp b/src/modules/comments/zcom/zcom.cpp
deleted file mode 100644
index 744a509..0000000
--- a/src/modules/comments/zcom/zcom.cpp
+++ /dev/null
@@ -1,216 +0,0 @@
-/******************************************************************************
- * rawcom.cpp - code for class 'zCom'- a module that reads raw commentary
- * files: ot and nt using indexs ??.bks ??.cps ??.vss
- */
-
-
-#include <ctype.h>
-#include <stdio.h>
-#include <fcntl.h>
-
-#ifndef __GNUC__
-#include <io.h>
-#else
-#include <unistd.h>
-#endif
-
-#include <utilfuns.h>
-#include <zverse.h>
-#include <zcom.h>
-
-SWORD_NAMESPACE_START
-
-/******************************************************************************
- * zCom Constructor - Initializes data for instance of zCom
- *
- * ENT: ipath - path to data files
- * iname - Internal name for module
- * idesc - Name to display to user for module
- * iblockType - verse, chapter, book, etc. of index chunks
- * icomp - Compressor object
- * idisp - Display object to use for displaying
- */
-
-zCom::zCom(const char *ipath, const char *iname, const char *idesc, int iblockType, SWCompress *icomp, SWDisplay *idisp, SWTextEncoding enc, SWTextDirection dir, SWTextMarkup mark, const char* ilang) : zVerse(ipath, -1, iblockType, icomp), SWCom(iname, idesc, idisp, enc, dir, mark, ilang)/*, SWCompress()*/
-{
- blockType = iblockType;
- lastWriteKey = 0;
-}
-
-/******************************************************************************
- * zCom Destructor - Cleans up instance of zCom
- */
-
-zCom::~zCom() {
- flushCache();
-
- if (lastWriteKey)
- delete lastWriteKey;
-}
-
-/******************************************************************************
- * zCom::getRawEntry - Returns the correct verse when char * cast
- * is requested
- *
- * RET: string buffer with verse
- */
-SWBuf &zCom::getRawEntryBuf() {
- long start = 0;
- unsigned short size = 0;
- VerseKey *key = &getVerseKey();
-
- findOffset(key->Testament(), key->Index(), &start, &size);
- entrySize = size; // support getEntrySize call
-
- entryBuf = "";
- zReadText(key->Testament(), start, size, entryBuf);
-
- rawFilter(entryBuf, key);
-
-// if (!isUnicode())
- prepText(entryBuf);
-
- return entryBuf;
-}
-
-
-bool zCom::sameBlock(VerseKey *k1, VerseKey *k2) {
- if (k1->Testament() != k2->Testament())
- return false;
-
- switch (blockType) {
- case VERSEBLOCKS:
- if (k1->Verse() != k2->Verse())
- return false;
- case CHAPTERBLOCKS:
- if (k1->Chapter() != k2->Chapter())
- return false;
- case BOOKBLOCKS:
- if (k1->Book() != k2->Book())
- return false;
- }
- return true;
-}
-
-void zCom::setEntry(const char *inbuf, long len) {
- VerseKey *key = &getVerseKey();
-
- // see if we've jumped across blocks since last write
- if (lastWriteKey) {
- if (!sameBlock(lastWriteKey, key)) {
- flushCache();
- }
- delete lastWriteKey;
- }
-
- doSetText(key->Testament(), key->Index(), inbuf, len);
-
- lastWriteKey = (VerseKey *)key->clone(); // must delete
-}
-
-
-void zCom::linkEntry(const SWKey *inkey) {
- VerseKey *destkey = &getVerseKey();
- const VerseKey *srckey = 0;
-
- // see if we have a VerseKey * or decendant
- try {
- srckey = (const VerseKey *) SWDYNAMIC_CAST(VerseKey, inkey);
- }
- catch ( ... ) {
- }
- // if we don't have a VerseKey * decendant, create our own
- if (!srckey)
- srckey = new VerseKey(inkey);
-
- doLinkEntry(destkey->Testament(), destkey->Index(), srckey->Index());
-
- if (inkey != srckey) // free our key if we created a VerseKey
- delete srckey;
-}
-
-/******************************************************************************
- * zCom::deleteEntry - deletes this entry
- *
- * RET: *this
- */
-
-void zCom::deleteEntry() {
-
- VerseKey *key = &getVerseKey();
- doSetText(key->Testament(), key->Index(), "");
-}
-
-
-/******************************************************************************
- * zCom::increment - Increments module key a number of entries
- *
- * ENT: increment - Number of entries to jump forward
- *
- * RET: *this
- */
-
-void zCom::increment(int steps) {
- long start;
- unsigned short size;
- VerseKey *tmpkey = &getVerseKey();
-
- findOffset(tmpkey->Testament(), tmpkey->Index(), &start, &size);
-
- SWKey lastgood = *tmpkey;
- while (steps) {
- long laststart = start;
- unsigned short lastsize = size;
- SWKey lasttry = *tmpkey;
- (steps > 0) ? (*key)++ : (*key)--;
- tmpkey = &getVerseKey();
-
- if ((error = key->Error())) {
- *key = lastgood;
- break;
- }
- long index = tmpkey->Index();
- findOffset(tmpkey->Testament(), index, &start, &size);
- if (
- (((laststart != start) || (lastsize != size)) // we're a different entry
-// && (start > 0)
- && (size)) // and we actually have a size
- ||(!skipConsecutiveLinks)) { // or we don't want to skip consecutive links
- steps += (steps < 0) ? 1 : -1;
- lastgood = *tmpkey;
- }
- }
- error = (error) ? KEYERR_OUTOFBOUNDS : 0;
-}
-
-
-VerseKey &zCom::getVerseKey() {
- static VerseKey tmpVK;
- VerseKey *key;
- // see if we have a VerseKey * or decendant
- try {
- key = SWDYNAMIC_CAST(VerseKey, this->key);
- }
- catch ( ... ) { }
- if (!key) {
- ListKey *lkTest = 0;
- try {
- lkTest = SWDYNAMIC_CAST(ListKey, this->key);
- }
- catch ( ... ) { }
- if (lkTest) {
- try {
- key = SWDYNAMIC_CAST(VerseKey, lkTest->GetElement());
- }
- catch ( ... ) { }
- }
- }
- if (!key) {
- tmpVK = *(this->key);
- return tmpVK;
- }
- else return *key;
-}
-
-
-SWORD_NAMESPACE_END