summaryrefslogtreecommitdiff
path: root/src/modules/genbook
diff options
context:
space:
mode:
Diffstat (limited to 'src/modules/genbook')
-rw-r--r--src/modules/genbook/Makefile5
-rw-r--r--src/modules/genbook/Makefile.am5
-rw-r--r--src/modules/genbook/rawgenbook/Makefile4
-rw-r--r--src/modules/genbook/rawgenbook/Makefile.am4
-rw-r--r--src/modules/genbook/rawgenbook/rawgenbook.cpp209
-rw-r--r--src/modules/genbook/swgenbook.cpp29
6 files changed, 0 insertions, 256 deletions
diff --git a/src/modules/genbook/Makefile b/src/modules/genbook/Makefile
deleted file mode 100644
index 1a2d00d..0000000
--- a/src/modules/genbook/Makefile
+++ /dev/null
@@ -1,5 +0,0 @@
-
-root := ../../..
-
-all:
- make -C ${root}
diff --git a/src/modules/genbook/Makefile.am b/src/modules/genbook/Makefile.am
deleted file mode 100644
index 02f6ab1..0000000
--- a/src/modules/genbook/Makefile.am
+++ /dev/null
@@ -1,5 +0,0 @@
-genbookdir = $(top_srcdir)/src/modules/genbook
-
-libsword_la_SOURCES += $(genbookdir)/swgenbook.cpp
-
-include ../src/modules/genbook/rawgenbook/Makefile.am
diff --git a/src/modules/genbook/rawgenbook/Makefile b/src/modules/genbook/rawgenbook/Makefile
deleted file mode 100644
index aab8056..0000000
--- a/src/modules/genbook/rawgenbook/Makefile
+++ /dev/null
@@ -1,4 +0,0 @@
-root := ../../../..
-
-all:
- make -C ${root}
diff --git a/src/modules/genbook/rawgenbook/Makefile.am b/src/modules/genbook/rawgenbook/Makefile.am
deleted file mode 100644
index a176d75..0000000
--- a/src/modules/genbook/rawgenbook/Makefile.am
+++ /dev/null
@@ -1,4 +0,0 @@
-rawgenbookdir = $(top_srcdir)/src/modules/genbook/rawgenbook
-
-libsword_la_SOURCES += $(rawgenbookdir)/rawgenbook.cpp
-
diff --git a/src/modules/genbook/rawgenbook/rawgenbook.cpp b/src/modules/genbook/rawgenbook/rawgenbook.cpp
deleted file mode 100644
index 4850509..0000000
--- a/src/modules/genbook/rawgenbook/rawgenbook.cpp
+++ /dev/null
@@ -1,209 +0,0 @@
-/******************************************************************************
- * rawtext.cpp - code for class 'RawGenBook'- a module that reads raw text files:
- * ot and nt using indexs ??.bks ??.cps ??.vss
- */
-
-
-#include <stdio.h>
-#include <fcntl.h>
-
-#ifndef __GNUC__
-#include <io.h>
-#else
-#include <unistd.h>
-#endif
-
-#include <utilfuns.h>
-#include <rawgenbook.h>
-#include <rawstr.h>
-
-#ifndef O_BINARY
-#define O_BINARY 0
-#endif
-
-SWORD_NAMESPACE_START
-
-/******************************************************************************
- * RawGenBook Constructor - Initializes data for instance of RawGenBook
- *
- * ENT: iname - Internal name for module
- * idesc - Name to display to user for module
- * idisp - Display object to use for displaying
- */
-
-RawGenBook::RawGenBook(const char *ipath, const char *iname, const char *idesc, SWDisplay *idisp, SWTextEncoding enc, SWTextDirection dir, SWTextMarkup mark, const char* ilang)
- : SWGenBook(iname, idesc, idisp, enc, dir, mark, ilang) {
- int fileMode = O_RDWR;
- char *buf = new char [ strlen (ipath) + 20 ];
-
- path = 0;
- stdstr(&path, ipath);
-
-
- if ((path[strlen(path)-1] == '/') || (path[strlen(path)-1] == '\\'))
- path[strlen(path)-1] = 0;
-
- delete key;
- key = CreateKey();
-
-
- sprintf(buf, "%s.bdt", path);
- bdtfd = FileMgr::systemFileMgr.open(buf, fileMode|O_BINARY, true);
-
- delete [] buf;
-
-}
-
-
-/******************************************************************************
- * RawGenBook Destructor - Cleans up instance of RawGenBook
- */
-
-RawGenBook::~RawGenBook() {
-
- FileMgr::systemFileMgr.close(bdtfd);
-
- if (path)
- delete [] path;
-
-}
-
-
-/******************************************************************************
- * RawGenBook::getRawEntry - Returns the correct verse when char * cast
- * is requested
- *
- * RET: string buffer with verse
- */
-
-SWBuf &RawGenBook::getRawEntryBuf() {
-
- __u32 offset = 0;
- __u32 size = 0;
-
- TreeKeyIdx *key = 0;
- try {
- key = SWDYNAMIC_CAST(TreeKeyIdx, (this->key));
- }
- catch ( ... ) {}
-
- if (!key) {
- key = (TreeKeyIdx *)CreateKey();
- (*key) = *(this->key);
- }
-
- int dsize;
- key->getUserData(&dsize);
- entryBuf = "";
- if (dsize > 7) {
- memcpy(&offset, key->getUserData(), 4);
- offset = swordtoarch32(offset);
-
- memcpy(&size, key->getUserData() + 4, 4);
- size = swordtoarch32(size);
-
- entrySize = size; // support getEntrySize call
-
- entryBuf.setFillByte(0);
- entryBuf.setSize(size);
- lseek(bdtfd->getFd(), offset, SEEK_SET);
- read(bdtfd->getFd(), entryBuf.getRawData(), size);
-
- rawFilter(entryBuf, 0); // hack, decipher
- rawFilter(entryBuf, key);
-
-// if (!isUnicode())
- RawStr::prepText(entryBuf);
- }
-
- if (key != this->key) // free our key if we created a VerseKey
- delete key;
-
- return entryBuf;
-}
-
-
-void RawGenBook::setEntry(const char *inbuf, long len) {
-
- __u32 offset = archtosword32(lseek(bdtfd->getFd(), 0, SEEK_END));
- __u32 size = 0;
- TreeKeyIdx *key = ((TreeKeyIdx *)this->key);
-
- char userData[8];
-
- if (!len)
- len = strlen(inbuf);
-
- write(bdtfd->getFd(), inbuf, len);
-
- size = archtosword32(len);
- memcpy(userData, &offset, 4);
- memcpy(userData+4, &size, 4);
- key->setUserData(userData, 8);
- key->save();
-}
-
-
-void RawGenBook::linkEntry(const SWKey *inkey) {
- TreeKeyIdx *srckey = 0;
- TreeKeyIdx *key = ((TreeKeyIdx *)this->key);
- // see if we have a VerseKey * or decendant
- try {
- srckey = SWDYNAMIC_CAST(TreeKeyIdx, inkey);
- }
- catch ( ... ) {}
- // if we don't have a VerseKey * decendant, create our own
- if (!srckey) {
- srckey = (TreeKeyIdx *)CreateKey();
- (*srckey) = *inkey;
- }
-
- key->setUserData(srckey->getUserData(), 8);
- key->save();
-
- if (inkey != srckey) // free our key if we created a VerseKey
- delete srckey;
-}
-
-
-/******************************************************************************
- * RawGenBook::deleteEntry - deletes this entry
- *
- * RET: *this
- */
-
-void RawGenBook::deleteEntry() {
- TreeKeyIdx *key = ((TreeKeyIdx *)this->key);
- key->remove();
-}
-
-
-char RawGenBook::createModule(const char *ipath) {
- char *path = 0;
- char *buf = new char [ strlen (ipath) + 20 ];
- FileDesc *fd;
- signed char retval;
-
- stdstr(&path, ipath);
-
- if ((path[strlen(path)-1] == '/') || (path[strlen(path)-1] == '\\'))
- path[strlen(path)-1] = 0;
-
- sprintf(buf, "%s.bdt", path);
- unlink(buf);
- fd = FileMgr::systemFileMgr.open(buf, O_CREAT|O_WRONLY|O_BINARY, S_IREAD|S_IWRITE);
- fd->getFd();
- FileMgr::systemFileMgr.close(fd);
-
- retval = TreeKeyIdx::create(path);
- delete [] path;
- return retval;
-}
-
-
-SWKey *RawGenBook::CreateKey() {
- TreeKeyIdx *newKey = new TreeKeyIdx(path);
- return newKey;
-}
-
-SWORD_NAMESPACE_END
diff --git a/src/modules/genbook/swgenbook.cpp b/src/modules/genbook/swgenbook.cpp
deleted file mode 100644
index 3381ef8..0000000
--- a/src/modules/genbook/swgenbook.cpp
+++ /dev/null
@@ -1,29 +0,0 @@
-/******************************************************************************
- * swld.cpp - code for base class 'SWLD'. SWLD is the basis for all
- * types of Lexicon and Dictionary modules (hence the 'LD').
- */
-
-#include <swgenbook.h>
-
-SWORD_NAMESPACE_START
-
-/******************************************************************************
- * SWLD Constructor - Initializes data for instance of SWLD
- *
- * ENT: imodname - Internal name for module
- * imoddesc - Name to display to user for module
- * idisp - Display object to use for displaying
- */
-
-SWGenBook::SWGenBook(const char *imodname, const char *imoddesc, SWDisplay *idisp, SWTextEncoding enc, SWTextDirection dir, SWTextMarkup mark, const char* ilang) : SWModule(imodname, imoddesc, idisp, "Generic Books", enc, dir, mark, ilang) {
-}
-
-
-/******************************************************************************
- * SWLD Destructor - Cleans up instance of SWLD
- */
-
-SWGenBook::~SWGenBook() {
-}
-
-SWORD_NAMESPACE_END