summaryrefslogtreecommitdiff
path: root/utilities/diatheke/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'utilities/diatheke/CMakeLists.txt')
-rw-r--r--utilities/diatheke/CMakeLists.txt24
1 files changed, 24 insertions, 0 deletions
diff --git a/utilities/diatheke/CMakeLists.txt b/utilities/diatheke/CMakeLists.txt
new file mode 100644
index 0000000..ab11cb1
--- /dev/null
+++ b/utilities/diatheke/CMakeLists.txt
@@ -0,0 +1,24 @@
+####################################################################
+# And, of course, diatheke is a beast unto itself
+#
+# Let's go!
+#
+ADD_EXECUTABLE(diatheke
+ diatheke.cpp
+ corediatheke.cpp
+ diathekemgr.cpp
+ diafiltmgr.cpp
+ thmlcgi.cpp
+ gbfcgi.cpp
+ osiscgi.cpp
+)
+IF(BUILDING_SHARED)
+ TARGET_LINK_LIBRARIES(diatheke sword)
+ELSE(BUILDING_SHARED)
+ TARGET_LINK_LIBRARIES(diatheke sword_static)
+ENDIF(BUILDING_SHARED)
+INSTALL(TARGETS diatheke
+ DESTINATION "${BINDIR}"
+ COMPONENT utilities
+)
+