summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJCF Ploemen (jcfp) <linux@jcf.pm>2017-07-16 22:22:13 -0700
committerJCF Ploemen (jcfp) <linux@jcf.pm>2017-07-16 22:22:13 -0700
commitcdb9b45a91290363277a5636c87c1d303d9812d6 (patch)
tree4bf148f90772b34254e134d504ccb47008209fc3
parent4c390908513c4b61a66e3a9721ed9a03025030b2 (diff)
_dont_require_third_party
# Don't require third_party dir present for build after removing it via # uscan and an exclude in d/copyright. # # In the upstream releases, the third_party dir contains convenience # copies for a number of libraries including luajit, ck and cram. None # of these are needed by this debian package as it relies entirely on # system libraries instead. Gbp-Pq: Name 01_dont_require_third_party.diff
-rw-r--r--Makefile.am14
-rw-r--r--configure.ac2
2 files changed, 3 insertions, 13 deletions
diff --git a/Makefile.am b/Makefile.am
index a8cb064..3d8c145 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -18,15 +18,7 @@
ACLOCAL_AMFLAGS = -I m4
AM_DISTCHECK_CONFIGURE_FLAGS = --without-mysql
-if USE_BUNDLED_LUAJIT
- LUAJIT_DIR = third_party/luajit
-endif
-
-if USE_BUNDLED_CK
- CK_DIR = third_party/concurrency_kit
-endif
-
-SUBDIRS = doc $(LUAJIT_DIR) $(CK_DIR) src tests
+SUBDIRS = doc src tests
EXTRA_DIST = autogen.sh README.md README-WIN.txt README-Oracle.md ChangeLog \
snap/snapcraft.yaml.in third_party/cram \
@@ -37,10 +29,10 @@ EXTRA_DIST = autogen.sh README.md README-WIN.txt README-Oracle.md ChangeLog \
scripts/buildpack.sh
dist-hook:
- $(MAKE) -C $(distdir)/third_party/cram clean
+ $(MAKE) -C $(distdir)/third_party/cram clean || true
test:
cd tests && $(MAKE) test
clean-local:
- $(MAKE) -C $(top_srcdir)/third_party/cram clean
+ $(MAKE) -C $(top_srcdir)/third_party/cram clean || true
diff --git a/configure.ac b/configure.ac
index 5eabff1..cfa0bde 100644
--- a/configure.ac
+++ b/configure.ac
@@ -546,8 +546,6 @@ Makefile
doc/xsl/Makefile
doc/xsl/catalog.xml
doc/Makefile
-third_party/luajit/Makefile
-third_party/concurrency_kit/Makefile
src/Makefile
src/drivers/Makefile
src/drivers/mysql/Makefile