summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorJelmer Vernooij <jelmer@debian.org>2011-07-26 18:55:11 +0200
committerJelmer Vernooij <jelmer@debian.org>2011-07-26 18:55:11 +0200
commitceda78b19cfefcdf6fd6e7b597d2fb454505e9dd (patch)
tree3c83e644c333201348cf107d5f2ef95123cade3d /debian
parent711daf91cfb0df5468d47f33a39c48d3cfe0cb52 (diff)
releasing version 2.0.5-2
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog4
-rw-r--r--debian/patches/01_find_python15
-rw-r--r--debian/patches/series1
-rwxr-xr-xdebian/rules7
4 files changed, 22 insertions, 5 deletions
diff --git a/debian/changelog b/debian/changelog
index 00bce35..7d80170 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,7 +1,7 @@
-talloc (2.0.5-2) UNRELEASED; urgency=low
+talloc (2.0.5-2) unstable; urgency=low
* Switch to dh_python2.
- * Add multi-arch support.
+ * Add multi-arch support to libtalloc1.
-- Jelmer Vernooij <jelmer@debian.org> Tue, 26 Jul 2011 17:50:44 +0200
diff --git a/debian/patches/01_find_python b/debian/patches/01_find_python
new file mode 100644
index 0000000..baffb11
--- /dev/null
+++ b/debian/patches/01_find_python
@@ -0,0 +1,15 @@
+Description: Support PYTHON environment variable when looking for talloc.
+Author: Jelmer Vernooij <jelmer@debian.org>
+
+diff --git a/lib/talloc/wscript b/lib/talloc/wscript
+index c96c69c..d1f3087 100644
+--- a/wscript
++++ b/wscript
+@@ -57,6 +57,7 @@ def configure(conf):
+
+ if not conf.env.disable_python:
+ # also disable if we don't have the python libs installed
++ conf.find_program('python', var='PYTHON', mandatory=False)
+ conf.check_tool('python')
+ conf.check_python_version((2,4,2))
+ conf.SAMBA_CHECK_PYTHON_HEADERS(mandatory=False)
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..1d5f3a0
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1 @@
+01_find_python
diff --git a/debian/rules b/debian/rules
index 872b845..d8a9c80 100755
--- a/debian/rules
+++ b/debian/rules
@@ -14,16 +14,17 @@ DESTDIR=$(CURDIR)/debian/tmp
DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
-export PYTHON=$(pyversions -r)
-
conf_args = --prefix=/usr --disable-rpath-install --disable-rpath --bundled-libraries=NONE
conf_args += --build $(DEB_BUILD_GNU_TYPE) --host $(DEB_HOST_GNU_TYPE)
conf_args += --libdir=/usr/lib/$(DEB_HOST_MULTIARCH)
+export PYTHON=$(shell which `pyversions -r`)
+export PYTHON_CONFIG=$(shell which `pyversions -r`-config)
+
configure: configure-stamp
configure-stamp:
dh_testdir
- PYTHON="$(PYTHON)" CFLAGS="$(CFLAGS)" ./configure $(conf_args)
+ CFLAGS="$(CFLAGS)" ./configure $(conf_args)
touch configure-stamp
build: configure build-stamp