summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorJelmer Vernooij <jelmer@debian.org>2011-07-28 16:37:32 +0200
committerJelmer Vernooij <jelmer@debian.org>2011-07-28 16:37:32 +0200
commite9bfd85ed3f72953a20c02e6f2e0cc8b67d7ab5b (patch)
tree8e482335e78b858cc84f702de06288109e2952e1 /debian
parent2a495925c1b2a5c560e3105836fd6f32dc31b4e7 (diff)
releasing version 2.0.5-3
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog7
-rw-r--r--debian/python-talloc-dev.lintian-overrides1
-rw-r--r--debian/python-talloc.lintian-overrides1
-rwxr-xr-xdebian/rules55
4 files changed, 22 insertions, 42 deletions
diff --git a/debian/changelog b/debian/changelog
index 1e91727..1c3cf28 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+talloc (2.0.5-3) unstable; urgency=low
+
+ * Switch to new style debhelper.
+ * Upload to unstable.
+
+ -- Jelmer Vernooij <jelmer@debian.org> Thu, 28 Jul 2011 16:22:52 +0200
+
talloc (2.0.5-2) experimental; urgency=low
* Switch to dh_python2.
diff --git a/debian/python-talloc-dev.lintian-overrides b/debian/python-talloc-dev.lintian-overrides
new file mode 100644
index 0000000..ed4653d
--- /dev/null
+++ b/debian/python-talloc-dev.lintian-overrides
@@ -0,0 +1 @@
+python-talloc-dev binary: wrong-section-according-to-package-name python-talloc-dev => python
diff --git a/debian/python-talloc.lintian-overrides b/debian/python-talloc.lintian-overrides
new file mode 100644
index 0000000..09fabcf
--- /dev/null
+++ b/debian/python-talloc.lintian-overrides
@@ -0,0 +1 @@
+python-talloc binary: package-name-doesnt-match-sonames libpytalloc-util2
diff --git a/debian/rules b/debian/rules
index 5abe59d..71469f2 100755
--- a/debian/rules
+++ b/debian/rules
@@ -21,67 +21,38 @@ conf_args += --libdir=/usr/lib/$(DEB_HOST_MULTIARCH)
export PYTHON=$(shell which `pyversions -r`)
export PYTHON_CONFIG=$(shell which `pyversions -r`-config)
-configure: configure-stamp
-configure-stamp:
- dh_testdir
+%:
+ dh $*
+
+override_dh_auto_configure:
CFLAGS="$(CFLAGS)" ./configure $(conf_args)
- touch configure-stamp
-build: configure build-stamp
-build-stamp:
- dh_testdir
+override_dh_auto_build:
$(MAKE) all
+
+override_dh_auto_test:
ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
LD_LIBRARY_PATH=bin/shared ./bin/talloc_testsuite
endif
- touch build-stamp
get-orig-source:
./debian/build-orig.sh
-clean:
- dh_testdir
- dh_testroot
- rm -f build-stamp configure-stamp
+override_dh_auto_clean:
[ ! -f Makefile ] || $(MAKE) distclean
rm -f buildtools/wafsamba/*.pyc
rm -rf buildtools/bin/.waf*
- dh_clean
-install: build
- dh_testdir
- dh_testroot
- dh_prep
- dh_installdirs
+override_dh_auto_install:
mkdir -p $(DESTDIR)`swig -swiglib`
$(MAKE) install DESTDIR=$(DESTDIR)
# Waf really should be doing this:
ar -rc libtalloc.a bin/default/talloc_*.o
cp libtalloc.a $(DESTDIR)/usr/lib/$(DEB_HOST_MULTIARCH)
- dh_install --list-missing --fail-missing --sourcedir=$(DESTDIR)
-
-# Build architecture-dependent files here.
-# Pass -a to all debhelper commands in this target to reduce clutter.
-binary-arch: DH_OPTIONS=-a
-binary-arch: build install
- dh_testdir
- dh_testroot
- dh_installdocs
- dh_installchangelogs
+
+override_dh_strip:
dh_strip -plibtalloc2 --dbg-package=libtalloc2-dbg
dh_strip -ppython-talloc --dbg-package=python-talloc-dbg
- dh_link
- dh_compress
- dh_fixperms
- dh_makeshlibs -- -c4
- dh_python2
- dh_installdeb
- dh_shlibdeps
- dh_gencontrol
- dh_md5sums
- dh_builddeb
-
-binary-indep:
-binary: binary-arch binary-indep
-.PHONY: build clean binary-arch binary install configure
+override_dh_makeshlibs:
+ dh_makeshlibs -- -c4