summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarlos Pascual <cpascual@cells.es>2019-02-05 16:12:10 +0100
committerCarlos Pascual <cpascual@cells.es>2019-02-05 16:12:10 +0100
commit0d8f10aa974bef5196b13cb513ece1d58861cdf5 (patch)
treea5f12ba669f87e8c1b1c68f94742060146143ece
parent97ef716da6d9f5f4d7d4649782e93d49e9ddb4e4 (diff)
Revert "Disable creation of python3-taurus (to avoid delays in buster queue)"
This reverts commit c29930afb8f411b96986e3e2280eb229bef60e20.
-rw-r--r--debian/control46
-rw-r--r--debian/python3-taurus.links13
-rwxr-xr-xdebian/rules3
3 files changed, 61 insertions, 1 deletions
diff --git a/debian/control b/debian/control
index 853d30fc..294605b8 100644
--- a/debian/control
+++ b/debian/control
@@ -23,6 +23,22 @@ Build-Depends: debhelper (>= 9),
python-sphinx-rtd-theme,
python-spyder,
python-tango,
+ python3-all,
+ python3-future,
+ python3-guiqwt,
+ python3-h5py,
+ python3-lxml,
+ python3-numpy,
+ python3-pint,
+ python3-ply,
+ python3-pymca5,
+ python3-pyqt5,
+ python3-pyqt5.qtopengl,
+ python3-setuptools,
+ python3-sphinx,
+ python3-sphinx-rtd-theme,
+ python3-spyder,
+ python3-tango,
qttools5-dev-tools,
rdfind,
sphinx-common,
@@ -65,6 +81,36 @@ Description: Framework for scientific/industrial CLIs and GUIs - Python2
.
This is the Python 2 version of the package.
+Package: python3-taurus
+Architecture: all
+Section: python
+Depends: ${misc:Depends},
+ ${python3:Depends},
+ python3-future,
+ python3-guiqwt,
+ python3-h5py,
+ python3-lxml,
+ python3-numpy,
+ python3-pint,
+ python3-ply,
+ python3-pyqt5,
+ python3-pyqt5.qtopengl,
+ python3-setuptools,
+ python3-spyder,
+ python3-tango
+Recommends: python3-pymca5,
+ qttools5-dev-tools,
+ python
+Suggests: python-taurus-doc
+Provides: ${python3:Provides}
+Description: Framework for scientific/industrial CLIs and GUIs - Python3
+ Taurus is a Python framework for control and data acquisition CLIs
+ and GUIs in scientific/industrial environments. It supports multiple
+ control systems or data sources: Tango, EPICS, ... New control
+ system libraries can be integrated through plugins.
+ .
+ This is the Python 3 version of the package.
+
Package: python-taurus-doc
Architecture: all
Section: doc
diff --git a/debian/python3-taurus.links b/debian/python3-taurus.links
new file mode 100644
index 00000000..b0e56fc3
--- /dev/null
+++ b/debian/python3-taurus.links
@@ -0,0 +1,13 @@
+usr/share/python3-taurus/scripts/taurusconfigbrowser usr/bin/taurusconfigbrowser3
+usr/share/python3-taurus/scripts/tauruscurve usr/bin/tauruscurve3
+usr/share/python3-taurus/scripts/taurusdemo usr/bin/taurusdemo3
+usr/share/python3-taurus/scripts/taurusdesigner usr/bin/taurusdesigner3
+usr/share/python3-taurus/scripts/taurusdevicepanel usr/bin/taurusdevicepanel3
+usr/share/python3-taurus/scripts/taurusform usr/bin/taurusform3
+usr/share/python3-taurus/scripts/taurusgui usr/bin/taurusgui3
+usr/share/python3-taurus/scripts/taurusiconcatalog usr/bin/taurusiconcatalog3
+usr/share/python3-taurus/scripts/taurusimage usr/bin/taurusimage3
+usr/share/python3-taurus/scripts/tauruspanel usr/bin/tauruspanel3
+usr/share/python3-taurus/scripts/taurustestsuite usr/bin/taurustestsuite3
+usr/share/python3-taurus/scripts/taurustrend1d usr/bin/taurustrend1d3
+usr/share/python3-taurus/scripts/taurustrend2d usr/bin/taurustrend2d3
diff --git a/debian/rules b/debian/rules
index aa1b18a2..97adbf97 100755
--- a/debian/rules
+++ b/debian/rules
@@ -3,9 +3,10 @@
export PYBUILD_NAME=taurus
export PYBUILD_AFTER_INSTALL=dh_numpy
export PYBUILD_DISABLE=test
+export PYBUILD_INSTALL_ARGS_python3=--install-scripts=/usr/share/python3-taurus/scripts/
%:
- dh $@ --with python2,sphinxdoc --buildsystem=pybuild
+ dh $@ --with python2,python3,sphinxdoc --buildsystem=pybuild
override_dh_sphinxdoc:
ifeq (,$(findstring nodocs, $(DEB_BUILD_OPTIONS)))