summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorcpascual <cpascual@cells.es>2016-02-29 15:22:01 +0100
committercpascual <cpascual@cells.es>2016-02-29 15:22:01 +0100
commit1bff809b503bfca25c038c8f9195a4dde302c92c (patch)
tree1b42237322dd106b0a4550b1c3c464355330fcb3 /setup.py
parent8ebd1b46e6fe8ca0d56cc4a41449eb14a7968745 (diff)
Apply autopep8 for W291,W293
(pep8)cpascual@pc218:~/src/taurus(taurus4-preview)$ flake8 -qq --count --statistics lib doc scripts setup.py --exclude="lib/taurus/external/*" 8 E111 indentation is not a multiple of four 1 E124 closing bracket does not match visual indentation 2 E127 continuation line over-indented for visual indent 800 E265 block comment should start with '# ' 2819 E501 line too long (81 > 79 characters) 7 E712 comparison to True should be 'if cond is True:' or 'if cond:' 10 E713 test for membership should be 'not in' 29 E714 test for object identity should be 'is not' 5 E721 do not compare types, use 'isinstance()' 149 F401 '__qt' imported but unused 165 F403 'from core.taurushelper import *' used; unable to detect undefined names 7 F811 redefinition of unused 'sys' from line 32 4 F812 list comprehension redefines 'row' from line 378 29 F821 undefined name 'self' 5 F822 undefined name 'TaurusNexusBrowser' in __all__ 93 F841 local variable 'ok' is assigned to but never used 776 W291 trailing whitespace 64 W293 blank line contains whitespace 42 W601 .has_key() is deprecated, use 'in' 18 W602 deprecated form of raising exception 5033 cpascual@pc218:~/src/taurus(taurus4-preview)$ devenv python lib/taurus/test/testsuite.py (...) Ran 558 tests in 41.833s OK (skipped=10) (pep8)cpascual@pc218:~/src/taurus(taurus4-preview)$ autopep8 -a -a -irv --select="W291,W293" --exclude="*/taurus/external/*" lib doc scripts setup.py (pep8)cpascual@pc218:~/src/taurus(taurus4-preview)$ flake8 -qq --count --statistics lib doc scripts setup. 8 E111 indentation is not a multiple of four 1 E124 closing bracket does not match visual indentation 2 E127 continuation line over-indented for visual indent 800 E265 block comment should start with '# ' 2819 E501 line too long (81 > 79 characters) 7 E712 comparison to True should be 'if cond is True:' or 'if cond:' 10 E713 test for membership should be 'not in' 29 E714 test for object identity should be 'is not' 5 E721 do not compare types, use 'isinstance()' 149 F401 '__qt' imported but unused 165 F403 'from core.taurushelper import *' used; unable to detect undefined names 7 F811 redefinition of unused 'sys' from line 32 4 F812 list comprehension redefines 'row' from line 378 29 F821 undefined name 'self' 5 F822 undefined name 'TaurusNexusBrowser' in __all__ 93 F841 local variable 'ok' is assigned to but never used 42 W601 .has_key() is deprecated, use 'in' 18 W602 deprecated form of raising exception 4193 cpascual@pc218:~/src/taurus(taurus4-preview)$ devenv python lib/taurus/test/testsuite.py (...) Ran 558 tests in 40.323s OK (skipped=10)
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py8
1 files changed, 4 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index aaf07c62..e77a79e6 100644
--- a/setup.py
+++ b/setup.py
@@ -587,11 +587,11 @@ class install_html(Command):
class install_scripts(dftinstall_scripts):
- '''Customization to create .bat wrappers for the scripts
+ '''Customization to create .bat wrappers for the scripts
when installing on windows.
Adapted from a recipe by Matthew Brett (who licensed it under CC0):
https://github.com/matthew-brett/myscripter/blob/master/setup.py
- See rationale in:
+ See rationale in:
http://matthew-brett.github.io/pydagogue/installing_scripts.html
'''
@@ -791,7 +791,7 @@ if sphinx:
from sphinx.setup_command import BuildDoc
class build_catalog(object):
- '''builds an html catalog of icons. It links to png thumbnails that are
+ '''builds an html catalog of icons. It links to png thumbnails that are
created in the _static dir
'''
@@ -918,7 +918,7 @@ if sphinx:
@staticmethod
def _zipdir(basedir, archivename):
- '''function to zip the contents of basedir into archivename.
+ '''function to zip the contents of basedir into archivename.
Adapted from: http://stackoverflow.com/questions/296499
'''
from zipfile import ZipFile, ZIP_DEFLATED