summaryrefslogtreecommitdiff
path: root/taurus
diff options
context:
space:
mode:
authorcpascual <cpascual@cells.es>2015-02-04 15:08:26 +0100
committercpascual <cpascual@cells.es>2015-02-04 15:08:48 +0100
commit23f9ffec53ea7adfe78d6108f44852ae78cbe2be (patch)
tree293d72f36ac6d591e103eb700b941d6bc54eed17 /taurus
parentddc60eb3ed138b95f1ea18137a0da5b1bb612f51 (diff)
Install ui dirs as package_data instead of packages
"ui" dirs are treated by setup.py as packages (submodules) and installed as such. This forces the ui dir to have a __ini__.py file. This was necessary when ui dirs also contained compiled ui_*.py files, but since SEP11 it is no longer the case. Therefore, remove all __init__.py files from ui dirs and install the ui dirs as package_data instead of packages. Also force the ui files to be added explicitly.
Diffstat (limited to 'taurus')
-rw-r--r--taurus/lib/taurus/qt/qtgui/extra_guiqwt/ui/__init__.py29
-rw-r--r--taurus/lib/taurus/qt/qtgui/panel/report/ui/__init__.py0
-rw-r--r--taurus/lib/taurus/qt/qtgui/panel/ui/__init__.py29
-rw-r--r--taurus/lib/taurus/qt/qtgui/plot/ui/__init__.py29
-rw-r--r--taurus/lib/taurus/qt/qtgui/taurusgui/ui/__init__.py28
-rw-r--r--taurus/lib/taurus/qt/qtgui/ui/__init__.py28
-rw-r--r--taurus/setup.py27
7 files changed, 12 insertions, 158 deletions
diff --git a/taurus/lib/taurus/qt/qtgui/extra_guiqwt/ui/__init__.py b/taurus/lib/taurus/qt/qtgui/extra_guiqwt/ui/__init__.py
deleted file mode 100644
index 208f8eb3..00000000
--- a/taurus/lib/taurus/qt/qtgui/extra_guiqwt/ui/__init__.py
+++ /dev/null
@@ -1,29 +0,0 @@
-#!/usr/bin/env python
-
-#############################################################################
-##
-## This file is part of Taurus, a Tango User Interface Library
-##
-## http://www.tango-controls.org/static/taurus/latest/doc/html/index.html
-##
-## Copyright 2011 CELLS / ALBA Synchrotron, Bellaterra, Spain
-##
-## Taurus is free software: you can redistribute it and/or modify
-## it under the terms of the GNU Lesser General Public License as published by
-## the Free Software Foundation, either version 3 of the License, or
-## (at your option) any later version.
-##
-## Taurus is distributed in the hope that it will be useful,
-## but WITHOUT ANY WARRANTY; without even the implied warranty of
-## MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-## GNU Lesser General Public License for more details.
-##
-## You should have received a copy of the GNU Lesser General Public License
-## along with Taurus. If not, see <http://www.gnu.org/licenses/>.
-##
-#############################################################################
-
-"""
-__init__.py:
-"""
-
diff --git a/taurus/lib/taurus/qt/qtgui/panel/report/ui/__init__.py b/taurus/lib/taurus/qt/qtgui/panel/report/ui/__init__.py
deleted file mode 100644
index e69de29b..00000000
--- a/taurus/lib/taurus/qt/qtgui/panel/report/ui/__init__.py
+++ /dev/null
diff --git a/taurus/lib/taurus/qt/qtgui/panel/ui/__init__.py b/taurus/lib/taurus/qt/qtgui/panel/ui/__init__.py
deleted file mode 100644
index 208f8eb3..00000000
--- a/taurus/lib/taurus/qt/qtgui/panel/ui/__init__.py
+++ /dev/null
@@ -1,29 +0,0 @@
-#!/usr/bin/env python
-
-#############################################################################
-##
-## This file is part of Taurus, a Tango User Interface Library
-##
-## http://www.tango-controls.org/static/taurus/latest/doc/html/index.html
-##
-## Copyright 2011 CELLS / ALBA Synchrotron, Bellaterra, Spain
-##
-## Taurus is free software: you can redistribute it and/or modify
-## it under the terms of the GNU Lesser General Public License as published by
-## the Free Software Foundation, either version 3 of the License, or
-## (at your option) any later version.
-##
-## Taurus is distributed in the hope that it will be useful,
-## but WITHOUT ANY WARRANTY; without even the implied warranty of
-## MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-## GNU Lesser General Public License for more details.
-##
-## You should have received a copy of the GNU Lesser General Public License
-## along with Taurus. If not, see <http://www.gnu.org/licenses/>.
-##
-#############################################################################
-
-"""
-__init__.py:
-"""
-
diff --git a/taurus/lib/taurus/qt/qtgui/plot/ui/__init__.py b/taurus/lib/taurus/qt/qtgui/plot/ui/__init__.py
deleted file mode 100644
index 208f8eb3..00000000
--- a/taurus/lib/taurus/qt/qtgui/plot/ui/__init__.py
+++ /dev/null
@@ -1,29 +0,0 @@
-#!/usr/bin/env python
-
-#############################################################################
-##
-## This file is part of Taurus, a Tango User Interface Library
-##
-## http://www.tango-controls.org/static/taurus/latest/doc/html/index.html
-##
-## Copyright 2011 CELLS / ALBA Synchrotron, Bellaterra, Spain
-##
-## Taurus is free software: you can redistribute it and/or modify
-## it under the terms of the GNU Lesser General Public License as published by
-## the Free Software Foundation, either version 3 of the License, or
-## (at your option) any later version.
-##
-## Taurus is distributed in the hope that it will be useful,
-## but WITHOUT ANY WARRANTY; without even the implied warranty of
-## MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-## GNU Lesser General Public License for more details.
-##
-## You should have received a copy of the GNU Lesser General Public License
-## along with Taurus. If not, see <http://www.gnu.org/licenses/>.
-##
-#############################################################################
-
-"""
-__init__.py:
-"""
-
diff --git a/taurus/lib/taurus/qt/qtgui/taurusgui/ui/__init__.py b/taurus/lib/taurus/qt/qtgui/taurusgui/ui/__init__.py
deleted file mode 100644
index a18b97e0..00000000
--- a/taurus/lib/taurus/qt/qtgui/taurusgui/ui/__init__.py
+++ /dev/null
@@ -1,28 +0,0 @@
-#!/usr/bin/env python
-
-#############################################################################
-##
-## This file is part of Taurus, a Tango User Interface Library
-##
-## http://www.tango-controls.org/static/taurus/latest/doc/html/index.html
-##
-## Copyright 2011 CELLS / ALBA Synchrotron, Bellaterra, Spain
-##
-## Taurus is free software: you can redistribute it and/or modify
-## it under the terms of the GNU Lesser General Public License as published by
-## the Free Software Foundation, either version 3 of the License, or
-## (at your option) any later version.
-##
-## Taurus is distributed in the hope that it will be useful,
-## but WITHOUT ANY WARRANTY; without even the implied warranty of
-## MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-## GNU Lesser General Public License for more details.
-##
-## You should have received a copy of the GNU Lesser General Public License
-## along with Taurus. If not, see <http://www.gnu.org/licenses/>.
-##
-###########################################################################
-
-"""This package provides configurations for specific GUIs based on TaurusGui"""
-
-__docformat__ = 'restructuredtext'
diff --git a/taurus/lib/taurus/qt/qtgui/ui/__init__.py b/taurus/lib/taurus/qt/qtgui/ui/__init__.py
deleted file mode 100644
index a3027547..00000000
--- a/taurus/lib/taurus/qt/qtgui/ui/__init__.py
+++ /dev/null
@@ -1,28 +0,0 @@
-#!/usr/bin/env python
-
-#############################################################################
-##
-## This file is part of Taurus, a Tango User Interface Library
-##
-## http://www.tango-controls.org/static/taurus/latest/doc/html/index.html
-##
-## Copyright 2011 CELLS / ALBA Synchrotron, Bellaterra, Spain
-##
-## Taurus is free software: you can redistribute it and/or modify
-## it under the terms of the GNU Lesser General Public License as published by
-## the Free Software Foundation, either version 3 of the License, or
-## (at your option) any later version.
-##
-## Taurus is distributed in the hope that it will be useful,
-## but WITHOUT ANY WARRANTY; without even the implied warranty of
-## MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-## GNU Lesser General Public License for more details.
-##
-## You should have received a copy of the GNU Lesser General Public License
-## along with Taurus. If not, see <http://www.gnu.org/licenses/>.
-##
-#############################################################################
-
-"""
-__init__.py:
-"""
diff --git a/taurus/setup.py b/taurus/setup.py
index 7151c326..1e82e486 100644
--- a/taurus/setup.py
+++ b/taurus/setup.py
@@ -133,24 +133,19 @@ packages = [
'taurus.qt.qtgui.graphic.jdraw',
'taurus.qt.qtgui.graphic.jdraw.test.res',
'taurus.qt.qtgui.help',
- 'taurus.qt.qtgui.help.ui',
'taurus.qt.qtgui.image',
'taurus.qt.qtgui.input',
'taurus.qt.qtgui.model',
'taurus.qt.qtgui.panel',
'taurus.qt.qtgui.panel.test',
'taurus.qt.qtgui.panel.report',
- 'taurus.qt.qtgui.panel.report.ui',
- 'taurus.qt.qtgui.panel.ui',
'taurus.qt.qtgui.plot',
- 'taurus.qt.qtgui.plot.ui',
'taurus.qt.qtgui.resource',
# 'taurus.qt.qtgui.shell',
'taurus.qt.qtgui.style',
'taurus.qt.qtgui.table',
'taurus.qt.qtgui.taurusgui',
'taurus.qt.qtgui.taurusgui.conf',
- 'taurus.qt.qtgui.taurusgui.ui',
'taurus.qt.qtgui.tree',
'taurus.qt.qtgui.ui',
'taurus.qt.qtgui.util',
@@ -171,7 +166,6 @@ extra_packages = [
'taurus.qt.qtgui.extra_nexus',
'taurus.qt.qtgui.extra_xterm',
'taurus.qt.qtgui.extra_guiqwt',
- 'taurus.qt.qtgui.extra_guiqwt.ui',
'taurus.qt.qtgui.taurusgui.conf.tgconf_example01',
'taurus.qt.qtgui.taurusgui.conf.tgconf_macrogui',
@@ -208,13 +202,23 @@ package_data = {
'taurus.qt.qtgui.resource' : ['*.rcc'],
'taurus.qt.qtgui.util' : ['tauruswidget_template',
'tauruswidget_qtdesignerplugin_template'],
- 'taurus.qt.qtgui.util.test.test_ui' : ['ui/*', 'ui/mywidget2/*'],
'taurus.qt.uic' : ['pyuic4/*'],
'taurus.qt.qtgui.taurusgui.conf.tgconf_example01' : ['images/*'],
'taurus.qt.qtgui.button.test' : ['res/*'],
- 'taurus.qt.qtgui.graphic.jdraw.test' : ['res/*']
+ 'taurus.qt.qtgui.graphic.jdraw.test' : ['res/*'],
+
+ 'taurus.qt.qtgui.help': ['ui/*.ui'],
+ 'taurus.qt.qtgui.panel.report': ['ui/*.ui'],
+ 'taurus.qt.qtgui.panel': ['ui/*.ui'],
+ 'taurus.qt.qtgui.plot': ['ui/*.ui'],
+ 'taurus.qt.qtgui.taurusgui': ['ui/*.ui'],
+ 'taurus.qt.qtgui.extra_guiqwt': ['ui/*.ui'],
+ 'taurus.qt.qtgui.util.test.test_ui' : ['ui/*.ui', 'ui/mywidget2/*.ui'],
}
+
+
+
# The files listed here will be made executable when installed.
# The file names are relative to the dir containing setup.py
# Note: They must also be listed in packages or package_data
@@ -462,13 +466,6 @@ class build(dftbuild):
resource_package_data = self.get_extra_resource_package_data()
package_data['taurus.qt.qtgui.resource'].extend(resource_package_data)
- for package in packages:
- if package.endswith(".ui"):
- pdata = package_data.get(package)
- if pdata is None:
- package_data[package] = pdata = []
- pdata.append("*.ui")
-
def build_jdraw(self):
print("Building jdraw grammar...", end='')
taurus_dir = abspath('lib')