summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Izquierdo (mariodebian) <mariodebian@gmail.com>2008-08-06 18:23:04 +0000
committerMario Izquierdo (mariodebian) <mariodebian@gmail.com>2008-08-06 18:23:04 +0000
commit1f2f57307597e24446e0bebd83a486afd56d84ca (patch)
tree41c530bd2d67d4c8dcea4af69fcc0251599e40b0
parent757531753e17eed0d7e9ce90dce79536a7bb77a0 (diff)
initramfs-tools-tcos (0.89.5)
* tmixer/Makefile - Disable '-ansi -pedantic' compile flags (Debian Etch libasound2-dev don't like it) git-svn-id: http://tcosproject.org/svn/tcos/trunk/initramfs-tools-tcos@947 97557d6f-af72-4ac7-98cc-18709f36555f
-rw-r--r--debian/changelog4
-rw-r--r--tmixer/Makefile10
2 files changed, 12 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 64e8276..8f0560d 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -8,8 +8,10 @@ initramfs-tools-tcos (0.89.5) unstable; urgency=low
* Update Debian testing default kernel to 2.6.25-2-486
* xmlrpc/tcosxmlrpc.c
- Fix typo adding method tcos_tnc in OLD API
+ * tmixer/Makefile
+ - Disable '-ansi -pedantic' compile flags (Debian Etch libasound2-dev don't like it)
- -- Mario Izquierdo (mariodebian) <mariodebian@gmail.com> Wed, 06 Aug 2008 20:03:40 +0200
+ -- Mario Izquierdo (mariodebian) <mariodebian@gmail.com> Wed, 06 Aug 2008 20:21:58 +0200
initramfs-tools-tcos (0.89.4) unstable; urgency=low
diff --git a/tmixer/Makefile b/tmixer/Makefile
index ef83341..17a9d8a 100644
--- a/tmixer/Makefile
+++ b/tmixer/Makefile
@@ -1,9 +1,12 @@
-CFLAGS = -g -O2 -Wall -ansi -pedantic -std=c99 -DTCOS_VERSION="\"$(VERSION)\""
+DEBUGCFLAGS = -g -O2 -Wall -ansi -pedantic -std=c99 -DTCOS_VERSION="\"$(VERSION)\""
+CFLAGS = -g -O2 -Wall -DTCOS_VERSION="\"$(VERSION)\""
LDADD = -lasound
bin_PROGRAMS = tmixer
TMIXER_SOURCES= tmixer-alsa.c tmixer-oss.c
CC=gcc
+all: tmixer
+
tmixer: tmixer.c tmixer-oss.c tmixer-oss.h tmixer-alsa.c tmixer-alsa.h
$(CC) -o $(bin_PROGRAMS) tmixer.c $(LDADD) $(CFLAGS)
@@ -14,6 +17,11 @@ tmixer-oss: tmixer-oss.c tmixer-oss.h
$(CC) -o $(bin_PROGRAMS) tmixer-oss.c $(LDADD) $(CFLAGS)
+debug: tmixer.c tmixer-oss.c tmixer-oss.h tmixer-alsa.c tmixer-alsa.h
+ $(CC) -o $(bin_PROGRAMS) tmixer.c $(LDADD) $(DEBUGCFLAGS)
+
+
+
include ../common.mk
clean: