summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJelmer Vernooij <jelmer@jelmer.uk>2015-11-17 00:58:02 +0000
committerJelmer Vernooij <jelmer@samba.org>2015-11-17 01:01:02 +0000
commit474773040f94331ec6ec575bcf0ec9351b273233 (patch)
tree45de9c613e1618ac50fb2affc7790f281550c47a
parent8014e9ca812baec9ed7956f3edc295fd423bb458 (diff)
releasing package tevent version 0.9.26-2
-rw-r--r--debian/changelog2
-rw-r--r--debian/patches/01_fix_ld_library_path4
-rwxr-xr-xwscript3
3 files changed, 6 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index 8d789cb..abc2367 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,4 +1,4 @@
-tevent (0.9.26-2) UNRELEASED; urgency=medium
+tevent (0.9.26-2) unstable; urgency=medium
* Set LD_LIBRARY_PATH during tests. Fixes FTBFS. Closes: #805319
diff --git a/debian/patches/01_fix_ld_library_path b/debian/patches/01_fix_ld_library_path
index b6cd82e..3b3512f 100644
--- a/debian/patches/01_fix_ld_library_path
+++ b/debian/patches/01_fix_ld_library_path
@@ -1,7 +1,7 @@
diff --git a/lib/tevent/wscript b/lib/tevent/wscript
index 4c5fe0c..73871d8 100755
---- a/lib/tevent/wscript
-+++ b/lib/tevent/wscript
+--- a/wscript
++++ b/wscript
@@ -133,6 +133,9 @@ def test(ctx):
'''test tevent'''
print("The tevent testsuite is part of smbtorture in samba4")
diff --git a/wscript b/wscript
index 4c5fe0c..73871d8 100755
--- a/wscript
+++ b/wscript
@@ -133,6 +133,9 @@ def test(ctx):
'''test tevent'''
print("The tevent testsuite is part of smbtorture in samba4")
+ samba_utils.ADD_LD_LIBRARY_PATH('bin/shared')
+ samba_utils.ADD_LD_LIBRARY_PATH('bin/shared/private')
+
pyret = samba_utils.RUN_PYTHON_TESTS(['bindings.py'])
sys.exit(pyret)