summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRuss Allbery <rra@debian.org>2016-08-14 14:14:47 -0700
committerRuss Allbery <rra@debian.org>2018-05-26 19:03:58 -0700
commita10a4cc3c3d7c396a01608c8e1489621b54362e6 (patch)
tree5617554c7df3171434c708d3a2d96a9e19997468
parentc4621fa6cda58550f299fc732c77dcf3b50c05d9 (diff)
Fix library install path
The upstream top-level configure script doesn't correctly handle --program-suffix without this tweak. Gbp-Pq: Name 0006-Fix-library-install-path.patch
-rw-r--r--configure.in5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index e783564..c938531 100644
--- a/configure.in
+++ b/configure.in
@@ -599,13 +599,13 @@ fi
dnl The "right" way of using program_transform_name, program_prefix, and
dnl program_suffix expects you to use AC_ARG_PROGRAM here and do transformation
dnl in the Makefile, but we want the values now, so we do it ourselves.
-EXENAME="tf"
+EXENAME="tf" PROGNAME="tf"
test "${program_prefix}" != "NONE" && EXENAME="${program_prefix}${EXENAME}"
test "${program_suffix}" != "NONE" && EXENAME="${EXENAME}${program_suffix}"
if test "${program_transform_name}" != "NONE"; then
EXENAME=`echo "${EXENAME}" | sed "${program_transform_name}"`
fi
-LIBNAME="${EXENAME}-lib"
+LIBNAME="${PROGNAME}-lib"
if test "$enable_symlink" = "no"; then
SYMLINK=""
@@ -616,6 +616,7 @@ else
fi
AC_SUBST(EXENAME)
+AC_SUBST(PROGNAME)
AC_SUBST(LIBNAME)
AC_SUBST(SYMLINK)