summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBardur Arantsson <bardur@scientician.net>2013-03-24 18:14:18 +0100
committerBardur Arantsson <bardur@scientician.net>2013-09-27 14:46:40 +0200
commit7ab6f5007e8a4db9f2f19fd9a88347adfc36dcd9 (patch)
treee3bc7a6aad3e7a4447947700503e9b9225c05da4
parentad687f1dab21fee379ccf70fbe4fc27c2e66409f (diff)
Split Thrain quest from plots.c
-rw-r--r--src/CMakeLists.txt2
-rw-r--r--src/plots.c1
-rw-r--r--src/plots.h1
-rw-r--r--src/q_thrain.c5
-rw-r--r--src/q_thrain.h13
-rw-r--r--src/tables.c1
6 files changed, 19 insertions, 4 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index a5316cb4..bd706b04 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -10,7 +10,7 @@ SET(SRCS
z-rand.c z-util.c z-form.c z-virt.c z-term.c
variable.c tables.c plots.c util.c cave.c dungeon.c
melee1.c melee2.c messages.c modules.c
- q_god.c q_library.c q_fireprof.c q_bounty.c
+ q_god.c q_library.c q_fireprof.c q_bounty.c q_thrain.c
object1.c object2.c randart.c squeltch.cc traps.c
monster1.c monster2.c monster3.c
xtra1.c xtra2.c skills.c powers.c gods.c
diff --git a/src/plots.c b/src/plots.c
index 668d04ce..db0d1096 100644
--- a/src/plots.c
+++ b/src/plots.c
@@ -397,4 +397,3 @@ bool_ quest_null_hook(int q)
/*************************** Other plot ***************************/
#include "q_narsil.c"
-#include "q_thrain.c"
diff --git a/src/plots.h b/src/plots.h
index df3cc927..7b2396ec 100644
--- a/src/plots.h
+++ b/src/plots.h
@@ -45,7 +45,6 @@ extern bool_ quest_evil_init_hook(int q_idx);
/******* Plot Other *********/
extern bool_ quest_narsil_init_hook(int q_idx);
-extern bool_ quest_thrain_init_hook(int q_idx);
/******* Plot God Quest **************/
extern bool_ quest_god_describe(FILE *);
diff --git a/src/q_thrain.c b/src/q_thrain.c
index 6180706c..1b505a20 100644
--- a/src/q_thrain.c
+++ b/src/q_thrain.c
@@ -1,4 +1,7 @@
-#undef cquest
+#include "q_thrain.h"
+#include "quark.h"
+#include "messages.h"
+
#define cquest (quest[QUEST_THRAIN])
bool_ quest_thrain_death_hook(char *fmt)
diff --git a/src/q_thrain.h b/src/q_thrain.h
new file mode 100644
index 00000000..04c85823
--- /dev/null
+++ b/src/q_thrain.h
@@ -0,0 +1,13 @@
+#pragma once
+
+#include "angband.h"
+
+#ifdef __cplusplus
+extern "C" {
+#endif
+
+extern bool_ quest_thrain_init_hook(int q_idx);
+
+#ifdef __cplusplus
+} // extern "C"
+#endif
diff --git a/src/tables.c b/src/tables.c
index 82ccdb9e..a391e7d5 100644
--- a/src/tables.c
+++ b/src/tables.c
@@ -14,6 +14,7 @@
#include "q_library.h"
#include "q_fireprof.h"
#include "q_bounty.h"
+#include "q_thrain.h"