summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBardur Arantsson <bardur@scientician.net>2015-03-07 16:55:41 +0100
committerBardur Arantsson <bardur@scientician.net>2015-03-07 16:55:41 +0100
commit72ceb4f2aba3b86be43ba9a7cb5c576b79920543 (patch)
treee353c73e2f2dd75537370e1130a7303a549d5861
parent09f4a4cea91c4cb80f987ad903c3d2748fa73e8c (diff)
Split option variables into separate header and source file
Remove unused testing_stack testing_carry options while we're at it.
-rw-r--r--src/CMakeLists.txt2
-rw-r--r--src/cave.cc1
-rw-r--r--src/cmd1.cc1
-rw-r--r--src/cmd2.cc1
-rw-r--r--src/cmd3.cc1
-rw-r--r--src/cmd6.cc1
-rw-r--r--src/cmd7.cc1
-rw-r--r--src/dungeon.cc1
-rw-r--r--src/externs.h54
-rw-r--r--src/files.cc1
-rw-r--r--src/generate.cc1
-rw-r--r--src/melee1.cc35
-rw-r--r--src/melee2.cc11
-rw-r--r--src/monster2.cc1
-rw-r--r--src/object1.cc1
-rw-r--r--src/object2.cc3
-rw-r--r--src/options.cc69
-rw-r--r--src/options.hpp71
-rw-r--r--src/powers.cc1
-rw-r--r--src/q_ultrag.cc1
-rw-r--r--src/randart.cc1
-rw-r--r--src/spells1.cc1
-rw-r--r--src/spells2.cc1
-rw-r--r--src/spells4.cc1
-rw-r--r--src/store.cc1
-rw-r--r--src/tables.cc12
-rw-r--r--src/util.cc1
-rw-r--r--src/variable.cc86
-rw-r--r--src/wild.cc1
-rw-r--r--src/xtra1.cc1
-rw-r--r--src/xtra2.cc1
31 files changed, 167 insertions, 198 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 9573fe7d..346677b7 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -21,7 +21,7 @@ SET(SRCS_COMMON
xtra1.cc xtra2.cc skills.cc powers.cc gods.cc
spells1.cc spells2.cc spells3.cc spells4.cc spells5.cc spells6.cc
spell_type.cc device_allocation.cc
- corrupt.cc joke.cc mimic.cc
+ corrupt.cc joke.cc mimic.cc options.cc
status.cc files.cc notes.cc loadsave.cc
cmd1.cc cmd2.cc cmd3.cc cmd4.cc cmd5.cc cmd6.cc cmd7.cc
help.cc hiscore.cc range.cc dice.cc
diff --git a/src/cave.cc b/src/cave.cc
index e648d57e..5a38e7d6 100644
--- a/src/cave.cc
+++ b/src/cave.cc
@@ -2,6 +2,7 @@
#include "angband.h"
#include "monster2.hpp"
+#include "options.hpp"
#include "q_rand.h"
#include "spells1.hpp"
#include "util.hpp"
diff --git a/src/cmd1.cc b/src/cmd1.cc
index e9c8c66a..5b1e4562 100644
--- a/src/cmd1.cc
+++ b/src/cmd1.cc
@@ -23,6 +23,7 @@
#include "monster3.hpp"
#include "object1.hpp"
#include "object2.hpp"
+#include "options.hpp"
#include "quark.h"
#include "skills.hpp"
#include "spells1.hpp"
diff --git a/src/cmd2.cc b/src/cmd2.cc
index e9ab62e6..454c9a00 100644
--- a/src/cmd2.cc
+++ b/src/cmd2.cc
@@ -20,6 +20,7 @@
#include "monster3.hpp"
#include "object1.hpp"
#include "object2.hpp"
+#include "options.hpp"
#include "skills.hpp"
#include "spells1.hpp"
#include "spells2.hpp"
diff --git a/src/cmd3.cc b/src/cmd3.cc
index c5ef2cb0..43950710 100644
--- a/src/cmd3.cc
+++ b/src/cmd3.cc
@@ -15,6 +15,7 @@
#include "monster1.hpp"
#include "object1.hpp"
#include "object2.hpp"
+#include "options.hpp"
#include "quark.h"
#include "squeltch.hpp"
#include "store.hpp"
diff --git a/src/cmd6.cc b/src/cmd6.cc
index 089b6bf5..6b6d5705 100644
--- a/src/cmd6.cc
+++ b/src/cmd6.cc
@@ -20,6 +20,7 @@
#include "monster2.hpp"
#include "object1.hpp"
#include "object2.hpp"
+#include "options.hpp"
#include "randart.hpp"
#include "skills.hpp"
#include "spell_type.hpp"
diff --git a/src/cmd7.cc b/src/cmd7.cc
index 01e94cb3..2228132e 100644
--- a/src/cmd7.cc
+++ b/src/cmd7.cc
@@ -19,6 +19,7 @@
#include "monster2.hpp"
#include "object1.hpp"
#include "object2.hpp"
+#include "options.hpp"
#include "quark.h"
#include "skills.hpp"
#include "spells1.hpp"
diff --git a/src/dungeon.cc b/src/dungeon.cc
index ff113372..d2af3ef4 100644
--- a/src/dungeon.cc
+++ b/src/dungeon.cc
@@ -41,6 +41,7 @@
#include "notes.hpp"
#include "object1.hpp"
#include "object2.hpp"
+#include "options.hpp"
#include "powers.hpp"
#include "quest.h"
#include "quark.h"
diff --git a/src/externs.h b/src/externs.h
index 281ffa0e..90d1f310 100644
--- a/src/externs.h
+++ b/src/externs.h
@@ -166,66 +166,12 @@ extern int artifact_bias;
extern FILE *text_out_file;
extern void (*text_out_hook)(byte a, cptr str);
extern int text_out_indent;
-extern bool_ rogue_like_commands;
-extern bool_ quick_messages;
-extern bool_ carry_query_flag;
-extern bool_ always_pickup;
-extern bool_ prompt_pickup_heavy;
-extern bool_ always_repeat;
-extern bool_ use_old_target;
-extern bool_ hilite_player;
-extern bool_ ring_bell;
-extern bool_ find_ignore_stairs;
-extern bool_ find_ignore_doors;
-extern bool_ find_cut;
-extern bool_ find_examine;
-extern bool_ disturb_near;
-extern bool_ disturb_move;
-extern bool_ disturb_panel;
-extern bool_ disturb_detect;
-extern bool_ disturb_state;
-extern bool_ disturb_minor;
-extern bool_ disturb_other;
-extern bool_ avoid_abort;
-extern bool_ avoid_shimmer;
-extern bool_ avoid_other;
-extern bool_ flush_disturb;
-extern bool_ flush_failure;
-extern bool_ flush_command;
-extern bool_ fresh_before;
-extern bool_ fresh_after;
-extern bool_ fresh_message;
-extern bool_ alert_hitpoint;
-extern bool_ alert_failure;
-extern bool_ view_yellow_lite;
-extern bool_ view_bright_lite;
-extern bool_ view_granite_lite;
-extern bool_ view_special_lite;
-extern bool_ wear_confirm;
-extern bool_ confirm_stairs;
-extern bool_ disturb_pets;
-extern bool_ view_perma_grids;
-extern bool_ view_torch_grids;
-extern bool_ flow_by_sound;
-extern bool_ view_reduce_lite;
-extern bool_ auto_scum;
-extern bool_ expand_look;
-extern bool_ expand_list;
-extern bool_ dungeon_align;
-extern bool_ dungeon_stair;
-extern bool_ smart_learn;
-extern bool_ testing_stack;
-extern bool_ testing_carry;
extern bool_ cheat_peek;
extern bool_ cheat_hear;
extern bool_ cheat_room;
extern bool_ cheat_xtra;
extern bool_ cheat_know;
extern bool_ cheat_live;
-extern bool_ last_words; /* Zangband options */
-extern bool_ small_levels;
-extern bool_ empty_levels;
-extern bool_ always_small_level;
extern byte hitpoint_warn;
extern byte delay_factor;
extern s16b autosave_freq;
diff --git a/src/files.cc b/src/files.cc
index 0a154c42..4a5b46fa 100644
--- a/src/files.cc
+++ b/src/files.cc
@@ -25,6 +25,7 @@
#include "notes.hpp"
#include "object1.hpp"
#include "object2.hpp"
+#include "options.hpp"
#include "skills.hpp"
#include "spells2.hpp"
#include "util.hpp"
diff --git a/src/generate.cc b/src/generate.cc
index edd7ea35..40a65ec4 100644
--- a/src/generate.cc
+++ b/src/generate.cc
@@ -14,6 +14,7 @@
#include "loadsave.hpp"
#include "monster2.hpp"
#include "object2.hpp"
+#include "options.hpp"
#include "randart.hpp"
#include "spells1.hpp"
#include "traps.hpp"
diff --git a/src/melee1.cc b/src/melee1.cc
index d56eb263..30f94bb9 100644
--- a/src/melee1.cc
+++ b/src/melee1.cc
@@ -2108,8 +2108,7 @@ bool_ make_attack_normal(int m_idx, byte divis)
((o_ptr->number > 1) ? "One of y" : "Y"),
o_name, index_to_label(i));
- /* Option */
- if (testing_carry)
+ /* Copy into inventory of monster */
{
s16b o_idx;
@@ -2153,38 +2152,6 @@ bool_ make_attack_normal(int m_idx, byte divis)
m_ptr->hold_o_idx = o_idx;
}
}
- else
- {
- if (strstr(r_ptr->name, "black market") && randint(2) != 1)
- {
- s16b o_idx;
-
- /* Make an object */
- o_idx = o_pop();
-
- /* Success */
- if (o_idx)
- {
- object_type *j_ptr;
- if (cheat_xtra || cheat_peek)
- msg_print("Moving object to black market...");
-
- /* Get new object */
- j_ptr = &o_list[o_idx];
-
- /* Copy object */
- object_copy(j_ptr, o_ptr);
-
- /* Modify number */
- j_ptr->number = 1;
-
- /* Forget mark */
- j_ptr->marked = FALSE;
-
- move_to_black_market(j_ptr);
- }
- }
- }
/* Steal the items */
inc_stack_size_ex(i, -1, OPTIMIZE, NO_DESCRIBE);
diff --git a/src/melee2.cc b/src/melee2.cc
index 638b7151..58aa68cb 100644
--- a/src/melee2.cc
+++ b/src/melee2.cc
@@ -24,6 +24,7 @@
#include "monster3.hpp"
#include "object1.hpp"
#include "object2.hpp"
+#include "options.hpp"
#include "quark.h"
#include "skills.hpp"
#include "spells1.hpp"
@@ -7083,8 +7084,7 @@ static void process_monster(int m_idx, bool_ is_frien)
msg_format("%^s picks up %s.", m_name, o_name);
}
- /* Option */
- if (testing_carry)
+ /* Put into inventory of monster */
{
/* Excise the object */
excise_object_idx(this_o_idx);
@@ -7104,13 +7104,6 @@ static void process_monster(int m_idx, bool_ is_frien)
/* Carry object */
m_ptr->hold_o_idx = this_o_idx;
}
-
- /* Nope */
- else
- {
- /* Delete the object */
- delete_object_idx(this_o_idx);
- }
}
/* Destroy the item */
diff --git a/src/monster2.cc b/src/monster2.cc
index 6f74a86a..47e1c9ea 100644
--- a/src/monster2.cc
+++ b/src/monster2.cc
@@ -15,6 +15,7 @@
#include "mimic.hpp"
#include "monster3.hpp"
#include "object2.hpp"
+#include "options.hpp"
#include "randart.hpp"
#include "spells1.hpp"
#include "spells2.hpp"
diff --git a/src/object1.cc b/src/object1.cc
index f1ec9136..5d1e80f4 100644
--- a/src/object1.cc
+++ b/src/object1.cc
@@ -20,6 +20,7 @@
#include "monster1.hpp"
#include "monster2.hpp"
#include "object2.hpp"
+#include "options.hpp"
#include "quark.h"
#include "skills.hpp"
#include "spell_type.hpp"
diff --git a/src/object2.cc b/src/object2.cc
index 6863db6e..f6941f90 100644
--- a/src/object2.cc
+++ b/src/object2.cc
@@ -5244,9 +5244,6 @@ s16b drop_near(object_type *j_ptr, int chance, int y, int x)
/* Add new object */
if (!comb) k++;
- /* No stacking (allow combining) */
- if (!testing_stack && (k > 1)) continue;
-
/* Paranoia */
if (k > 23) continue;
diff --git a/src/options.cc b/src/options.cc
new file mode 100644
index 00000000..d3feb7b2
--- /dev/null
+++ b/src/options.cc
@@ -0,0 +1,69 @@
+#include "options.hpp"
+
+//
+// Option Set 1 -- User Interface
+//
+bool_ rogue_like_commands; /* Rogue-like commands */
+bool_ quick_messages; /* Activate quick messages */
+bool_ carry_query_flag; /* Prompt before picking things up */
+bool_ use_old_target; /* Use old target by default */
+bool_ always_pickup; /* Pick things up by default */
+bool_ prompt_pickup_heavy; /* Don't pick up the corpses */
+bool_ always_repeat; /* Repeat obvious commands */
+bool_ ring_bell; /* Ring the bell (on errors, etc) */
+
+//
+// Option Set 2 -- Disturbance
+//
+bool_ find_ignore_stairs; /* Run past stairs */
+bool_ find_ignore_doors; /* Run through open doors */
+bool_ find_cut; /* Run past known corners */
+bool_ find_examine; /* Run into potential corners */
+bool_ disturb_move; /* Disturb whenever any monster moves */
+bool_ disturb_near; /* Disturb whenever viewable monster moves */
+bool_ disturb_panel; /* Disturb whenever map panel changes */
+bool_ disturb_detect; /* Disturb whenever leaving trap-detected area */
+bool_ disturb_state; /* Disturn whenever player state changes */
+bool_ disturb_minor; /* Disturb whenever boring things happen */
+bool_ disturb_other; /* Disturb whenever various things happen */
+bool_ alert_hitpoint; /* Alert user to critical hitpoints */
+bool_ alert_failure; /* Alert user to various failures */
+bool_ last_words; /* Get last words upon dying */
+bool_ small_levels; /* Allow unusually small dungeon levels */
+bool_ empty_levels; /* Allow empty 'arena' levels */
+bool_ always_small_level; /* Small levels */
+bool_ confirm_stairs; /* Prompt before staircases... */
+bool_ wear_confirm; /* Confirm before putting on known cursed items */
+bool_ disturb_pets; /* Pets moving nearby disturb us */
+
+//
+// Option Set 3 -- Game-Play
+//
+bool_ auto_scum; /* Auto-scum for good levels */
+bool_ expand_look; /* Expand the power of the look command */
+bool_ expand_list; /* Expand the power of the list commands */
+bool_ view_perma_grids; /* Map remembers all perma-lit grids */
+bool_ view_torch_grids; /* Map remembers all torch-lit grids */
+bool_ dungeon_align; /* Generate dungeons with aligned rooms */
+bool_ dungeon_stair; /* Generate dungeons with connected stairs */
+bool_ flow_by_sound; /* Monsters track new player location */
+bool_ smart_learn; /* Monsters learn from their mistakes */
+
+//
+// Option Set 4 -- Efficiency
+//
+bool_ view_reduce_lite; /* Reduce lite-radius when running */
+bool_ avoid_abort; /* Avoid checking for user abort */
+bool_ avoid_shimmer; /* Avoid processing extra shimmering */
+bool_ avoid_other; /* Avoid processing special colors */
+bool_ flush_failure; /* Flush input on any failure */
+bool_ flush_disturb; /* Flush input on disturbance */
+bool_ flush_command; /* Flush input before every command */
+bool_ fresh_before; /* Flush output before normal commands */
+bool_ fresh_after; /* Flush output after normal commands */
+bool_ fresh_message; /* Flush output after all messages */
+bool_ hilite_player; /* Hilite the player with the cursor */
+bool_ view_yellow_lite; /* Use special colors for torch-lit grids */
+bool_ view_bright_lite; /* Use special colors for 'viewable' grids */
+bool_ view_granite_lite; /* Use special colors for wall grids (slow) */
+bool_ view_special_lite; /* Use special colors for floor grids (slow) */
diff --git a/src/options.hpp b/src/options.hpp
new file mode 100644
index 00000000..1d79f5f8
--- /dev/null
+++ b/src/options.hpp
@@ -0,0 +1,71 @@
+#pragma once
+
+#include "h-basic.h"
+
+//
+// Option Set 1 -- User Interface.
+//
+extern bool_ rogue_like_commands;
+extern bool_ quick_messages;
+extern bool_ carry_query_flag;
+extern bool_ use_old_target;
+extern bool_ always_pickup;
+extern bool_ prompt_pickup_heavy;
+extern bool_ always_repeat;
+extern bool_ ring_bell;
+
+//
+// Option Set 2 -- Disturbance
+//
+extern bool_ find_ignore_stairs;
+extern bool_ find_ignore_doors;
+extern bool_ find_cut;
+extern bool_ find_examine;
+extern bool_ disturb_move;
+extern bool_ disturb_near;
+extern bool_ disturb_panel;
+extern bool_ disturb_detect;
+extern bool_ disturb_state;
+extern bool_ disturb_minor;
+extern bool_ disturb_other;
+extern bool_ alert_hitpoint;
+extern bool_ alert_failure;
+extern bool_ last_words;
+extern bool_ small_levels;
+extern bool_ empty_levels;
+extern bool_ always_small_level;
+extern bool_ confirm_stairs;
+extern bool_ wear_confirm;
+extern bool_ disturb_pets;
+
+//
+// Option Set 3 -- Game-Play
+//
+extern bool_ auto_scum;
+extern bool_ expand_look;
+extern bool_ expand_list;
+extern bool_ view_perma_grids;
+extern bool_ view_torch_grids;
+extern bool_ dungeon_align;
+extern bool_ dungeon_stair;
+extern bool_ flow_by_sound;
+extern bool_ smart_learn;
+
+//
+// Option Set 4 -- Efficiency
+//
+extern bool_ view_reduce_lite;
+extern bool_ avoid_abort;
+extern bool_ avoid_shimmer;
+extern bool_ avoid_other;
+extern bool_ flush_failure;
+extern bool_ flush_disturb;
+extern bool_ flush_command;
+extern bool_ fresh_before;
+extern bool_ fresh_after;
+extern bool_ fresh_message;
+extern bool_ hilite_player;
+extern bool_ view_yellow_lite;
+extern bool_ view_bright_lite;
+extern bool_ view_granite_lite;
+extern bool_ view_special_lite;
diff --git a/src/powers.cc b/src/powers.cc
index 25742412..12a46b15 100644
--- a/src/powers.cc
+++ b/src/powers.cc
@@ -20,6 +20,7 @@
#include "monster3.hpp"
#include "object1.hpp"
#include "object2.hpp"
+#include "options.hpp"
#include "quark.h"
#include "spells1.hpp"
#include "spells2.hpp"
diff --git a/src/q_ultrag.cc b/src/q_ultrag.cc
index e5b50095..d0ed41be 100644
--- a/src/q_ultrag.cc
+++ b/src/q_ultrag.cc
@@ -4,6 +4,7 @@
#include "hooks.h"
#include "object1.hpp"
#include "object2.hpp"
+#include "options.hpp"
#include "util.hpp"
#define cquest (quest[QUEST_ULTRA_GOOD])
diff --git a/src/randart.cc b/src/randart.cc
index 8f65961d..42cdb79b 100644
--- a/src/randart.cc
+++ b/src/randart.cc
@@ -10,6 +10,7 @@
#include "mimic.hpp"
#include "object1.hpp"
#include "object2.hpp"
+#include "options.hpp"
#include "quark.h"
#include "spells2.hpp"
#include "util.hpp"
diff --git a/src/spells1.cc b/src/spells1.cc
index cd31b8d1..178df200 100644
--- a/src/spells1.cc
+++ b/src/spells1.cc
@@ -19,6 +19,7 @@
#include "monster3.hpp"
#include "object1.hpp"
#include "object2.hpp"
+#include "options.hpp"
#include "skills.hpp"
#include "spell_type.hpp"
#include "spells2.hpp"
diff --git a/src/spells2.cc b/src/spells2.cc
index bd460df6..e25e606e 100644
--- a/src/spells2.cc
+++ b/src/spells2.cc
@@ -20,6 +20,7 @@
#include "notes.hpp"
#include "object1.hpp"
#include "object2.hpp"
+#include "options.hpp"
#include "skills.hpp"
#include "spells1.hpp"
#include "spells3.hpp"
diff --git a/src/spells4.cc b/src/spells4.cc
index a5ec074c..4d91e5a1 100644
--- a/src/spells4.cc
+++ b/src/spells4.cc
@@ -4,6 +4,7 @@
#include "cmd5.hpp"
#include "gods.hpp"
#include "lua_bind.hpp"
+#include "options.hpp"
#include "spell_type.hpp"
#include "spell_idx_list.hpp"
#include "spells3.hpp"
diff --git a/src/store.cc b/src/store.cc
index a7707179..64a95a88 100644
--- a/src/store.cc
+++ b/src/store.cc
@@ -17,6 +17,7 @@
#include "hooks.h"
#include "object1.hpp"
#include "object2.hpp"
+#include "options.hpp"
#include "quark.h"
#include "spell_type.hpp"
#include "skills.hpp"
diff --git a/src/tables.cc b/src/tables.cc
index 16abe9b1..eb2c9ae1 100644
--- a/src/tables.cc
+++ b/src/tables.cc
@@ -12,6 +12,7 @@
#include "angband.h"
#include "modules.hpp"
+#include "options.hpp"
#include "q_library.h"
#include "q_fireprof.h"
#include "q_bounty.h"
@@ -1574,17 +1575,6 @@ option_type option_info[] =
{ &fate_option, TRUE, 6, 18,
"fate_option", "You can receive fates, good or bad" },
- /* XXX 17 is used BEFORE */
-
- /*** Stacking ***/
-
- { &testing_stack, TRUE, 7, 0,
- "testing_stack", "Allow objects to stack on floor" },
-
- { &testing_carry, TRUE, 7, 1,
- "testing_carry", "Allow monsters to carry objects" },
-
-
/*** End of Table ***/
{ NULL, 0, 0, 0,
diff --git a/src/util.cc b/src/util.cc
index 0d312e2b..76327883 100644
--- a/src/util.cc
+++ b/src/util.cc
@@ -10,6 +10,7 @@
#include "cmd4.hpp"
#include "init1.hpp"
#include "messages.h"
+#include "options.hpp"
#include "quark.h"
#include "xtra1.hpp"
diff --git a/src/variable.cc b/src/variable.cc
index 888a4182..d102c1da 100644
--- a/src/variable.cc
+++ b/src/variable.cc
@@ -165,92 +165,6 @@ int text_out_indent = 0;
*/
-/* Option Set 1 -- User Interface */
-
-bool_ rogue_like_commands; /* Rogue-like commands */
-bool_ quick_messages; /* Activate quick messages */
-bool_ carry_query_flag; /* Prompt before picking things up */
-bool_ use_old_target; /* Use old target by default */
-bool_ always_pickup; /* Pick things up by default */
-bool_ prompt_pickup_heavy; /* Don't pick up the corpses */
-bool_ always_repeat; /* Repeat obvious commands */
-
-bool_ ring_bell; /* Ring the bell (on errors, etc) */
-
-
-/* Option Set 2 -- Disturbance */
-
-bool_ find_ignore_stairs; /* Run past stairs */
-bool_ find_ignore_doors; /* Run through open doors */
-bool_ find_cut; /* Run past known corners */
-bool_ find_examine; /* Run into potential corners */
-
-bool_ disturb_move; /* Disturb whenever any monster moves */
-bool_ disturb_near; /* Disturb whenever viewable monster moves */
-bool_ disturb_panel; /* Disturb whenever map panel changes */
-bool_ disturb_detect; /* Disturb whenever leaving trap-detected area */
-bool_ disturb_state; /* Disturn whenever player state changes */
-bool_ disturb_minor; /* Disturb whenever boring things happen */
-bool_ disturb_other; /* Disturb whenever various things happen */
-
-bool_ alert_hitpoint; /* Alert user to critical hitpoints */
-bool_ alert_failure; /* Alert user to various failures */
-bool_ last_words; /* Get last words upon dying */
-bool_ small_levels; /* Allow unusually small dungeon levels */
-bool_ empty_levels; /* Allow empty 'arena' levels */
-bool_ always_small_level; /* Small levels */
-bool_ confirm_stairs; /* Prompt before staircases... */
-bool_ wear_confirm; /* Confirm before putting on known cursed items */
-bool_ disturb_pets; /* Pets moving nearby disturb us */
-
-
-/* Option Set 3 -- Game-Play */
-
-bool_ auto_scum; /* Auto-scum for good levels */
-
-bool_ expand_look; /* Expand the power of the look command */
-bool_ expand_list; /* Expand the power of the list commands */
-
-bool_ view_perma_grids; /* Map remembers all perma-lit grids */
-bool_ view_torch_grids; /* Map remembers all torch-lit grids */
-
-bool_ dungeon_align; /* Generate dungeons with aligned rooms */
-bool_ dungeon_stair; /* Generate dungeons with connected stairs */
-
-bool_ flow_by_sound; /* Monsters track new player location */
-
-bool_ smart_learn; /* Monsters learn from their mistakes */
-
-
-/* Option Set 4 -- Efficiency */
-
-bool_ view_reduce_lite; /* Reduce lite-radius when running */
-
-bool_ avoid_abort; /* Avoid checking for user abort */
-bool_ avoid_shimmer; /* Avoid processing extra shimmering */
-bool_ avoid_other; /* Avoid processing special colors */
-
-bool_ flush_failure; /* Flush input on any failure */
-bool_ flush_disturb; /* Flush input on disturbance */
-bool_ flush_command; /* Flush input before every command */
-
-bool_ fresh_before; /* Flush output before normal commands */
-bool_ fresh_after; /* Flush output after normal commands */
-bool_ fresh_message; /* Flush output after all messages */
-
-bool_ hilite_player; /* Hilite the player with the cursor */
-
-bool_ view_yellow_lite; /* Use special colors for torch-lit grids */
-bool_ view_bright_lite; /* Use special colors for 'viewable' grids */
-
-bool_ view_granite_lite; /* Use special colors for wall grids (slow) */
-bool_ view_special_lite; /* Use special colors for floor grids (slow) */
-
-/* Option set 5 -- Testing */
-
-bool_ testing_stack; /* Test the stacking code */
-
-bool_ testing_carry; /* Test the carrying code */
/* Cheating options */
diff --git a/src/wild.cc b/src/wild.cc
index aed243ba..f0fe451c 100644
--- a/src/wild.cc
+++ b/src/wild.cc
@@ -13,6 +13,7 @@
#include "hooks.h"
#include "init1.hpp"
#include "monster2.hpp"
+#include "options.hpp"
#include "util.hpp"
#include <memory>
diff --git a/src/xtra1.cc b/src/xtra1.cc
index 8add6798..27a8eb81 100644
--- a/src/xtra1.cc
+++ b/src/xtra1.cc
@@ -22,6 +22,7 @@
#include "monster2.hpp"
#include "object1.hpp"
#include "object2.hpp"
+#include "options.hpp"
#include "skills.hpp"
#include "spells3.hpp"
#include "spells6.hpp"
diff --git a/src/xtra2.cc b/src/xtra2.cc
index 149079a6..16d1f432 100644
--- a/src/xtra2.cc
+++ b/src/xtra2.cc
@@ -22,6 +22,7 @@
#include "notes.hpp"
#include "object1.hpp"
#include "object2.hpp"
+#include "options.hpp"
#include "quark.h"
#include "randart.hpp"
#include "skills.hpp"