summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--src/CMakeLists.txt2
-rw-r--r--src/bldg.c1
-rw-r--r--src/plots.c3
-rw-r--r--src/plots.h6
-rw-r--r--src/q_bounty.c3
-rw-r--r--src/q_bounty.h17
-rw-r--r--src/tables.c1
7 files changed, 22 insertions, 11 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index ea4206e1..a5316cb4 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -10,7 +10,7 @@ SET(SRCS
z-rand.c z-util.c z-form.c z-virt.c z-term.c
variable.c tables.c plots.c util.c cave.c dungeon.c
melee1.c melee2.c messages.c modules.c
- q_god.c q_library.c q_fireprof.c
+ q_god.c q_library.c q_fireprof.c q_bounty.c
object1.c object2.c randart.c squeltch.cc traps.c
monster1.c monster2.c monster3.c
xtra1.c xtra2.c skills.c powers.c gods.c
diff --git a/src/bldg.c b/src/bldg.c
index b17e8130..a182df65 100644
--- a/src/bldg.c
+++ b/src/bldg.c
@@ -16,6 +16,7 @@
#include "angband.h"
#include "q_library.h"
#include "q_fireprof.h"
+#include "q_bounty.h"
/* hack as in leave_store in store.c */
static bool_ leave_bldg = FALSE;
diff --git a/src/plots.c b/src/plots.c
index 376cd8d6..668d04ce 100644
--- a/src/plots.c
+++ b/src/plots.c
@@ -398,6 +398,3 @@ bool_ quest_null_hook(int q)
/*************************** Other plot ***************************/
#include "q_narsil.c"
#include "q_thrain.c"
-
-/*************************** Bounty Quest *************************/
-#include "q_bounty.c"
diff --git a/src/plots.h b/src/plots.h
index 211fdbb3..df3cc927 100644
--- a/src/plots.h
+++ b/src/plots.h
@@ -47,12 +47,6 @@ extern bool_ quest_evil_init_hook(int q_idx);
extern bool_ quest_narsil_init_hook(int q_idx);
extern bool_ quest_thrain_init_hook(int q_idx);
-/******* Plot Bounty Quest ********/
-extern bool_ quest_bounty_init_hook(int q_idx);
-extern bool_ quest_bounty_drop_item();
-extern bool_ quest_bounty_get_item();
-extern bool_ quest_bounty_describe(FILE *fff);
-
/******* Plot God Quest **************/
extern bool_ quest_god_describe(FILE *);
extern bool_ quest_god_init_hook(int q);
diff --git a/src/q_bounty.c b/src/q_bounty.c
index 01b119be..b7cd150e 100644
--- a/src/q_bounty.c
+++ b/src/q_bounty.c
@@ -1,4 +1,5 @@
-#undef cquest
+#include "q_bounty.h"
+
#define cquest (quest[QUEST_BOUNTY])
#define bounty_quest_monster (cquest.data[0])
diff --git a/src/q_bounty.h b/src/q_bounty.h
new file mode 100644
index 00000000..c0a4027c
--- /dev/null
+++ b/src/q_bounty.h
@@ -0,0 +1,17 @@
+#pragma once
+
+#include "angband.h"
+
+#ifdef __cplusplus
+extern "C" {
+#endif
+
+/******* Plot Bounty Quest ********/
+extern bool_ quest_bounty_init_hook(int q_idx);
+extern bool_ quest_bounty_drop_item();
+extern bool_ quest_bounty_get_item();
+extern bool_ quest_bounty_describe(FILE *fff);
+
+#ifdef __cplusplus
+} // extern "C"
+#endif
diff --git a/src/tables.c b/src/tables.c
index af3e2764..82ccdb9e 100644
--- a/src/tables.c
+++ b/src/tables.c
@@ -13,6 +13,7 @@
#include "angband.h"
#include "q_library.h"
#include "q_fireprof.h"
+#include "q_bounty.h"