summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--src/CMakeLists.txt2
-rw-r--r--src/plots.c3
-rw-r--r--src/plots.h3
-rw-r--r--src/q_thief.c3
-rw-r--r--src/q_thief.h13
-rw-r--r--src/tables.c1
6 files changed, 17 insertions, 8 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 6f0974f3..f9fc4a34 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -14,7 +14,7 @@ SET(SRCS
q_narsil.c q_evil.c q_betwen.c q_haunted.c q_invas.c
q_nirna.c q_eol.c q_god.c q_dragons.c q_poison.c
q_spider.c q_wolves.c q_shroom.c q_nazgul.c q_wight.c
- q_troll.c q_hobbit.c
+ q_troll.c q_hobbit.c q_thief.c
object1.c object2.c randart.c squeltch.cc traps.c
monster1.c monster2.c monster3.c
xtra1.c xtra2.c skills.c powers.c gods.c
diff --git a/src/plots.c b/src/plots.c
index 51b986a3..d3cc6827 100644
--- a/src/plots.c
+++ b/src/plots.c
@@ -368,6 +368,3 @@ bool_ quest_null_hook(int q)
#include "q_one.c"
#include "q_ultrag.c"
#include "q_ultrae.c"
-
-/**************************** Bree plot ***************************/
-#include "q_thief.c"
diff --git a/src/plots.h b/src/plots.h
index 47d54dbd..d5cc364d 100644
--- a/src/plots.h
+++ b/src/plots.h
@@ -16,6 +16,3 @@ extern bool_ quest_sauron_init_hook(int q_idx);
extern bool_ quest_morgoth_init_hook(int q_idx);
extern bool_ quest_ultra_good_init_hook(int q_idx);
extern bool_ quest_ultra_evil_init_hook(int q_idx);
-
-/******* Plot Bree *********/
-extern bool_ quest_thieves_init_hook(int q_idx);
diff --git a/src/q_thief.c b/src/q_thief.c
index 6b033f8c..b341c572 100644
--- a/src/q_thief.c
+++ b/src/q_thief.c
@@ -1,4 +1,5 @@
-#undef cquest
+#include "q_thief.h"
+
#define cquest (quest[QUEST_THIEVES])
bool_ quest_thieves_gen_hook(char *fmt)
diff --git a/src/q_thief.h b/src/q_thief.h
new file mode 100644
index 00000000..1962ee34
--- /dev/null
+++ b/src/q_thief.h
@@ -0,0 +1,13 @@
+#pragma once
+
+#include "angband.h"
+
+#ifdef __cplusplus
+extern "C" {
+#endif
+
+bool_ quest_thieves_init_hook(int q_idx);
+
+#ifdef __cplusplus
+} // extern "C"
+#endif
diff --git a/src/tables.c b/src/tables.c
index be79733f..2d4a0275 100644
--- a/src/tables.c
+++ b/src/tables.c
@@ -32,6 +32,7 @@
#include "q_wight.h"
#include "q_troll.h"
#include "q_hobbit.h"
+#include "q_thief.h"