summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CMakeLists.txt2
-rw-r--r--debian/changelog24
-rw-r--r--debian/control1
-rwxr-xr-xdebian/rules12
-rw-r--r--src/z-rand.cc2
5 files changed, 38 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 853c01fe..b5f24419 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -11,7 +11,7 @@ INCLUDE(FindPkgConfig)
#
# Basic common compiler flags.
#
-SET(COMMON_COMPILER_FLAGS "-pipe -Wall -Wno-unused-value -fsanitize=undefined -fsanitize=address")
+SET(COMMON_COMPILER_FLAGS "-pipe -Wall -Wno-unused-value")
#
# GCC/G++ flags
diff --git a/debian/changelog b/debian/changelog
index f75cddc4..98e4ceb1 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,27 @@
+tome (2.4~0.git.2015.12.29-1.2) unstable; urgency=medium
+
+ * Non-maintainer upload.
+
+ [ Colin Watson ]
+ * Only build with -fsanitize=undefined -fsanitize=address on architectures
+ that support these.
+
+ [ Bhavani Shankar ]
+ * Match variable boolean type in z-rand.cc to fix compilation on
+ 32 bit archs. Thanks to Andreas Beckmann from debian for the
+ report. Closes: #843984.
+
+ -- Matthias Klose <doko@debian.org> Wed, 13 Sep 2017 22:25:47 +0200
+
+tome (2.4~0.git.2015.12.29-1.1) unstable; urgency=medium
+
+ * Non-maintainer upload.
+ * Add "XS-Autobuild: yes" to have the buildds autobuild the package.
+ This is also to be able to build binNMUs on the buildds during transitions.
+ Closes: #750940
+
+ -- Mattia Rizzolo <mattia@debian.org> Mon, 10 Oct 2016 14:25:57 +0000
+
tome (2.4~0.git.2015.12.29-1) unstable; urgency=low
* New upstream git pull
diff --git a/debian/control b/debian/control
index e913e79a..2cf18ebb 100644
--- a/debian/control
+++ b/debian/control
@@ -9,6 +9,7 @@ Build-Depends: debhelper (>= 9.0.0), libjansson-dev, cmake,
libncurses5-dev | libncurses-dev | ncurses-dev, libboost-all-dev,
libsdl-image1.2-dev, libsdl-ttf2.0-dev, libx11-dev, dpkg-dev (>= 1.16.0)
Standards-Version: 3.9.6
+XS-Autobuild: yes
Package: tome
Architecture: any
diff --git a/debian/rules b/debian/rules
index c31c20b0..6abd12de 100755
--- a/debian/rules
+++ b/debian/rules
@@ -37,11 +37,21 @@ PKG_STATLIB= $(TMPTOP)$(PREFIX)/lib/$(package)
DPKG_ARCH := dpkg-architecture
export DEB_HOST_MULTIARCH := $(shell $(DPKG_ARCH) $(ha) -qDEB_HOST_MULTIARCH)
+DEB_HOST_ARCH := $(shell $(DPKG_ARCH) -qDEB_HOST_ARCH)
+CONFIGURE_ARGS :=
+ifneq (,$(filter amd64 arm64 armel armhf i386 powerpc ppc64 ppc64el x32 sparc sparc64,$(DEB_HOST_ARCH)))
+ # Upstream passes these unconditionally, but they're only available on
+ # certain architectures.
+ CONFIGURE_ARGS += \
+ -DCMAKE_C_FLAGS="-fsanitize=undefined -fsanitize=address" \
+ -DCMAKE_CXX_FLAGS="-fsanitize=undefined -fsanitize=address"
+endif
+
%:
dh $@
override_dh_auto_configure:
- dh_auto_configure -- -DSYSTEM_INSTALL:BOOL=true
+ dh_auto_configure -- -DSYSTEM_INSTALL:BOOL=true $(CONFIGURE_ARGS)
override_dh_auto_build:
bash -n debian/tome.postinst
diff --git a/src/z-rand.cc b/src/z-rand.cc
index c06b7893..e2960a55 100644
--- a/src/z-rand.cc
+++ b/src/z-rand.cc
@@ -351,7 +351,7 @@ s32b maxroll(s16b num, s16b sides)
return (num * sides);
}
-bool magik(int p) {
+bool magik(s32b p) {
return rand_int(100) < p;
}