summaryrefslogtreecommitdiff
path: root/debian/diff/0003-Makefile-avoid-rpath.diff
diff options
context:
space:
mode:
Diffstat (limited to 'debian/diff/0003-Makefile-avoid-rpath.diff')
-rw-r--r--debian/diff/0003-Makefile-avoid-rpath.diff25
1 files changed, 25 insertions, 0 deletions
diff --git a/debian/diff/0003-Makefile-avoid-rpath.diff b/debian/diff/0003-Makefile-avoid-rpath.diff
new file mode 100644
index 0000000..f5a5b02
--- /dev/null
+++ b/debian/diff/0003-Makefile-avoid-rpath.diff
@@ -0,0 +1,25 @@
+From 0e63fa0fb919e5394704c3c6dff87ed776c41d2a Mon Sep 17 00:00:00 2001
+From: Gerrit Pape <pape@smarden.org>
+Date: Mon, 19 Apr 2010 22:20:11 +0000
+Subject: [PATCH 3/3] Makefile: avoid rpath
+
+---
+ Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile b/Makefile
+index 9a66ba4..a8c65aa 100644
+--- a/Makefile
++++ b/Makefile
+@@ -59,7 +59,7 @@ load: conf-ld conf-bglibs
+ ( bglibs=`head -n 1 conf-bglibs`; \
+ echo '#!/bin/sh';\
+ echo 'main="$$1"; shift';\
+- echo exec `head -n 1 conf-ld` -L. "-L'$${bglibs}'" "-Wl,-R'$${bglibs}'" '-o "$$main" "$$main.o" $${1+"$$@"}' -lbg-sysdeps; \
++ echo exec `head -n 1 conf-ld` -L. "-L'$${bglibs}'" '-o "$$main" "$$main.o" $${1+"$$@"}' -lbg-sysdeps; \
+ ) >load
+ chmod 755 load
+
+--
+2.0.1
+