summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRuben Undheim <ruben.undheim@gmail.com>2018-07-13 16:36:06 +0200
committerRuben Undheim <ruben.undheim@gmail.com>2018-08-10 13:32:26 +0200
commit624a6807fd667647a704ffa3586bdd3aafaa1845 (patch)
treef752f78824297ebd6f266468e87a05c187d8c377
parent40847b6ab358433e2b0d98589217bd9d77ebbbe3 (diff)
Fixes install location of python package
Gbp-Pq: Name 01_fixpythoninstall.patch
-rw-r--r--host/python/specan_ui/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/host/python/specan_ui/CMakeLists.txt b/host/python/specan_ui/CMakeLists.txt
index c365bd5..21b206d 100644
--- a/host/python/specan_ui/CMakeLists.txt
+++ b/host/python/specan_ui/CMakeLists.txt
@@ -31,7 +31,7 @@ add_custom_command(OUTPUT ${OUTPUT}/timestamp
DEPENDS ${DEPS})
add_custom_target(specan ALL DEPENDS ${OUTPUT}/timestamp)
-install(CODE "execute_process(COMMAND ${PYTHON_EXECUTABLE} ${SETUP_PY} build -b ${OUTPUT} install)")
+install(CODE "execute_process(COMMAND ${PYTHON_EXECUTABLE} ${SETUP_PY} build -b ${OUTPUT} install --root=${CMAKE_SOURCE_DIR}/../debian/tmp --install-layout=deb)")
add_custom_target(ubertooth-specan-ui ALL DEPENDS ${CMAKE_CURRENT_SOURCE_DIR}/ubertooth-specan-ui)
install(PROGRAMS ubertooth-specan-ui DESTINATION ${INSTALL_DEFAULT_BINDIR})