summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRuben Undheim <ruben.undheim@gmail.com>2018-07-13 16:36:06 +0200
committerRuben Undheim <ruben.undheim@gmail.com>2018-12-20 10:36:18 +0100
commite56442e3d970526891b1929f042ae26ca1bd464c (patch)
treee08bc577d95b268883d5fdd1c119c031519377cd
parentc826aedd28d636c0ab58f32af67d85da45e0c976 (diff)
When building the package, the source is not necessarily part of a git repository. This patch removes all git command executions. Additionally it replaces GIT_REVISION with the current Debian version number. This will go into some of the firmware files.
Gbp-Pq: Name 04_no_git_for_debian.patch
-rw-r--r--firmware/common.mk10
1 files changed, 5 insertions, 5 deletions
diff --git a/firmware/common.mk b/firmware/common.mk
index e6b6245..44a5e00 100644
--- a/firmware/common.mk
+++ b/firmware/common.mk
@@ -52,13 +52,13 @@ ifeq ($(DISABLE_TX), )
UBERTOOTH_OPTS += -DTX_ENABLE
endif
-DIRTY = $(shell git status -s --untracked-files=no)
-ifneq ($(DIRTY), )
- DIRTY_FLAG = *
-endif
+#DIRTY = $(shell git status -s --untracked-files=no)
+#ifneq ($(DIRTY), )
+# DIRTY_FLAG = *
+#endif
# automatic git version when working out of git
-GIT_REVISION ?= -D'GIT_REVISION="git-$(shell git log --pretty=format:'%h' -n 1)$(DIRTY_FLAG)"'
+GIT_REVISION ?= -D'GIT_REVISION="REPLACE_ME_WITH_VERSION"'
# compile info
COMPILE_BY ?= -D'COMPILE_BY="$(shell whoami)"'