summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRuben Undheim <ruben.undheim@gmail.com>2018-07-13 16:36:06 +0200
committerRuben Undheim <ruben.undheim@gmail.com>2018-07-13 20:06:07 +0200
commitfc1f56c50118087f9d9d2a6df9a92d54f4f06cdd (patch)
treebbb55a1b9a78a89f8e4edd922ea0096af4de9318
parent6e72d4c147c96c674ceaf4fde2fb41be49ca3481 (diff)
When building the package, the source is not necessarily part of a git repository. This patch removes all git command executions. Additionally it replaces GIT_REVISION with the current Debian version number. This will go into some of the firmware files.
Gbp-Pq: Name 04_no_git_for_debian.patch
-rw-r--r--firmware/common.mk10
1 files changed, 5 insertions, 5 deletions
diff --git a/firmware/common.mk b/firmware/common.mk
index e6b6245..aacbd3e 100644
--- a/firmware/common.mk
+++ b/firmware/common.mk
@@ -52,13 +52,13 @@ ifeq ($(DISABLE_TX), )
UBERTOOTH_OPTS += -DTX_ENABLE
endif
-DIRTY = $(shell git status -s --untracked-files=no)
-ifneq ($(DIRTY), )
- DIRTY_FLAG = *
-endif
+#DIRTY = $(shell git status -s --untracked-files=no)
+#ifneq ($(DIRTY), )
+# DIRTY_FLAG = *
+#endif
# automatic git version when working out of git
-GIT_REVISION ?= -D'GIT_REVISION="git-$(shell git log --pretty=format:'%h' -n 1)$(DIRTY_FLAG)"'
+GIT_REVISION ?= -D'GIT_REVISION="2017-03-R2"'
# compile info
COMPILE_BY ?= -D'COMPILE_BY="$(shell whoami)"'