summaryrefslogtreecommitdiff
path: root/firmware/common.mk
diff options
context:
space:
mode:
authorWill Code <willcode4@gmail.com>2012-03-25 13:57:24 +0000
committerWill Code <willcode4@gmail.com>2012-03-25 13:57:24 +0000
commit3d9571447f114471ee21ac0076e87d5cbad4343a (patch)
treeee08d46526d653987bbaa6afffa73c306d66c941 /firmware/common.mk
parent114534b3847ab1461e46c241e1c66319ded2bf03 (diff)
Move squelch to firmware.
- Use "carrier sense" on CC2400 as a trigger, received LPC17XX interrupt - Keep squelch open for min 2 packets (CS_HOLD_TIME) - Set squelch level with ubertooth-util -z-70 (just -z to get value) - Squelch commented out on host - Firmware keeps per-channel IIR for "noise" statistics, reported to host
Diffstat (limited to 'firmware/common.mk')
-rw-r--r--firmware/common.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/firmware/common.mk b/firmware/common.mk
index 5375ee1..6749ce7 100644
--- a/firmware/common.mk
+++ b/firmware/common.mk
@@ -98,7 +98,7 @@ OBJDIR = .
# Optimization level, can be [0, 1, 2, 3, s].
# 0 = turn off optimization. s = optimize for size.
# (Note: 3 is not always the best optimization level. See libc FAQ.)
-OPT = s
+OPT = 2
# Debugging format.
DEBUG = dwarf-2 -g3