summaryrefslogtreecommitdiff
path: root/firmware/common.mk
diff options
context:
space:
mode:
authorDominic Spill <dominicgs@gmail.com>2012-07-09 07:14:12 +0000
committerDominic Spill <dominicgs@gmail.com>2012-07-09 07:14:12 +0000
commitd8cfb7fca2aca7a9b2293bbfe96fdb39cd51e3c6 (patch)
tree96f28977ce9be384b8e957e77107f1ba4c36c7b8 /firmware/common.mk
parent23281d75a993b560b054edf34d1458294d30cb97 (diff)
Use Openmoko vendor and product IDs
- Still signing firmware with 0xffff/0x0004 so no need to flash bootloader - Reorg of ubertooth-dfu to move non-ubertooth code to module - Fix vendorId in udev rules - Ubertooth tools try all three vendor/product ID combinations
Diffstat (limited to 'firmware/common.mk')
-rw-r--r--firmware/common.mk7
1 files changed, 3 insertions, 4 deletions
diff --git a/firmware/common.mk b/firmware/common.mk
index 6749ce7..61e4365 100644
--- a/firmware/common.mk
+++ b/firmware/common.mk
@@ -246,14 +246,13 @@ READELF = arm-none-eabi-readelf
SIZE = arm-none-eabi-size
AR = arm-none-eabi-ar -r
NM = arm-none-eabi-nm
-PYTHON = /usr/bin/env python
REMOVE = rm -f
#
ifeq ($(strip $(`which ubertooth-dfu`)),)
- DFU_TOOL ?= $(PYTHON) ../../host/usb_dfu/ubertooth-dfu
+ DFU_TOOL ?= ../../host/usb_dfu/ubertooth-dfu
else
- DFU_TOOL ?= $(PYTHON) `which ubertooth-dfu`
+ DFU_TOOL ?= `which ubertooth-dfu`
endif
# Define Messages
@@ -381,7 +380,7 @@ program: $(TARGET).hex
%.dfu: %.bin
@echo
@echo $(MSG_DFU) $@
- $(DFU_TOOL) sign $(TARGET).bin
+ $(DFU_TOOL) --sign $(TARGET).bin
# Create library from object files.
.SECONDARY : $(TARGET).a