summaryrefslogtreecommitdiff
path: root/firmware/common.mk
diff options
context:
space:
mode:
authorDominic Spill <dominicgs@gmail.com>2011-07-17 07:58:10 +0000
committerDominic Spill <dominicgs@gmail.com>2011-07-17 07:58:10 +0000
commite1d17968c6d744ee853b90e04a40aa1d883473c9 (patch)
tree6a5392e4151b40daf12d21bb7911b4380585ba6e /firmware/common.mk
parent830ba2738fcd01536dba6cfeebc017c02ce1828c (diff)
Try to guess where ubertooth-dfu is installed
Diffstat (limited to 'firmware/common.mk')
-rw-r--r--firmware/common.mk8
1 files changed, 7 insertions, 1 deletions
diff --git a/firmware/common.mk b/firmware/common.mk
index 2ce3110..863de72 100644
--- a/firmware/common.mk
+++ b/firmware/common.mk
@@ -237,9 +237,15 @@ SIZE = arm-none-eabi-size
AR = arm-none-eabi-ar -r
NM = arm-none-eabi-nm
PYTHON = /usr/bin/env python
-DFU_TOOL = $(PYTHON) ../../host/usb_dfu/ubertooth-dfu
REMOVE = rm -f
+#
+ifeq ($(strip $(`which ubertooth-dfu`)),)
+ DFU_TOOL = $(PYTHON) ../../host/usb_dfu/ubertooth-dfu
+else
+ DFU_TOOL = $(PYTHON) `which ubertooth-dfu`
+endif
+
# Define Messages
# English
MSG_BEGIN = -------- begin --------