summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rwxr-xr-xtools/ubertooth-release.sh6
-rw-r--r--web/content/stylesheet.css8
-rw-r--r--web/content/usage/build.html277
3 files changed, 156 insertions, 135 deletions
diff --git a/tools/ubertooth-release.sh b/tools/ubertooth-release.sh
index 03e8208..66dfeca 100755
--- a/tools/ubertooth-release.sh
+++ b/tools/ubertooth-release.sh
@@ -10,7 +10,9 @@ if test $# -lt 2 ; then
branch=`git rev-parse --abbrev-ref HEAD`
else
branch=${2}
- git checkout ${2}
+ # Not sure this is really a good idea, better to make
+ # sure that you're on the branch in the first place
+ #git checkout ${2}
fi
# FIXME you'll need to update these:
@@ -99,4 +101,4 @@ rm ${targetdir}/.gitignore
# Archive
############################
cd ${top}
-tar -zcf ${releasename}.tar.gz ${releasename}/
+tar -cJf ${releasename}.tar.xz ${releasename}/
diff --git a/web/content/stylesheet.css b/web/content/stylesheet.css
index 345c982..1d68aa9 100644
--- a/web/content/stylesheet.css
+++ b/web/content/stylesheet.css
@@ -114,3 +114,11 @@ a[name]:hover {
line-height: 20px;
}
+
+pre {
+ /*margin: 1em 1em 1em 1.6em;*/
+ font-family: monospace;
+ padding: 2px 2px 2px 0;
+ background-color: #FAFAFA;
+ border: 1px solid #DADADA;
+}
diff --git a/web/content/usage/build.html b/web/content/usage/build.html
index 801f180..582763f 100644
--- a/web/content/usage/build.html
+++ b/web/content/usage/build.html
@@ -7,6 +7,7 @@ title: Build Guide
<ul>
<li><a href="#ubuntu">Ubuntu</a> (Debian/BackTrack 5 - untested)</li>
<li><a href="#fedora">Fedora</a> (RedHat/CentOS - untested)</li>
+ <li><a href="#gentoo">Gentoo</a></li>
<li><a href="#windows">Windows</a> (experimental - unsupported)</li>
<li><a href="#osx">Mac OS X</a> (experimental)</li>
</ul>
@@ -21,26 +22,26 @@ images and flashing them to the Ubertooth can be found <a href="#firmware">here.
<p>There are some prerequisites that can be installed from the apt repositories
on Debian/Ubuntu systems:</p>
<pre>
- sudo apt-get install libusb-1.0-0-dev make gcc pyside-tools
+ sudo apt-get install libusb-1.0-0-dev make gcc pyside-tools
</pre>
<p>PyUSB is not yet available from the apt repositories, so it must be
downloaded and built from sourece as follows:</p>
<pre>
- wget http://sourceforge.net/projects/pyusb/files/PyUSB%201.0/1.0.0-alpha-2/pyusb-1.0.0a2.tar.gz/download -O pyusb-1.0.0a2.tar.gz
- tar xvf pyusb-1.0.0a2.tar.gz
- cd pyusb-1.0.0a2
- sudo python setup.py install
+ wget http://sourceforge.net/projects/pyusb/files/PyUSB%201.0/1.0.0-alpha-2/pyusb-1.0.0a2.tar.gz/download -O pyusb-1.0.0a2.tar.gz
+ tar xvf pyusb-1.0.0a2.tar.gz
+ cd pyusb-1.0.0a2
+ sudo python setup.py install
</pre>
<p>Next the Bluetooth baseband library (libbtbb) needs to be built for the
Ubertooth tools to decode Bluetooth packets:</p>
<pre>
- wget http://sourceforge.net/projects/libbtbb/files/libbtbb-2012-10-R1.tar.xz/download -O libbtbb-2012-10-R1.tar.xz
- tar xf libbtbb-2012-10-R1.tar.xz
- cd libbtbb-2012-10-R1
- make
- sudo make install
+ wget http://sourceforge.net/projects/libbtbb/files/libbtbb-2012-10-R1.tar.xz/download -O libbtbb-2012-10-R1.tar.xz
+ tar xf libbtbb-2012-10-R1.tar.xz
+ cd libbtbb-2012-10-R1
+ make
+ sudo make install
</pre>
<br />
@@ -49,19 +50,19 @@ Ubertooth tools to decode Bluetooth packets:</p>
Bluetooth sniffing tools and firmware update. All three are built and installed
by default using the following method:</p>
<pre>
- wget http://sourceforge.net/projects/ubertooth/files/ubertooth-2012-10-R1.tar.xz/download -O ubertooth-2012-10-R1.tar.xz
- tar xf ubertooth-2012-10-R1.tar.xz
- cd ubertooth-2012-10-R1/host
- make
- sudo make install
+ wget http://sourceforge.net/projects/ubertooth/files/ubertooth-2012-10-R1.tar.xz/download -O ubertooth-2012-10-R1.tar.xz
+ tar xf ubertooth-2012-10-R1.tar.xz
+ cd ubertooth-2012-10-R1/host
+ make
+ sudo make install
</pre>
<p>If using the ubertooth-follow tool, the Bluetooth library headers are
required and the tools need to be built with the "clock_debug" flag set:</p>
<pre>
- sudo apt-get install libbluetooth-dev
- cd ubertooth-2012-10-R1/host
- make clock_debug=true
- sudo make clock_debug=true install
+ sudo apt-get install libbluetooth-dev
+ cd ubertooth-2012-10-R1/host
+ make clock_debug=true
+ sudo make clock_debug=true install
</pre>
<br />
@@ -70,28 +71,31 @@ required and the tools need to be built with the "clock_debug" flag set:</p>
old to support the Ubertooth plugin. In order to use Ubertooth with Kismet it
is nessecary to compile Kismet from source:</p>
<pre>
- sudo apt-get install libpcap0.8-dev libcap-dev build-essential pkg-config libnl-dev libncurses-dev libpcre3-dev libpcap-dev libcap-dev
- wget http://www.kismetwireless.net/code/kismet-2011-03-R2.tar.gz
- tar xf kismet-2011-03-R2.tar.gz
- ln -s ubertooth-2012-10-R1/host/kismet/plugin-ubertooth kismet-2011-03-R2/
- cd kismet-2011-03-R2
- ./configure
- make && make plugins
- sudo make suidinstall
- sudo make plugins-install
+ sudo apt-get install libpcap0.8-dev libcap-dev pkg-config \
+ build-essential libnl-dev libncurses-dev libpcre3-dev \
+ libpcap-dev libcap-dev
+ wget http://www.kismetwireless.net/code/kismet-2011-03-R2.tar.gz
+ tar xf kismet-2011-03-R2.tar.gz
+ ln -s ubertooth-2012-10-R1/host/kismet/plugin-ubertooth kismet-2011-03-R2/
+ cd kismet-2011-03-R2
+ ./configure
+ make && make plugins
+ sudo make suidinstall
+ sudo make plugins-install
+ Add "pcapbtbb" to the "logtypes=..." line in kismet.conf
</pre>
-
+<br />
<h3>Wireshark</h3>
<p>The Wireshark plugin allows Bluetooth baseband traffic that has been captured
using Kismet to be analysed and disected within the Wireshark GUI. It is built
separately from the rest of the Ubertooth and libbtbb software:</p>
<pre>
- sudo apt-get install wireshark wireshark-dev libwireshark1 libwireshark-dev
- cd libbtbb-2012-10-R1/wireshark/plugins/btbb
- cmake -DCMAKE_INSTALL_LIBDIR=/usr/lib/wireshark/libwireshark1/plugins .
- make
- sudo make install
- Add "pcapbtbb" to the "logtypes=..." line in kismet.conf
+ sudo apt-get install wireshark wireshark-dev \
+ libwireshark1 libwireshark-dev
+ cd libbtbb-2012-10-R1/wireshark/plugins/btbb
+ cmake -DCMAKE_INSTALL_LIBDIR=/usr/lib/wireshark/libwireshark1/plugins .
+ make
+ sudo make install
</pre>
<p>This completes the install of the Ubertooth tools, the next step is to
@@ -106,26 +110,27 @@ useful to update the <a href="#firmware">firmware</a> on the Ubertooth.</p>
<p>There are some prerequisites that can be installed from the yum repositories
on RedHat based systems:</p>
<pre>
- su -c "yum install libusb1-devel make gcc pyside-tools pyusb wget tar"
+ su -c "yum install libusb1-devel make gcc pyside-tools \
+ pyusb wget tar"
</pre>
<p>Next the Bluetooth baseband library (libbtbb) needs to be built for the
Ubertooth tools to decode Bluetooth packets:</p>
<pre>
- wget http://sourceforge.net/projects/libbtbb/files/libbtbb-2012-10-R1.tar.xz/download -O libbtbb-2012-10-R1.tar.xz
- tar xf libbtbb-2012-10-R1.tar.xz
- cd libbtbb-2012-10-R1
- make
- su -c "make install"
+ wget http://sourceforge.net/projects/libbtbb/files/libbtbb-2012-10-R1.tar.xz/download -O libbtbb-2012-10-R1.tar.xz
+ tar xf libbtbb-2012-10-R1.tar.xz
+ cd libbtbb-2012-10-R1
+ make
+ su -c "make install"
</pre>
</pre>
<p>If using the ubertooth-follow tool, the Bluetooth library headers are
required and the tools need to be built with the "clock_debug" flag set:</p>
<pre>
- su -c "yum install libbluetooth-dev"
- cd ubertooth-2012-10-R1/host
- make clock_debug=true
- sudo make clock_debug=true install
+ su -c "yum install libbluetooth-dev"
+ cd ubertooth-2012-10-R1/host
+ make clock_debug=true
+ sudo make clock_debug=true install
</pre>
<br />
@@ -134,10 +139,10 @@ required and the tools need to be built with the "clock_debug" flag set:</p>
Bluetooth sniffing tools and firmware update. All three are built and installed
by default using the following method:</p>
<pre>
- wget http://sourceforge.net/projects/ubertooth/files/ubertooth-2012-10-R1.tar.xz/download -O ubertooth-2012-10-R1.tar.xz
- tar xf ubertooth-2012-10-R1.tar.xz
- cd ubertooth-2012-10-R1/host/bluetooth_rxtx
- make
+ wget http://sourceforge.net/projects/ubertooth/files/ubertooth-2012-10-R1.tar.xz/download -O ubertooth-2012-10-R1.tar.xz
+ tar xf ubertooth-2012-10-R1.tar.xz
+ cd ubertooth-2012-10-R1/host/bluetooth_rxtx
+ make
</pre>
<br />
@@ -146,28 +151,29 @@ by default using the following method:</p>
development package, so in order to build the Ubertooth plugin it is nessecary
to compile Kismet from source:</p>
<pre>
- su -c "yum install libpcap-devel libcap-devel libnl-devel libstdc++-devel gcc-c++ ncurses-devel"
- wget http://www.kismetwireless.net/code/kismet-2011-03-R2.tar.gz
- tar xf kismet-2011-03-R2.tar.gz
- ln -s ubertooth-2012-10-R1/host/kismet/plugin-ubertooth kismet-2011-03-R2/
- cd kismet-2011-03-R2
- ./configure
- make && make plugins
- su -c "make suidinstall"
- su -c "make plugins-install"
- Add "pcapbtbb" to the "logtypes=..." line in kismet.conf
+ su -c "yum install libpcap-devel libcap-devel libnl-devel \
+ libstdc++-devel gcc-c++ ncurses-devel"
+ wget http://www.kismetwireless.net/code/kismet-2011-03-R2.tar.gz
+ tar xf kismet-2011-03-R2.tar.gz
+ ln -s ubertooth-2012-10-R1/host/kismet/plugin-ubertooth kismet-2011-03-R2/
+ cd kismet-2011-03-R2
+ ./configure
+ make && make plugins
+ su -c "make suidinstall"
+ su -c "make plugins-install"
+ Add "pcapbtbb" to the "logtypes=..." line in kismet.conf
</pre>
-
+<br />
<h3>Wireshark</h3>
<p>The Wireshark plugin allows Bluetooth baseband traffic that has been captured
using Kismet to be analysed and disected within the Wireshark GUI. It is built
separately from the rest of the Ubertooth and libbtbb software:</p>
<pre>
- su -c "yum install wireshark wireshark-devel"
- cd libbtbb-2012-10-R1/wireshark/plugins/btbb
- cmake .
- make
- su -c "make install"
+ su -c "yum install wireshark wireshark-devel"
+ cd libbtbb-2012-10-R1/wireshark/plugins/btbb
+ cmake .
+ make
+ su -c "make install"
</pre>
@@ -176,6 +182,19 @@ look at the <a href="../start">getting started</a> guide. It may also be
useful to update the <a href="#firmware">firmware</a> on the Ubertooth.</p>
+<h2 id="gentoo">Gentoo</h2>
+<p>Libbtbb, Ubertooth and the Kismet and Wireshark plugins are all supported
+out of the box in Gentoo. To install, simply use emerge as follows:</p>
+<pre>
+ emerge libbtbb
+ emerge kismet-ubertooth
+</pre>
+<p>This completes the install of the Ubertooth tools, the next step is to
+look at the <a href="../start">getting started</a> guide. It may also be
+useful to update the <a href="#firmware">firmware</a> on the Ubertooth.</p>
+<br />
+
+
<h2 id="windows">Windows</h2>
<p>Experimental Windows support is available under Cygwin. Although this is
unsupported.</p>
@@ -186,21 +205,21 @@ unsupported.</p>
http://cygwin.com/setup.exe</a> and install it. When installing Cygwin, the
following tools are required:</p>
<pre>
- gcc
- automake
- python
- libusb-1.0
- libusb-1.0-dev
+ gcc
+ automake
+ python
+ libusb-1.0
+ libusb-1.0-dev
</pre>
<p>Libbtbb needs to be built before the Ubertooth tools, it is available from
SourceForge as follows:</p>
<pre>
- wget http://sourceforge.net/projects/libbtbb/files/libbtbb-2012-10-R1.tar.xz/download -O libbtbb-2012-10-R1.tar.xz
- tar xf libbtbb-2012-10-R1.tar.xz
- cd libbtbb-2012-10-R1
- make
- make cygwin-install
+ wget http://sourceforge.net/projects/libbtbb/files/libbtbb-2012-10-R1.tar.xz/download -O libbtbb-2012-10-R1.tar.xz
+ tar xf libbtbb-2012-10-R1.tar.xz
+ cd libbtbb-2012-10-R1
+ make
+ make cygwin-install
</pre>
<br />
@@ -209,10 +228,11 @@ SourceForge as follows:</p>
Bluetooth sniffing tools and firmware upload. All three are built and installed
by default using the following method:</p>
<pre>
- wget http://sourceforge.net/projects/ubertooth/files/ubertooth-2012-10-R1.tar.xz/download -O ubertooth-2012-10-R1.tar.xz
- tar xf ubertooth-2012-10-R1.tar.xz
- cd ubertooth-2012-10-R1/host/bluetooth_rxtx
- make
+ wget http://sourceforge.net/projects/ubertooth/files/ubertooth-2012-10-R1.tar.xz/download -O ubertooth-2012-10-R1.tar.xz
+ tar xf ubertooth-2012-10-R1.tar.xz
+ cd ubertooth-2012-10-R1/host/bluetooth_rxtx
+ make
+ make cygwin-install
</pre>
<br />
@@ -232,26 +252,26 @@ useful to update the <a href="#firmware">firmware</a> on the Ubertooth.</p>
<p>There are some prerequisites that can be installed from the
<a href="http://www.macports.org/">MacPorts</a> systems:</p>
<pre>
- sudo apt-get install libusb-1.0-0-dev make gcc pyside-tools
+ sudo port install libusb py26-pyside-tools py26-pyusb-devel
</pre>
<p>PyUSB is not yet available from the apt repositories, so it must be
downloaded and built from sourece as follows:</p>
<pre>
- wget http://sourceforge.net/projects/pyusb/files/PyUSB%201.0/1.0.0-alpha-2/pyusb-1.0.0a2.tar.gz/download -O pyusb-1.0.0a2.tar.gz
- tar xvf pyusb-1.0.0a2.tar.gz
- cd pyusb-1.0.0a2
- sudo python setup.py install
+ wget http://sourceforge.net/projects/pyusb/files/PyUSB%201.0/1.0.0-alpha-2/pyusb-1.0.0a2.tar.gz/download -O pyusb-1.0.0a2.tar.gz
+ tar xvf pyusb-1.0.0a2.tar.gz
+ cd pyusb-1.0.0a2
+ sudo python setup.py install
</pre>
<p>Next the Bluetooth baseband library (libbtbb) needs to be built for the
Ubertooth tools to decode Bluetooth packets:</p>
<pre>
- wget http://sourceforge.net/projects/libbtbb/files/libbtbb-2012-10-R1.tar.xz/download -O libbtbb-2012-10-R1.tar.xz
- tar xf libbtbb-2012-10-R1.tar.xz
- cd libbtbb-2012-10-R1
- make osx
- sudo make osx-install
+ wget http://sourceforge.net/projects/libbtbb/files/libbtbb-2012-10-R1.tar.xz/download -O libbtbb-2012-10-R1.tar.xz
+ tar xf libbtbb-2012-10-R1.tar.xz
+ cd libbtbb-2012-10-R1
+ make osx
+ sudo make osx-install
</pre>
<br />
@@ -260,49 +280,41 @@ Ubertooth tools to decode Bluetooth packets:</p>
Bluetooth sniffing tools and firmware update. All three are built and installed
by default using the following method:</p>
<pre>
- wget http://sourceforge.net/projects/ubertooth/files/ubertooth-2012-10-R1.tar.xz/download -O ubertooth-2012-10-R1.tar.xz
- tar xf ubertooth-2012-10-R1.tar.xz
- cd ubertooth-2012-10-R1/host
- make
- sudo make install
-</pre>
-<p>If using the ubertooth-follow tool, the Bluetooth library headers are
-required and the tools need to be built with the "clock_debug" flag set:</p>
-<pre>
- sudo apt-get install libbluetooth-dev
- cd ubertooth-2012-10-R1/host
- make clock_debug=true
- sudo make clock_debug=true install
+ wget http://sourceforge.net/projects/ubertooth/files/ubertooth-2012-10-R1.tar.xz/download -O ubertooth-2012-10-R1.tar.xz
+ tar xf ubertooth-2012-10-R1.tar.xz
+ cd ubertooth-2012-10-R1/host
+ make
+ sudo make osx-install
</pre>
<br />
<h3>Kismet</h3>
-<p>The version if kismet provided by Debian/Ubuntu is 2008-05-R1, which is too
-old to support the Ubertooth plugin. In order to use Ubertooth with Kismet it
-is nessecary to compile Kismet from source:</p>
+<p>In order to use Ubertooth with Kismet it is nessecary to compile Kismet from
+source, with the plugin linked to the source tree:</p>
<pre>
- First, create a kismet user group
- wget http://www.kismetwireless.net/code/kismet-2011-03-R2.tar.gz
- tar xf kismet-2011-03-R2.tar.gz
- ln -s ubertooth-2012-10-R1/host/kismet/plugin-ubertooth kismet-2011-03-R2/
- cd kismet-2011-03-R2
- ./configure --prefix=/opt/local --with-suidgroup=kismet
- make && make plugins
- sudo make suidinstall
- sudo make plugins-install
- Add "pcapbtbb" to the "logtypes=..." line in kismet.conf
+ First, create a kismet user group
+ wget http://www.kismetwireless.net/code/kismet-2011-03-R2.tar.gz
+ tar xf kismet-2011-03-R2.tar.gz
+ ln -s ubertooth-2012-10-R1/host/kismet/plugin-ubertooth kismet-2011-03-R2/
+ cd kismet-2011-03-R2
+ ./configure --prefix=/opt/local --with-suidgroup=kismet
+ make && make plugins
+ sudo make suidinstall
+ sudo make plugins-install
+ Add "pcapbtbb" to the "logtypes=..." line in kismet.conf
</pre>
+<br />
<h3>Wireshark</h3>
<p>The Wireshark plugin allows Bluetooth baseband traffic that has been captured
using Kismet to be analysed and disected within the Wireshark GUI. It is built
separately from the rest of the Ubertooth and libbtbb software:</p>
<pre>
- sudo apt-get install wireshark wireshark-dev libwireshark1 libwireshark-dev
- cd libbtbb-2012-10-R1/wireshark/plugins/btbb
- cmake -DCMAKE_INSTALL_LIBDIR=/usr/lib/wireshark/libwireshark1/plugins .
- make
- sudo make install
+ sudo port install wireshark wireshark-devel
+ cd libbtbb-2012-10-R1/wireshark/plugins/btbb
+ cmake -DCMAKE_INSTALL_LIBDIR=/usr/lib/wireshark/libwireshark1/plugins .
+ make
+ sudo make install
</pre>
<p>This completes the install of the Ubertooth tools, the next step is to
@@ -314,43 +326,42 @@ useful to update the <a href="#firmware">firmware</a> on the Ubertooth.</p>
<h2>Firmware</h2>
<p>Binary firmware images are available as part of the release package. They
are specific to the version of the Ubertooth being used (Ubertooth one,
-Ubertooth zero, Toorcon 13 badge). In order to write a firmware image to a
-device, it first needs to be put in to flashing mode, then the image is written
-using the ubertooth-dfu tool:</p>
+Ubertooth zero, Toorcon 13 badge). To write a firmware image to a device, use
+the ubertooth-dfu tool:</p>
<pre>
- ubertooth-util -f
- ubertooth-dfu --write bluetooth_rxtx.dfu --detach
+ ubertooth-dfu --write bluetooth_rxtx.dfu --detach
</pre>
<br />
<h3>Building firmware</h3>
<p>Firmware images are built using the Arm Cortex M3 version of gcc, which is
available <a href="https://launchpad.net/gcc-arm-embedded">here</a>.</p>
<pre>
- wget https://launchpad.net/gcc-arm-embedded/4.6/4.6-2012-q2-update/+download/gcc-arm-none-eabi-4_6-2012q2-20120614.tar.bz2
- tar xf gcc-arm-none-eabi-4_6-2012q2-20120614.tar.bz2
- sudo cp -R gcc-arm-none-eabi-4_6-2012q2 /opt/
+ wget https://launchpad.net/gcc-arm-embedded/4.6/4.6-2012-q2-update/+download/gcc-arm-none-eabi-4_6-2012q2-20120614.tar.bz2
+ tar xf gcc-arm-none-eabi-4_6-2012q2-20120614.tar.bz2
+ sudo cp -R gcc-arm-none-eabi-4_6-2012q2 /opt/
</pre>
<p>You will probably need to add the compiler to your path as follows:</p>
<pre>
- export PATH=$PATH:/opt/gcc-arm-none-eabi-4_6-2012q2/bin
+ export PATH=$PATH:/opt/gcc-arm-none-eabi-4_6-2012q2/bin
</pre>
<p>To add this permanently to your path, run the following:</p>
<pre>
- echo "export PATH=$PATH:/opt/gcc-arm-none-eabi-4_6-2012q2/bin" >> ~/.bashrc
+ echo "export PATH=$PATH:/opt/gcc-arm-none-eabi-4_6-2012q2/bin" >> ~/.bashrc
</pre>
<br />
<p>In order to flash a firmware image to the Ubertooth the ubertooth-dfu tool
can be used; it should have been installed along with the Ubertooth tools
earlier. It is used as follows:</p>
<pre>
- ubertooth-dfu --write bluetooth_rxtx --detach
+ ubertooth-dfu --write bluetooth_rxtx --detach
</pre>
<br />
<p>If for some reason the image flashed to the Ubertooth makes the device
unresponsive the inbuilt bootloader allows the device to be reflashed. To
trigger bootloader (flashing) mode, use the following steps:</p>
<pre>
- Disconnect the Ubertooth from the host system
- Using a paperclip, short pins 1 and 3 on the expansion header (<a href="../../hardware/one/#pins">shown here</a>)
+ Disconnect the Ubertooth from the host system
+ Using a paperclip, short pins 1 and 3 on the expansion header (<a href="../../hardware/one/#pins">shown here</a>)
+ Reconnect to the host system
</pre>
<br />