summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--firmware/common.mk10
1 files changed, 5 insertions, 5 deletions
diff --git a/firmware/common.mk b/firmware/common.mk
index e6b6245..44a5e00 100644
--- a/firmware/common.mk
+++ b/firmware/common.mk
@@ -52,13 +52,13 @@ ifeq ($(DISABLE_TX), )
UBERTOOTH_OPTS += -DTX_ENABLE
endif
-DIRTY = $(shell git status -s --untracked-files=no)
-ifneq ($(DIRTY), )
- DIRTY_FLAG = *
-endif
+#DIRTY = $(shell git status -s --untracked-files=no)
+#ifneq ($(DIRTY), )
+# DIRTY_FLAG = *
+#endif
# automatic git version when working out of git
-GIT_REVISION ?= -D'GIT_REVISION="git-$(shell git log --pretty=format:'%h' -n 1)$(DIRTY_FLAG)"'
+GIT_REVISION ?= -D'GIT_REVISION="REPLACE_ME_WITH_VERSION"'
# compile info
COMPILE_BY ?= -D'COMPILE_BY="$(shell whoami)"'