summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorGerrit Pape <pape@smarden.org>2009-10-13 22:57:51 +0000
committerDmitry Bogatov <KAction@debian.org>2018-11-29 05:18:33 +0000
commit14d23cfcb6ead69c05e2e36c854b33e27aa44787 (patch)
treeda65c5de16bc0779936fa6bf8c28be1a596569e9 /debian
parentd98777c7f350bf18c2673e312ae1f9adb4d16eec (diff)
Import Debian changes 1:0.88-3
ucspi-tcp (1:0.88-3) unstable; urgency=low * ucspi-tcp-ipv6/diff/0001-rblsmtpd.c...diff, 0002-Makefile...diff, 0003-Apply-fefe-s-ucspi-tcp-0.88-ipv6.diff19-ipv6-patch.diff: new: ucspi-tcp with IPv6 support added. * debian/control: new package ucspi-tcp-ipv6: ucspi-tcp with IPv6 support added (thx fefe; closes: #534925). * debian/rules: build and install new package ucspi-tcp-ipv6.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog11
-rw-r--r--debian/control35
-rwxr-xr-xdebian/rules81
3 files changed, 118 insertions, 9 deletions
diff --git a/debian/changelog b/debian/changelog
index 9ff4269..79c1399 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,14 @@
+ucspi-tcp (1:0.88-3) unstable; urgency=low
+
+ * ucspi-tcp-ipv6/diff/0001-rblsmtpd.c...diff, 0002-Makefile...diff,
+ 0003-Apply-fefe-s-ucspi-tcp-0.88-ipv6.diff19-ipv6-patch.diff: new:
+ ucspi-tcp with IPv6 support added.
+ * debian/control: new package ucspi-tcp-ipv6: ucspi-tcp with IPv6
+ support added (thx fefe; closes: #534925).
+ * debian/rules: build and install new package ucspi-tcp-ipv6.
+
+ -- Gerrit Pape <pape@smarden.org> Tue, 13 Oct 2009 22:57:51 +0000
+
ucspi-tcp (1:0.88-2) unstable; urgency=low
* debian/rules: install: force remove also auto_home.c before re-doing
diff --git a/debian/control b/debian/control
index 069b760..4e38073 100644
--- a/debian/control
+++ b/debian/control
@@ -35,3 +35,38 @@ Description: command-line tools for building TCP client-server applications
tcpserver and tcpclient conform to UCSPI, the UNIX Client-Server Program
Interface, using the TCP protocol. UCSPI tools are
available for several different networks.
+
+Package: ucspi-tcp-ipv6
+Architecture: any
+Depends: ${shlibs:Depends}
+Replaces: ucspi-tcp-doc
+Conflicts: ucspi-tcp
+Provides: ucspi-tcp
+Description: command-line tools for building TCP client-server applications (IPv6)
+ ucspi-tcp-ipv6 is the ucspi-tcp package with IPv6 support added.
+ .
+ tcpserver waits for incoming connections and, for each connection, runs a
+ program of your choice. Your program receives environment variables showing
+ the local and remote host names, IP addresses, and port numbers.
+ .
+ tcpserver offers a concurrency limit to protect you from running out of
+ processes and memory. When you are handling 40 (by default) simultaneous
+ connections, tcpserver smoothly defers acceptance of new connections.
+ .
+ tcpserver also provides TCP access control features, similar to
+ tcp-wrappers/tcpd's hosts.allow but much faster. Its access control rules
+ are compiled into a hashed format with cdb, so it can easily deal with
+ thousands of different hosts.
+ .
+ This package includes a recordio tool that monitors all the input and output
+ of a server.
+ .
+ tcpclient makes a TCP connection and runs a program of your choice. It sets
+ up the same environment variables as tcpserver.
+ .
+ This package includes several sample clients built on top of tcpclient:
+ who@, date@, finger@, http@, tcpcat, and mconnect.
+ .
+ tcpserver and tcpclient conform to UCSPI, the UNIX Client-Server Program
+ Interface, using the TCP protocol. UCSPI tools are
+ available for several different networks.
diff --git a/debian/rules b/debian/rules
index fbd14ee..fde562a 100755
--- a/debian/rules
+++ b/debian/rules
@@ -6,32 +6,55 @@ ifneq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
endif
DIR=$(shell pwd)/debian/ucspi-tcp
+DIRIPV6=$(shell pwd)/debian/ucspi-tcp-ipv6
-patch: deb-checkdir patch-stamp
-patch-stamp:
+configure: deb-checkdir configure-stamp
+configure-stamp:
+ for i in `cat FILES`; do \
+ test -r ucspi-tcp-ipv6/$$i || \
+ cp -p $$i ucspi-tcp-ipv6/$$i || exit 1; \
+ done
+ touch configure-stamp
+
+patch: deb-checkdir patch-stamp ucspi-tcp-ipv6/patch-stamp
+patch-stamp: configure-stamp
for i in `ls -1 debian/diff/*.diff || :`; do \
patch -p1 <$$i || exit 1; \
done
touch patch-stamp
+ucspi-tcp-ipv6/patch-stamp: configure-stamp
+ for i in `ls -1 ucspi-tcp-ipv6/diff/*.diff || :`; do \
+ (cd ucspi-tcp-ipv6/ && patch -p1) <$$i || exit 1; \
+ done
+ touch ucspi-tcp-ipv6/patch-stamp
-build: deb-checkdir build-stamp
+build: deb-checkdir build-stamp ucspi-tcp-ipv6/build-stamp
build-stamp: patch-stamp
test -r conf-home'{orig}' || cp -f conf-home conf-home'{orig}'
echo /usr >conf-home
$(MAKE)
touch build-stamp
+ucspi-tcp-ipv6/build-stamp: ucspi-tcp-ipv6/patch-stamp
+ test -r ucspi-tcp-ipv6/conf-home'{orig}' || \
+ cp -f ucspi-tcp-ipv6/conf-home ucspi-tcp-ipv6/conf-home'{orig}'
+ echo /usr >ucspi-tcp-ipv6/conf-home
+ $(MAKE) -Cucspi-tcp-ipv6/
+ touch ucspi-tcp-ipv6/build-stamp
clean: deb-checkdir deb-checkuid
rm -f `cat TARGETS`
+ for i in ucspi-tcp-ipv6/*; do test -d $$i || rm -f $$i; done
test ! -e patch-stamp || \
for i in `ls -1r debian/diff/*.diff || :`; do patch -p1 -R <$$i; done
- rm -f patch-stamp build-stamp
- rm -rf '$(DIR)'
+ rm -f configure-stamp patch-stamp build-stamp \
+ ucspi-tcp-ipv6/patch-stamp ucspi-tcp-ipv6/build-stamp
+ rm -rf '$(DIR)' '$(DIRIPV6)'
rm -f debian/files debian/substvars changelog
test ! -r conf-home'{orig}' || mv -f conf-home'{orig}' conf-home
-install: deb-checkdir deb-checkuid build-stamp
- rm -rf '$(DIR)'
+install: deb-checkdir deb-checkuid build-stamp ucspi-tcp-ipv6/build-stamp
+ rm -rf '$(DIR)' '$(DIRIPV6)'
+ # ucspi-tcp
# programs
install -d -m0755 '$(DIR)'/usr/bin
test -r conf-home'{orig}' || cp conf-home conf-home'{orig}'
@@ -55,16 +78,56 @@ install: deb-checkdir deb-checkuid build-stamp
install -m0644 $$i '$(DIR)'/usr/share/man/man1/ && \
gzip -9 '$(DIR)'/usr/share/man/man1/$${i##*/} || exit 1; \
done
+ # ucspi-tcp-ipv6
+ # programs
+ install -d -m0755 '$(DIRIPV6)'/usr/bin
+ test -r ucspi-tcp-ipv6/conf-home'{orig}' || \
+ cp ucspi-tcp-ipv6/conf-home ucspi-tcp-ipv6/conf-home'{orig}'
+ echo '$(DIRIPV6)'/usr >ucspi-tcp-ipv6/conf-home
+ for i in install instcheck install.o instcheck.o hier.o auto_home.c \
+ auto_home.o; do \
+ rm -f ucspi-tcp-ipv6/$$i; \
+ done
+ $(MAKE) -Cucspi-tcp-ipv6/ install instcheck
+ mv -f ucspi-tcp-ipv6/conf-home'{orig}' ucspi-tcp-ipv6/conf-home
+ (cd ucspi-tcp-ipv6/ && ./install)
+ (cd ucspi-tcp-ipv6/ && ./instcheck)
+ # fix up permissions
+ chmod g-s '$(DIRIPV6)'/usr '$(DIRIPV6)'/usr/bin \
+ '$(DIRIPV6)'/usr/man '$(DIRIPV6)'/usr/man/man1
+ # strip
+ for i in addcr argv0 delcr fixcrio mconnect-io rblsmtpd recordio \
+ tcpclient tcprules tcprulescheck tcpserver; do \
+ $(STRIP) -R .comment -R .note '$(DIRIPV6)'/usr/bin/$$i || exit 1; \
+ done
+ # manpages
+ install -d -m0755 '$(DIRIPV6)'/usr/share
+ rm -rf '$(DIRIPV6)'/usr/man/man5 # don't include tcp-environ(5)
+ mv '$(DIRIPV6)'/usr/man '$(DIRIPV6)'/usr/share/
+ for i in fixcrio.1 rblsmtpd.1 tcpcat.1; do \
+ install -m0644 debian/ucspi-tcp-man/$$i \
+ '$(DIRIPV6)'/usr/share/man/man1/; \
+ done
+ for i in '$(DIRIPV6)'/usr/share/man/man1/*.1; do \
+ gzip -9 $$i || exit 1; \
+ done
# changelog
test -r changelog || ln -s CHANGES changelog
binary: binary-arch binary-indep
-binary-arch: install ucspi-tcp.deb
+binary-arch: install ucspi-tcp.deb ucspi-tcp-ipv6.deb
+ rm -f debian/substvars
dpkg-shlibdeps '$(DIR)'/usr/bin/*
dpkg-gencontrol -isp -pucspi-tcp -P'$(DIR)'
dpkg -b '$(DIR)' ..
+ rm -f debian/substvars
+ dpkg-shlibdeps '$(DIRIPV6)'/usr/bin/*
+ dpkg-gencontrol -isp -pucspi-tcp-ipv6 -P'$(DIRIPV6)'
+ dpkg -b '$(DIRIPV6)' ..
+
binary-indep:
-.PHONY: patch build clean install binary-indep binary-arch binary
+.PHONY: configure patch ucspi-tcp-ipv6/patch build ucspi-tcp-ipv6/build \
+ clean install binary-indep binary-arch binary
include debian/implicit