summaryrefslogtreecommitdiff
path: root/dns_random.c
diff options
context:
space:
mode:
authorGerrit Pape <pape@smarden.org>2008-03-30 23:06:24 +0000
committerDmitry Bogatov <KAction@debian.org>2018-11-29 05:18:32 +0000
commita2670d6b2b9050b7d110ab7d732a65a96c9a03e3 (patch)
treeb76afb0f16d00d4d3a778d37518a8d52830baec4 /dns_random.c
parentea0237e72a0305379fa489dc18e93369e65ec5bd (diff)
Import Debian changes 1:0.88-1~bpo40+1
ucspi-tcp (1:0.88-1~bpo40+1) etch-backports; urgency=low * build for etch. ucspi-tcp (1:0.88-1) unstable; urgency=low * debian/changelog: add epoch 1 to supersede unofficial package. * debian/rules: remove target configure:; use glibc by default instead of dietlibc. * debian/control: no longer Build-Depends: dietlibc. * debian/gcc/: remove; obsolete. * debian/rules: install programs into /usr/bin/. * debian/rules: new target patch: apply diffs from debian/diff/, reverse apply in target clean:. * debian/diff/0001-error.h-include-errno.h-instead-of-extern-int.diff: new; error.h: '#include <errno.h>' instead of 'extern int errno;'. * debian/ucspi-tcp-man/: new; add manpages downloaded from http://smarden.org/pape/djb/manpages/ucspi-tcp-0.88-man-20020317.tar.gz. * debian/rules: install manpages from debian/ucspi-tcp-man/ into /usr/share/man/man1/. * debian/control: no longer Recommends: ucspi-tcp-doc; Replaces: ucspi-tcp-doc. * debian/implicit: add proper dependencies to support 'parallel build' through make -j (thx Daniel Schepler for the patch). * debian/rules: run dpkg-shlibdeps; remove debian/substvars in target clean:. * debian/control: Depends: ${shlibs:Depends}. * debian/control: Standards-Version: 3.7.2.2. * debian/copyright: rewrite copyright. * debian/ucspi-tcp.README.Debian: remove reference to unofficial packages. * debian/control: minor updates to descriptions. * debian/diff/0002-rblsmtpd.c-don-t-use-a-the-default-rbl.maps.vix.com.diff: new; rblsmtpd.c: don't use a the default rbl.maps.vix.com if run without -r switch. * first upload to Debian/main (closes: #459318). * debian/ucspi-tcp.NEWS.Debian: new; package introduced to Debian/main, mention how to put on hold if upgrade from non-free is not desired. ucspi-tcp (0.88-zarge2) sarge; urgency=low * build against sarge's dietlibc-dev (0.28-3). ucspi-tcp (0.88-zarge1) sarge; urgency=low * debian/rules: minor cleanup. * debian/implicit: update to revision 1.10. ucspi-tcp (0.88-zarge0.3) sarge; urgency=low * debian/rules: stop using debhelper, use implicit rules. * debian/implicit: new; implicit Makefile rules. * debian/README.Debian, debian/docs: rename to debian/ucspi-tcp.*. * debian/dirs: remove; obsolete. * debian/copyright: minor. * debian/control: no longer Build-Depends: dephelper; remove Standards-Version. ucspi-tcp (0.88-zarge0.2) sarge; urgency=low * use diet libc. * debian/rules: set up diet program as c compiler wrapper; conditionally overwrite PATH to have diet program used as c compiler wrapper; minor cleanup. * debian/gcc/gcc*: new; diet program as c compiler wrapper. * debian/control: Build-Depends: dietlibc-dev; no longer Depends: ${shlibs:Depends}. ucspi-tcp (0.88-woody0.1) woody; urgency=low * woody package; new Standards-Version: 3.5.2. * just _recommend_ ucspi-tcp-doc.
Diffstat (limited to 'dns_random.c')
-rw-r--r--dns_random.c3
1 files changed, 1 insertions, 2 deletions
diff --git a/dns_random.c b/dns_random.c
index 2158ed4..b9892b4 100644
--- a/dns_random.c
+++ b/dns_random.c
@@ -1,4 +1,3 @@
-#include <unistd.h>
#include "dns.h"
#include "taia.h"
#include "uint32.h"
@@ -30,7 +29,7 @@ static void surf(void)
}
}
-void dns_random_init(const char data[128])
+void dns_random_init(char data[128])
{
int i;
struct taia t;