summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules82
1 files changed, 4 insertions, 78 deletions
diff --git a/debian/rules b/debian/rules
index 8cff2b1..5376477 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,81 +1,7 @@
#!/usr/bin/make -f
+# -*- makefile -*-
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
-configure: configure-stamp
-configure-stamp:
- dh_testdir mkudffs/main.c
- dh_autoreconf
- ./configure --prefix=/usr --mandir=\$${prefix}/share/man \
- --infodir=\$${prefix}/share/info
- touch configure-stamp
-
-build: build-stamp
-
-patch-apply:
- for f in `ls debian/patch-*.diff`; do \
- echo "Applying patch \`$$f'"; \
- patch --forward --dry -p1 <"$$f" \
- && patch --quiet --forward -p1 <"$$f"; \
- done
-patch-unapply:
- -for f in `ls -r debian/patch-*.diff`; do \
- echo "Reversing patch \`$$f'"; \
- patch --forward --reverse --dry -p1 <"$$f" \
- && patch --quiet --forward --reverse -p1 <"$$f"; \
- done
-
-
-build-stamp: configure-stamp
- dh_testdir mkudffs/main.c
- $(MAKE) -f debian/rules patch-apply
- $(MAKE)
- touch build-stamp
-
-clean:
- dh_testdir mkudffs/main.c
- dh_testroot
- rm -f build-stamp configure-stamp
- -$(MAKE) distclean
- dh_autoreconf_clean
- -$(MAKE) -f debian/rules patch-unapply
- rm -f include/stamp-h include/stamp-h[0-9]*
- dh_clean
-
-install: build
- dh_testdir mkudffs/main.c
- dh_testroot
- dh_clean -k
- dh_installdirs
- $(MAKE) install DESTDIR=$(CURDIR)/debian/udftools
- rm -rf debian/udftools/usr/lib # libudffs not needed
- rm -f debian/udftools/usr/bin/udffsck # Does nothing ATM
- sed 's%^\(\.TH .*\) 8 %\1 1 %' <debian/udftools/usr/share/man/man8/mkudffs.8 >debian/udftools/usr/share/man/man1/mkudffs.1
- sed 's%^\(\.TH .*\) 8 %\1 1 %' <debian/udftools/usr/share/man/man8/pktsetup.8 >debian/udftools/usr/share/man/man1/pktsetup.1
- rm -rf debian/udftools/usr/share/man/man8
-
-# Build architecture-independent files here.
-binary-indep: build install
-
-# Build architecture-dependent files here.
-binary-arch: build install
- dh_testdir mkudffs/main.c
- dh_testroot
- dh_installdebconf
- dh_installdocs
- dh_installchangelogs
- dh_installinit
- dh_link
- dh_strip
- dh_compress
- dh_fixperms
- dh_installdeb
- dh_shlibdeps
- dh_gencontrol
- dh_md5sums
- dh_builddeb
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install configure \
- patch-apply patch-unapply
+%:
+ dh $@ --with autoreconf