summaryrefslogtreecommitdiff
path: root/wrudf/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'wrudf/Makefile.am')
-rw-r--r--wrudf/Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/wrudf/Makefile.am b/wrudf/Makefile.am
index fe1c269..4224b13 100644
--- a/wrudf/Makefile.am
+++ b/wrudf/Makefile.am
@@ -1,5 +1,10 @@
bin_PROGRAMS = wrudf
-wrudf_LDADD = $(top_builddir)/libudffs/libudffs.la -lreadline
+wrudf_LDADD = $(top_builddir)/libudffs/libudffs.la
wrudf_SOURCES = wrudf.c wrudf-cmnd.c wrudf-desc.c wrudf-cdrw.c wrudf-cdr.c ide-pc.c wrudf.h ide-pc.h ../include/ecma_167.h ../include/osta_udf.h ../include/bswap.h
-AM_CPPFLAGS = -I$(top_srcdir)/include -D_GNU_SOURCE -DDEBUG
+AM_CPPFLAGS = -I$(top_srcdir)/include
+
+if USE_READLINE
+wrudf_LDADD += -lreadline
+AM_CPPFLAGS += -DUSE_READLINE
+endif