summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Vogelgesang <matthias.vogelgesang@kit.edu>2013-01-31 10:28:46 +0100
committerMatthias Vogelgesang <matthias.vogelgesang@kit.edu>2013-01-31 10:28:46 +0100
commit2a2f2354e16a0e53f1bc23a03ea51d0eec007210 (patch)
treee9dcbe81bd480131c0e7a206c90732aa587fae94
parentee65b87173d08a6561a8d315c908dfbec3cd421c (diff)
Allow a single ufo/ufo.h header only
From a user perspective it is simpler to remember to include ufo/ufo.h. This is also more future-proof if header file names or dependencies change.
-rw-r--r--src/CMakeLists.txt51
-rw-r--r--src/ufo-arch-graph.h5
-rw-r--r--src/ufo-buffer.h4
-rw-r--r--src/ufo-config.h4
-rw-r--r--src/ufo-configurable.h4
-rw-r--r--src/ufo-cpu-node.h4
-rw-r--r--src/ufo-cpu-task-iface.h4
-rw-r--r--src/ufo-dummy-task.h5
-rw-r--r--src/ufo-gpu-node.h4
-rw-r--r--src/ufo-gpu-task-iface.h4
-rw-r--r--src/ufo-graph.h5
-rw-r--r--src/ufo-group.h5
-rw-r--r--src/ufo-input-task.h4
-rw-r--r--src/ufo-node.h4
-rw-r--r--src/ufo-output-task.h5
-rw-r--r--src/ufo-plugin-manager.h6
-rw-r--r--src/ufo-profiler.h4
-rw-r--r--src/ufo-remote-node.h4
-rw-r--r--src/ufo-remote-task.h5
-rw-r--r--src/ufo-resources.h5
-rw-r--r--src/ufo-scheduler.h5
-rw-r--r--src/ufo-task-graph.h5
-rw-r--r--src/ufo-task-iface.h5
-rw-r--r--src/ufo-task-node.h4
-rw-r--r--src/ufo.h52
-rw-r--r--tests/test-config.c3
-rw-r--r--tests/test-graph.c5
-rw-r--r--tests/test-profiler.c2
-rw-r--r--tests/test-suite.c9
-rw-r--r--tools/runjson.c7
-rw-r--r--tools/ufo-server.c11
31 files changed, 183 insertions, 61 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 13565ab..a7e7b5c 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -61,25 +61,25 @@ find_program(GLIB2_MKENUMS glib-mkenums REQUIRED)
# --- Add enum generation targets ---------------------------------------------
add_custom_command(
- OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/ufo-enums.h
- COMMAND ${GLIB2_MKENUMS}
- ARGS
- --template ufo-enums.h.template
- ${ufocore_HDRS} > ${CMAKE_CURRENT_BINARY_DIR}/ufo-enums.h
- WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}
- DEPENDS ${ufocore_HDRS}
- ${CMAKE_CURRENT_SOURCE_DIR}/ufo-enums.h.template
+ OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/ufo-enums.h
+ COMMAND ${GLIB2_MKENUMS}
+ ARGS
+ --template ufo-enums.h.template
+ ${ufocore_HDRS} > ${CMAKE_CURRENT_BINARY_DIR}/ufo-enums.h
+ WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}
+ DEPENDS ${ufocore_HDRS}
+ ${CMAKE_CURRENT_SOURCE_DIR}/ufo-enums.h.template
)
add_custom_command(
- OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/ufo-enums.c
- COMMAND ${GLIB2_MKENUMS}
- ARGS
- --template ufo-enums.c.template
- ${ufocore_HDRS} > ${CMAKE_CURRENT_BINARY_DIR}/ufo-enums.c
- WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}
- DEPENDS ${ufocore_HDRS} ${CMAKE_CURRENT_BINARY_DIR}/ufo-enums.h
- ${CMAKE_CURRENT_SOURCE_DIR}/ufo-enums.c.template
+ OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/ufo-enums.c
+ COMMAND ${GLIB2_MKENUMS}
+ ARGS
+ --template ufo-enums.c.template
+ ${ufocore_HDRS} > ${CMAKE_CURRENT_BINARY_DIR}/ufo-enums.c
+ WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}
+ DEPENDS ${ufocore_HDRS} ${CMAKE_CURRENT_BINARY_DIR}/ufo-enums.h
+ ${CMAKE_CURRENT_SOURCE_DIR}/ufo-enums.c.template
)
# --- Target ------------------------------------------------------------------
@@ -88,14 +88,16 @@ get_property(LIB64 GLOBAL PROPERTY FIND_LIBRARY_USE_LIB64_PATHS)
set(LIBDIR "lib${LIB_SUFFIX}")
set(INCLUDEDIR "include/ufo")
+add_definitions(-DUFO_COMPILATION)
+
if(CMAKE_BUILD_TYPE MATCHES "Release")
add_definitions(-DG_DISABLE_ASSERT)
endif()
add_library(ufo SHARED
- ${ufocore_SRCS}
- ${ufocore_NODOC_SRCS}
- ${CMAKE_CURRENT_BINARY_DIR}/ufo-enums.c)
+ ${ufocore_SRCS}
+ ${ufocore_NODOC_SRCS}
+ ${CMAKE_CURRENT_BINARY_DIR}/ufo-enums.c)
set_target_properties(ufo PROPERTIES
VERSION ${PACKAGE_VERSION}
@@ -107,16 +109,18 @@ install(TARGETS ufo
ARCHIVE DESTINATION ${LIBDIR}
LIBRARY DESTINATION ${LIBDIR})
-install(FILES ${ufocore_HDRS} ${CMAKE_CURRENT_BINARY_DIR}/ufo-enums.h
+install(FILES ${ufocore_HDRS}
+ ${CMAKE_CURRENT_SOURCE_DIR}/ufo.h
+ ${CMAKE_CURRENT_BINARY_DIR}/ufo-enums.h
DESTINATION ${INCLUDEDIR})
# --- pkg-config --------------------------------------------------------------
set(UFO_PKG_PREFIX "${CMAKE_INSTALL_PREFIX}")
set(UFO_PKG_EXEC_PREFIX "${UFO_PKG_PREFIX}/bin")
-set(UFO_PKG_LIBDIR "${UFO_PKG_PREFIX}/${LIBDIR}")
-set(UFO_PKG_INCLUDEDIR "${UFO_PKG_PREFIX}/${INCLUDEDIR}")
+set(UFO_PKG_INCLUDEDIR "${UFO_PKG_PREFIX}/include")
set(UFO_PKG_GIRDIR "${UFO_PKG_PREFIX}/share/gir-1.0")
+set(UFO_PKG_LIBDIR "${UFO_PKG_PREFIX}/${LIBDIR}")
set(UFO_PKG_TYPELIBDIR "${UFO_PKG_PREFIX}/${LIBDIR}/girepository-1.0")
# FIXME: inside the ufo.pc.in we should set the lib names that we found out, not
@@ -153,9 +157,10 @@ if (INTROSPECTION_SCANNER AND INTROSPECTION_COMPILER)
--include=GLib-2.0
-I${OPENCL_INCLUDE_DIRS}
-I${CMAKE_CURRENT_SOURCE_DIR}
+ -DUFO_COMPILATION
--output ${GIR_XML}
--warn-all
- ${_gir_input} > /dev/null
+ ${_gir_input}# > /dev/null
DEPENDS ${ufocore_SRCS}
WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR})
diff --git a/src/ufo-arch-graph.h b/src/ufo-arch-graph.h
index 17faed7..cea40aa 100644
--- a/src/ufo-arch-graph.h
+++ b/src/ufo-arch-graph.h
@@ -20,7 +20,10 @@
#ifndef __UFO_ARCH_GRAPH_H
#define __UFO_ARCH_GRAPH_H
-#include <glib-object.h>
+#if !defined (__UFO_H_INSIDE__) && !defined (UFO_COMPILATION)
+#error "Only <ufo/ufo.h> can be included directly."
+#endif
+
#include <ufo-graph.h>
#include <ufo-resources.h>
diff --git a/src/ufo-buffer.h b/src/ufo-buffer.h
index 985ce49..de6c0f6 100644
--- a/src/ufo-buffer.h
+++ b/src/ufo-buffer.h
@@ -20,6 +20,10 @@
#ifndef __UFO_BUFFER_H
#define __UFO_BUFFER_H
+#if !defined (__UFO_H_INSIDE__) && !defined (UFO_COMPILATION)
+#error "Only <ufo/ufo.h> can be included directly."
+#endif
+
#include <glib-object.h>
G_BEGIN_DECLS
diff --git a/src/ufo-config.h b/src/ufo-config.h
index 95ded45..447350e 100644
--- a/src/ufo-config.h
+++ b/src/ufo-config.h
@@ -20,6 +20,10 @@
#ifndef __UFO_CONFIG_H
#define __UFO_CONFIG_H
+#if !defined (__UFO_H_INSIDE__) && !defined (UFO_COMPILATION)
+#error "Only <ufo/ufo.h> can be included directly."
+#endif
+
#include <glib-object.h>
G_BEGIN_DECLS
diff --git a/src/ufo-configurable.h b/src/ufo-configurable.h
index 94809b2..99e6adc 100644
--- a/src/ufo-configurable.h
+++ b/src/ufo-configurable.h
@@ -20,6 +20,10 @@
#ifndef __UFO_CONFIGURABLE_H
#define __UFO_CONFIGURABLE_H
+#if !defined (__UFO_H_INSIDE__) && !defined (UFO_COMPILATION)
+#error "Only <ufo/ufo.h> can be included directly."
+#endif
+
#include <glib-object.h>
G_BEGIN_DECLS
diff --git a/src/ufo-cpu-node.h b/src/ufo-cpu-node.h
index 9d8b146..df7e4a8 100644
--- a/src/ufo-cpu-node.h
+++ b/src/ufo-cpu-node.h
@@ -20,6 +20,10 @@
#ifndef __UFO_CPU_NODE_H
#define __UFO_CPU_NODE_H
+#if !defined (__UFO_H_INSIDE__) && !defined (UFO_COMPILATION)
+#error "Only <ufo/ufo.h> can be included directly."
+#endif
+
#include <ufo-node.h>
G_BEGIN_DECLS
diff --git a/src/ufo-cpu-task-iface.h b/src/ufo-cpu-task-iface.h
index c26618c..3cff0b9 100644
--- a/src/ufo-cpu-task-iface.h
+++ b/src/ufo-cpu-task-iface.h
@@ -20,6 +20,10 @@
#ifndef UFO_CPU_TASK_IFACE_H
#define UFO_CPU_TASK_IFACE_H
+#if !defined (__UFO_H_INSIDE__) && !defined (UFO_COMPILATION)
+#error "Only <ufo/ufo.h> can be included directly."
+#endif
+
#include <ufo-task-iface.h>
#include <ufo-buffer.h>
diff --git a/src/ufo-dummy-task.h b/src/ufo-dummy-task.h
index 42cc33e..6f1934f 100644
--- a/src/ufo-dummy-task.h
+++ b/src/ufo-dummy-task.h
@@ -20,7 +20,10 @@
#ifndef __UFO_DUMMY_TASK_H
#define __UFO_DUMMY_TASK_H
-#include <glib-object.h>
+#if !defined (__UFO_H_INSIDE__) && !defined (UFO_COMPILATION)
+#error "Only <ufo/ufo.h> can be included directly."
+#endif
+
#include <ufo-task-node.h>
G_BEGIN_DECLS
diff --git a/src/ufo-gpu-node.h b/src/ufo-gpu-node.h
index e9ad6d0..ef042cc 100644
--- a/src/ufo-gpu-node.h
+++ b/src/ufo-gpu-node.h
@@ -20,6 +20,10 @@
#ifndef __UFO_GPU_NODE_H
#define __UFO_GPU_NODE_H
+#if !defined (__UFO_H_INSIDE__) && !defined (UFO_COMPILATION)
+#error "Only <ufo/ufo.h> can be included directly."
+#endif
+
#include <ufo-node.h>
G_BEGIN_DECLS
diff --git a/src/ufo-gpu-task-iface.h b/src/ufo-gpu-task-iface.h
index fd60eaa..6125254 100644
--- a/src/ufo-gpu-task-iface.h
+++ b/src/ufo-gpu-task-iface.h
@@ -20,6 +20,10 @@
#ifndef UFO_GPU_TASK_IFACE_H
#define UFO_GPU_TASK_IFACE_H
+#if !defined (__UFO_H_INSIDE__) && !defined (UFO_COMPILATION)
+#error "Only <ufo/ufo.h> can be included directly."
+#endif
+
#include <ufo-gpu-node.h>
#include <ufo-task-iface.h>
#include <ufo-buffer.h>
diff --git a/src/ufo-graph.h b/src/ufo-graph.h
index 6df2246..41ca0a7 100644
--- a/src/ufo-graph.h
+++ b/src/ufo-graph.h
@@ -20,7 +20,10 @@
#ifndef __UFO_GRAPH_H
#define __UFO_GRAPH_H
-#include <glib-object.h>
+#if !defined (__UFO_H_INSIDE__) && !defined (UFO_COMPILATION)
+#error "Only <ufo/ufo.h> can be included directly."
+#endif
+
#include <ufo-node.h>
G_BEGIN_DECLS
diff --git a/src/ufo-group.h b/src/ufo-group.h
index ba9d081..6ae265b 100644
--- a/src/ufo-group.h
+++ b/src/ufo-group.h
@@ -20,7 +20,10 @@
#ifndef __UFO_GROUP_H
#define __UFO_GROUP_H
-#include <glib-object.h>
+#if !defined (__UFO_H_INSIDE__) && !defined (UFO_COMPILATION)
+#error "Only <ufo/ufo.h> can be included directly."
+#endif
+
#include <ufo-task-iface.h>
#include <ufo-buffer.h>
diff --git a/src/ufo-input-task.h b/src/ufo-input-task.h
index 52c162e..a131b9e 100644
--- a/src/ufo-input-task.h
+++ b/src/ufo-input-task.h
@@ -20,6 +20,10 @@
#ifndef __UFO_INPUT_TASK_H
#define __UFO_INPUT_TASK_H
+#if !defined (__UFO_H_INSIDE__) && !defined (UFO_COMPILATION)
+#error "Only <ufo/ufo.h> can be included directly."
+#endif
+
#include <ufo-task-node.h>
G_BEGIN_DECLS
diff --git a/src/ufo-node.h b/src/ufo-node.h
index 4602c0c..9d5eb18 100644
--- a/src/ufo-node.h
+++ b/src/ufo-node.h
@@ -20,6 +20,10 @@
#ifndef __UFO_NODE_H
#define __UFO_NODE_H
+#if !defined (__UFO_H_INSIDE__) && !defined (UFO_COMPILATION)
+#error "Only <ufo/ufo.h> can be included directly."
+#endif
+
#include <glib-object.h>
G_BEGIN_DECLS
diff --git a/src/ufo-output-task.h b/src/ufo-output-task.h
index 1135fb1..2a6a945 100644
--- a/src/ufo-output-task.h
+++ b/src/ufo-output-task.h
@@ -20,7 +20,10 @@
#ifndef __UFO_OUTPUT_TASK_H
#define __UFO_OUTPUT_TASK_H
-#include <glib-object.h>
+#if !defined (__UFO_H_INSIDE__) && !defined (UFO_COMPILATION)
+#error "Only <ufo/ufo.h> can be included directly."
+#endif
+
#include <ufo-task-node.h>
G_BEGIN_DECLS
diff --git a/src/ufo-plugin-manager.h b/src/ufo-plugin-manager.h
index 82f0c4d..0b3d03a 100644
--- a/src/ufo-plugin-manager.h
+++ b/src/ufo-plugin-manager.h
@@ -20,7 +20,11 @@
#ifndef __UFO_PLUGIN_MANAGER_H
#define __UFO_PLUGIN_MANAGER_H
-#include <glib-object.h>
+#if !defined (__UFO_H_INSIDE__) && !defined (UFO_COMPILATION)
+#error "Only <ufo/ufo.h> can be included directly."
+#endif
+
+#include <ufo-configurable.h>
#include <ufo-config.h>
#include <ufo-node.h>
diff --git a/src/ufo-profiler.h b/src/ufo-profiler.h
index 22e0ab7..050e251 100644
--- a/src/ufo-profiler.h
+++ b/src/ufo-profiler.h
@@ -20,6 +20,10 @@
#ifndef __UFO_PROFILER_H
#define __UFO_PROFILER_H
+#if !defined (__UFO_H_INSIDE__) && !defined (UFO_COMPILATION)
+#error "Only <ufo/ufo.h> can be included directly."
+#endif
+
#include <glib-object.h>
G_BEGIN_DECLS
diff --git a/src/ufo-remote-node.h b/src/ufo-remote-node.h
index 5645ae6..4a5e2c4 100644
--- a/src/ufo-remote-node.h
+++ b/src/ufo-remote-node.h
@@ -20,6 +20,10 @@
#ifndef __UFO_REMOTE_NODE_H
#define __UFO_REMOTE_NODE_H
+#if !defined (__UFO_H_INSIDE__) && !defined (UFO_COMPILATION)
+#error "Only <ufo/ufo.h> can be included directly."
+#endif
+
#include <ufo-node.h>
#include <ufo-buffer.h>
#include <ufo-task-iface.h>
diff --git a/src/ufo-remote-task.h b/src/ufo-remote-task.h
index 9201968..e5405db 100644
--- a/src/ufo-remote-task.h
+++ b/src/ufo-remote-task.h
@@ -20,7 +20,10 @@
#ifndef __UFO_REMOTE_TASK_H
#define __UFO_REMOTE_TASK_H
-#include <glib-object.h>
+#if !defined (__UFO_H_INSIDE__) && !defined (UFO_COMPILATION)
+#error "Only <ufo/ufo.h> can be included directly."
+#endif
+
#include <ufo-task-node.h>
G_BEGIN_DECLS
diff --git a/src/ufo-resources.h b/src/ufo-resources.h
index 83bb5a1..640c53b 100644
--- a/src/ufo-resources.h
+++ b/src/ufo-resources.h
@@ -20,7 +20,10 @@
#ifndef __UFO_RESOURCES_H
#define __UFO_RESOURCES_H
-#include <glib-object.h>
+#if !defined (__UFO_H_INSIDE__) && !defined (UFO_COMPILATION)
+#error "Only <ufo/ufo.h> can be included directly."
+#endif
+
#include <ufo-config.h>
#include <ufo-buffer.h>
diff --git a/src/ufo-scheduler.h b/src/ufo-scheduler.h
index 3400c05..76f19bb 100644
--- a/src/ufo-scheduler.h
+++ b/src/ufo-scheduler.h
@@ -20,7 +20,10 @@
#ifndef __UFO_SCHEDULER_H
#define __UFO_SCHEDULER_H
-#include <glib-object.h>
+#if !defined (__UFO_H_INSIDE__) && !defined (UFO_COMPILATION)
+#error "Only <ufo/ufo.h> can be included directly."
+#endif
+
#include <ufo-arch-graph.h>
#include <ufo-task-graph.h>
diff --git a/src/ufo-task-graph.h b/src/ufo-task-graph.h
index 7d65aa9..8e6447f 100644
--- a/src/ufo-task-graph.h
+++ b/src/ufo-task-graph.h
@@ -20,7 +20,10 @@
#ifndef __UFO_TASK_GRAPH_H
#define __UFO_TASK_GRAPH_H
-#include <glib-object.h>
+#if !defined (__UFO_H_INSIDE__) && !defined (UFO_COMPILATION)
+#error "Only <ufo/ufo.h> can be included directly."
+#endif
+
#include <ufo-graph.h>
#include <ufo-arch-graph.h>
#include <ufo-task-node.h>
diff --git a/src/ufo-task-iface.h b/src/ufo-task-iface.h
index 788ad93..ccc7913 100644
--- a/src/ufo-task-iface.h
+++ b/src/ufo-task-iface.h
@@ -20,7 +20,10 @@
#ifndef UFO_TASK_IFACE_H
#define UFO_TASK_IFACE_H
-#include <glib-object.h>
+#if !defined (__UFO_H_INSIDE__) && !defined (UFO_COMPILATION)
+#error "Only <ufo/ufo.h> can be included directly."
+#endif
+
#include <ufo-buffer.h>
#include <ufo-resources.h>
diff --git a/src/ufo-task-node.h b/src/ufo-task-node.h
index 5ce8eac..ee52844 100644
--- a/src/ufo-task-node.h
+++ b/src/ufo-task-node.h
@@ -20,6 +20,10 @@
#ifndef __UFO_TASK_NODE_H
#define __UFO_TASK_NODE_H
+#if !defined (__UFO_H_INSIDE__) && !defined (UFO_COMPILATION)
+#error "Only <ufo/ufo.h> can be included directly."
+#endif
+
#include <ufo-node.h>
#include <ufo-group.h>
diff --git a/src/ufo.h b/src/ufo.h
new file mode 100644
index 0000000..b9b3d8e
--- /dev/null
+++ b/src/ufo.h
@@ -0,0 +1,52 @@
+/*
+ * Copyright (C) 2011-2013 Karlsruhe Institute of Technology
+ *
+ * This file is part of Ufo.
+ *
+ * This library is free software: you can redistribute it and/or
+ * modify it under the terms of the GNU Lesser General Public
+ * License as published by the Free Software Foundation, either
+ * version 3 of the License, or (at your option) any later version.
+ *
+ * This library is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+ * Lesser General Public License for more details.
+ *
+ * You should have received a copy of the GNU Lesser General Public
+ * License along with this library. If not, see <http://www.gnu.org/licenses/>.
+ */
+
+#ifndef __UFO_H
+#define __UFO_H
+
+#define __UFO_H_INSIDE__
+
+#include <ufo/ufo-arch-graph.h>
+#include <ufo/ufo-buffer.h>
+#include <ufo/ufo-config.h>
+#include <ufo/ufo-configurable.h>
+#include <ufo/ufo-cpu-node.h>
+#include <ufo/ufo-cpu-task-iface.h>
+#include <ufo/ufo-dummy-task.h>
+#include <ufo/ufo-enums.h>
+#include <ufo/ufo-gpu-node.h>
+#include <ufo/ufo-gpu-task-iface.h>
+#include <ufo/ufo-graph.h>
+#include <ufo/ufo-group.h>
+#include <ufo/ufo-input-task.h>
+#include <ufo/ufo-node.h>
+#include <ufo/ufo-output-task.h>
+#include <ufo/ufo-plugin-manager.h>
+#include <ufo/ufo-profiler.h>
+#include <ufo/ufo-remote-node.h>
+#include <ufo/ufo-remote-task.h>
+#include <ufo/ufo-resources.h>
+#include <ufo/ufo-scheduler.h>
+#include <ufo/ufo-task-graph.h>
+#include <ufo/ufo-task-iface.h>
+#include <ufo/ufo-task-node.h>
+
+#undef __UFO_H_INSIDE__
+
+#endif
diff --git a/tests/test-config.c b/tests/test-config.c
index 4a27190..1f479e8 100644
--- a/tests/test-config.c
+++ b/tests/test-config.c
@@ -17,9 +17,8 @@
* License along with this library. If not, see <http://www.gnu.org/licenses/>.
*/
-#include <glib-object.h>
+#include <ufo.h>
#include "test-suite.h"
-#include "ufo-config.h"
static void
test_path (void)
diff --git a/tests/test-graph.c b/tests/test-graph.c
index 4d47bf9..2acb8b4 100644
--- a/tests/test-graph.c
+++ b/tests/test-graph.c
@@ -17,11 +17,8 @@
* License along with this library. If not, see <http://www.gnu.org/licenses/>.
*/
-#include <glib.h>
+#include <ufo.h>
#include "test-suite.h"
-#include "ufo-graph.h"
-#include "ufo-node.h"
-
typedef struct {
UfoGraph *graph;
diff --git a/tests/test-profiler.c b/tests/test-profiler.c
index 2683511..ce9b4ae 100644
--- a/tests/test-profiler.c
+++ b/tests/test-profiler.c
@@ -21,8 +21,8 @@
#include <glib/gstdio.h>
#include <stdio.h>
#include <string.h>
+#include <ufo.h>
#include "test-suite.h"
-#include "ufo-profiler.h"
typedef struct {
UfoProfiler *profiler;
diff --git a/tests/test-suite.c b/tests/test-suite.c
index 0bd1077..d16b214 100644
--- a/tests/test-suite.c
+++ b/tests/test-suite.c
@@ -20,10 +20,11 @@
#include <glib-object.h>
#include "test-suite.h"
-static void ignore_log (const gchar *domain,
- GLogLevelFlags flags,
- const gchar *message,
- gpointer data)
+static void
+ignore_log (const gchar *domain,
+ GLogLevelFlags flags,
+ const gchar *message,
+ gpointer data)
{
}
diff --git a/tools/runjson.c b/tools/runjson.c
index f932bf1..929c0d2 100644
--- a/tools/runjson.c
+++ b/tools/runjson.c
@@ -18,12 +18,7 @@
*/
#include <stdlib.h>
-#include <glib-object.h>
-#include <ufo-config.h>
-#include <ufo-task-graph.h>
-#include <ufo-arch-graph.h>
-#include <ufo-scheduler.h>
-#include <ufo-resources.h>
+#include <ufo.h>
static void
handle_error (const gchar *prefix, GError *error, UfoGraph *graph)
diff --git a/tools/ufo-server.c b/tools/ufo-server.c
index b5e9893..4b28d5c 100644
--- a/tools/ufo-server.c
+++ b/tools/ufo-server.c
@@ -18,17 +18,8 @@
*/
#include <zmq.h>
-#include <glib-object.h>
#include <string.h>
-#include <ufo-buffer.h>
-#include <ufo-resources.h>
-#include <ufo-task-graph.h>
-#include <ufo-scheduler.h>
-#include <ufo-plugin-manager.h>
-#include <ufo-input-task.h>
-#include <ufo-output-task.h>
-#include <ufo-dummy-task.h>
-#include <ufo-remote-node.h>
+#include <ufo.h>
typedef struct {
gpointer socket;