summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Vogelgesang <matthias.vogelgesang@kit.edu>2013-11-16 21:50:51 +0100
committerMatthias Vogelgesang <matthias.vogelgesang@kit.edu>2013-11-16 21:50:51 +0100
commit603c7f721d1b769ae9e1560474a833ba6839b729 (patch)
tree7b52a2583b09c20d8c189cc4a14ad94bfb07c18f /CMakeLists.txt
parent06b5f326499ce24c14570b1c782a3a8b24816cfa (diff)
Move config.h.in to the top level
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5082ce7..2f2a0ab 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -121,6 +121,9 @@ if (CMAKE_COMPILER_IS_GNUCC OR ("${CMAKE_C_COMPILER_ID}" STREQUAL "Clang"))
endif()
add_definitions(-DG_LOG_DOMAIN=\"Ufo\")
+
+configure_file(${CMAKE_CURRENT_SOURCE_DIR}/config.h.in
+ ${CMAKE_CURRENT_BINARY_DIR}/config.h)
#}}}
#{{{ Subdirectories
add_subdirectory(ufo)