summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Vogelgesang <matthias.vogelgesang@kit.edu>2017-12-08 16:35:52 +0100
committerMatthias Vogelgesang <matthias.vogelgesang@kit.edu>2017-12-08 16:35:52 +0100
commitd5947621bb774901bf55a3b3c3595c58d4205675 (patch)
tree74574adf6b5007265089ee7a3064e409ec1e2bb4 /CMakeLists.txt
parentd67a890d4cfff63eca50bcdd08fd506c05a0e897 (diff)
Compile with gnu99 to avoid GLOB_TILDE complaints
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5d212e6..c6d5f1f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -125,7 +125,7 @@ include_directories(
#}}}
#}}}
#{{{ Definitions
-set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -std=c99 -Wall -Wextra -fPIC -Wno-unused-parameter -Wno-deprecated-declarations")
+set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -std=gnu99 -Wall -Wextra -fPIC -Wno-unused-parameter -Wno-deprecated-declarations")
add_definitions(-DG_LOG_DOMAIN=\"Ufo\"
-D_FILE_OFFSET_BITS=64)