summaryrefslogtreecommitdiff
path: root/common/cmake
diff options
context:
space:
mode:
authorMatthias Vogelgesang <matthias.vogelgesang@kit.edu>2013-10-28 18:28:40 +0100
committerMatthias Vogelgesang <matthias.vogelgesang@kit.edu>2013-10-28 18:28:40 +0100
commit0a8225e6f35680265beded2a391a62f5edee0dcc (patch)
treed058a675fc6317e6f4d7e9f7fc081dfa06171b2b /common/cmake
parenta942a472acd42e7ecbf2cd5954a1c5ef97b47cd1 (diff)
Remove unused CMake modules
Diffstat (limited to 'common/cmake')
-rw-r--r--common/cmake/FindFFTW3.cmake133
-rw-r--r--common/cmake/FindOCLFFT.cmake14
-rw-r--r--common/cmake/FindVala.cmake65
3 files changed, 0 insertions, 212 deletions
diff --git a/common/cmake/FindFFTW3.cmake b/common/cmake/FindFFTW3.cmake
deleted file mode 100644
index 252fcd9..0000000
--- a/common/cmake/FindFFTW3.cmake
+++ /dev/null
@@ -1,133 +0,0 @@
-#
-# Try to find FFTW3 library
-# (see www.fftw.org)
-# Once run this will define:
-#
-# FFTW3_FOUND
-# FFTW3_INCLUDE_DIR
-# FFTW3_LIBRARIES
-# FFTW3_LINK_DIRECTORIES
-#
-# You may set one of these options before including this file:
-# FFTW3_USE_SSE2
-#
-# TODO: _F_ versions.
-#
-# Jan Woetzel 05/2004
-# www.mip.informatik.uni-kiel.de
-# --------------------------------
-
- FIND_PATH(FFTW3_INCLUDE_DIR fftw3.h
- ${FFTW3_DIR}/include
- ${FFTW3_HOME}/include
- ${FFTW3_DIR}
- ${FFTW3_HOME}
- $ENV{FFTW3_DIR}/include
- $ENV{FFTW3_HOME}/include
- $ENV{FFTW3_DIR}
- $ENV{FFTW3_HOME}
- /usr/include
- /usr/local/include
- $ENV{SOURCE_DIR}/fftw3
- $ENV{SOURCE_DIR}/fftw3/include
- $ENV{SOURCE_DIR}/fftw
- $ENV{SOURCE_DIR}/fftw/include
- )
-#MESSAGE("DBG FFTW3_INCLUDE_DIR=${FFTW3_INCLUDE_DIR}")
-
-
-SET(FFTW3_POSSIBLE_LIBRARY_PATH
- ${FFTW3_DIR}/lib
- ${FFTW3_HOME}/lib
- ${FFTW3_DIR}
- ${FFTW3_HOME}
- $ENV{FFTW3_DIR}/lib
- $ENV{FFTW3_HOME}/lib
- $ENV{FFTW3_DIR}
- $ENV{FFTW3_HOME}
- /usr/lib
- /usr/local/lib
- $ENV{SOURCE_DIR}/fftw3
- $ENV{SOURCE_DIR}/fftw3/lib
- $ENV{SOURCE_DIR}/fftw
- $ENV{SOURCE_DIR}/fftw/lib
-)
-
-
-# the lib prefix is containe din filename onf W32, unfortuantely. JW
-# teh "general" lib:
-FIND_LIBRARY(FFTW3_FFTW_LIBRARY
- NAMES fftw3 libfftw libfftw3 libfftw3-3
- PATHS
- ${FFTW3_POSSIBLE_LIBRARY_PATH}
- )
-#MESSAGE("DBG FFTW3_FFTW_LIBRARY=${FFTW3_FFTW_LIBRARY}")
-
-FIND_LIBRARY(FFTW3_FFTWF_LIBRARY
- NAMES fftwf3 fftw3f fftwf libfftwf libfftwf3 libfftw3f libfftw3f-3
- PATHS
- ${FFTW3_POSSIBLE_LIBRARY_PATH}
- )
-#MESSAGE("DBG FFTW3_FFTWF_LIBRARY=${FFTW3_FFTWF_LIBRARY}")
-
-FIND_LIBRARY(FFTW3_FFTWL_LIBRARY
- NAMES fftwl3 fftw3l fftwl libfftwl libfftwl3 libfftw3l libfftw3l-3
- PATHS
- ${FFTW3_POSSIBLE_LIBRARY_PATH}
- )
-#MESSAGE("DBG FFTW3_FFTWF_LIBRARY=${FFTW3_FFTWL_LIBRARY}")
-
-
-FIND_LIBRARY(FFTW3_FFTW_SSE2_LIBRARY
- NAMES fftw_sse2 fftw3_sse2 libfftw_sse2 libfftw3_sse2
- PATHS
- ${FFTW3_POSSIBLE_LIBRARY_PATH}
- )
-#MESSAGE("DBG FFTW3_FFTW_SSE2_LIBRARY=${FFTW3_FFTW_SSE2_LIBRARY}")
-
-FIND_LIBRARY(FFTW3_FFTWF_SSE_LIBRARY
- NAMES fftwf_sse fftwf3_sse fftw3f_sse libfftwf_sse libfftwf3_sse libfftw3f_sse
- PATHS
- ${FFTW3_POSSIBLE_LIBRARY_PATH}
- )
-#MESSAGE("DBG FFTW3_FFTWF_SSE_LIBRARY=${FFTW3_FFTWF_SSE_LIBRARY}")
-
-
-# --------------------------------
-# select one of the above
-# default:
-IF (FFTW3_FFTW_LIBRARY)
- SET(FFTW3_LIBRARIES ${FFTW3_FFTW_LIBRARY})
-ENDIF (FFTW3_FFTW_LIBRARY)
-# specialized:
-IF (FFTW3_USE_SSE2 AND FFTW3_FFTW_SSE2_LIBRARY)
- SET(FFTW3_LIBRARIES ${FFTW3_FFTW_SSE2_LIBRARY})
-ENDIF (FFTW3_USE_SSE2 AND FFTW3_FFTW_SSE2_LIBRARY)
-
-# --------------------------------
-
-IF(FFTW3_LIBRARIES)
- IF (FFTW3_INCLUDE_DIR)
-
- # OK, found all we need
- SET(FFTW3_FOUND TRUE)
- GET_FILENAME_COMPONENT(FFTW3_LINK_DIRECTORIES ${FFTW3_LIBRARIES} PATH)
-
- ELSE (FFTW3_INCLUDE_DIR)
- MESSAGE("FFTW3 include dir not found. Set FFTW3_DIR to find it.")
- ENDIF(FFTW3_INCLUDE_DIR)
-ELSE(FFTW3_LIBRARIES)
- MESSAGE("FFTW3 lib not found. Set FFTW3_DIR to find it.")
-ENDIF(FFTW3_LIBRARIES)
-
-
-MARK_AS_ADVANCED(
- FFTW3_INCLUDE_DIR
- FFTW3_LIBRARIES
- FFTW3_FFTW_LIBRARY
- FFTW3_FFTW_SSE2_LIBRARY
- FFTW3_FFTWF_LIBRARY
- FFTW3_FFTWF_SSE_LIBRARY
- FFTW3_FFTWL_LIBRARY
- FFTW3_LINK_DIRECTORIES
-)
diff --git a/common/cmake/FindOCLFFT.cmake b/common/cmake/FindOCLFFT.cmake
deleted file mode 100644
index fd9c156..0000000
--- a/common/cmake/FindOCLFFT.cmake
+++ /dev/null
@@ -1,14 +0,0 @@
-# Try to find liboclfft and clFFT.h. Once found the following variables will be
-# defined:
-#
-# OCLFFT_FOUND
-# OCLFFT_INCLUDE_DIRS
-# OCLFFT_LIBRARIES
-
-find_path(OCLFFT_INCLUDE_DIRS clFFT.h)
-find_library(OCLFFT_LIBRARIES oclfft)
-
-include(FindPackageHandleStandardArgs)
-find_package_handle_standard_args(OCLFFT DEFAULT_MSG OCLFFT_INCLUDE_DIRS OCLFFT_LIBRARIES)
-
-mark_as_advanced(OCLFFT_INCLUDE_DIRS OCLFFT_LIBRARIES)
diff --git a/common/cmake/FindVala.cmake b/common/cmake/FindVala.cmake
deleted file mode 100644
index 2d1ed14..0000000
--- a/common/cmake/FindVala.cmake
+++ /dev/null
@@ -1,65 +0,0 @@
-##
-# Copyright 2009 Jakob Westhoff. All rights reserved.
-#
-# Redistribution and use in source and binary forms, with or without
-# modification, are permitted provided that the following conditions are met:
-#
-# 1. Redistributions of source code must retain the above copyright notice,
-# this list of conditions and the following disclaimer.
-#
-# 2. Redistributions in binary form must reproduce the above copyright notice,
-# this list of conditions and the following disclaimer in the documentation
-# and/or other materials provided with the distribution.
-#
-# THIS SOFTWARE IS PROVIDED BY JAKOB WESTHOFF ``AS IS'' AND ANY EXPRESS OR
-# IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL JAKOB WESTHOFF OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT,
-# INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
-# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
-# PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF
-# LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE
-# OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-#
-# The views and conclusions contained in the software and documentation are those
-# of the authors and should not be interpreted as representing official policies,
-# either expressed or implied, of Jakob Westhoff
-##
-
-##
-# Find module for the Vala compiler (valac)
-#
-# This module determines wheter a Vala compiler is installed on the current
-# system and where its executable is.
-#
-# Call the module using "find_package(Vala) from within your CMakeLists.txt.
-#
-# The following variables will be set after an invocation:
-#
-# VALA_FOUND Whether the vala compiler has been found or not
-# VALA_EXECUTABLE Full path to the valac executable if it has been found
-# VALA_VERSION Version number of the available valac
-##
-
-
-# Search for the valac executable in the usual system paths.
-find_program(VALA_EXECUTABLE
- NAMES valac)
-
-# Handle the QUIETLY and REQUIRED arguments, which may be given to the find call.
-# Furthermore set VALA_FOUND to TRUE if Vala has been found (aka.
-# VALA_EXECUTABLE is set)
-
-include(FindPackageHandleStandardArgs)
-find_package_handle_standard_args(Vala DEFAULT_MSG VALA_EXECUTABLE)
-
-mark_as_advanced(VALA_EXECUTABLE)
-
-# Determine the valac version
-if(VALA_FOUND)
- execute_process(COMMAND ${VALA_EXECUTABLE} "--version"
- OUTPUT_VARIABLE "VALA_VERSION")
- string(REPLACE "Vala" "" "VALA_VERSION" ${VALA_VERSION})
- string(STRIP ${VALA_VERSION} "VALA_VERSION")
-endif(VALA_FOUND)