summaryrefslogtreecommitdiff
path: root/docs/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Vogelgesang <matthias.vogelgesang@kit.edu>2012-01-17 09:33:45 +0100
committerMatthias Vogelgesang <matthias.vogelgesang@kit.edu>2012-01-17 09:33:45 +0100
commit4372d62ec615567634a5a3d5c07ccd209d55f0c3 (patch)
tree0924f63e1220dced2eb6e26e067159ff951f0c08 /docs/CMakeLists.txt
parentae85db054f042875488b6b9bd02b15c7e20b00f7 (diff)
Generate and install reference
Diffstat (limited to 'docs/CMakeLists.txt')
-rw-r--r--docs/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/docs/CMakeLists.txt b/docs/CMakeLists.txt
index 539317a..7e6b9fc 100644
--- a/docs/CMakeLists.txt
+++ b/docs/CMakeLists.txt
@@ -10,10 +10,27 @@ if(GTK_DOC_FOUND)
configure_file(${CMAKE_CURRENT_SOURCE_DIR}/upd-ref.sh.in
${CMAKE_CURRENT_BINARY_DIR}/upd-ref.sh)
+ configure_file(${CMAKE_CURRENT_SOURCE_DIR}/Ufo-docs.xml.in
+ ${CMAKE_CURRENT_BINARY_DIR}/Ufo-docs.xml)
+
add_custom_target(reference
sh ${CMAKE_CURRENT_BINARY_DIR}/upd-ref.sh
WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
DEPENDS ${ufocore_SRCS})
+
+ set(doc_root "${CMAKE_CURRENT_BINARY_DIR}/html")
+ file(GLOB ref_files "${doc_root}/*.html")
+ set(ref_files
+ ${ref_files}
+ "${doc_root}/style.css"
+ "${doc_root}/Ufo.devhelp"
+ "${doc_root}/Ufo.devhelp2")
+ file(GLOB img_files "${doc_root}/*.png")
+
+ install(FILES
+ ${ref_files}
+ ${img_files}
+ DESTINATION /usr/share/gtk-doc/html/Ufo)
endif(GTK_DOC_FOUND)
if(SPHINX)