summaryrefslogtreecommitdiff
path: root/docs/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Vogelgesang <matthias.vogelgesang@kit.edu>2013-11-18 08:59:22 +0100
committerMatthias Vogelgesang <matthias.vogelgesang@kit.edu>2013-11-18 08:59:22 +0100
commit67af69a7773a91ffca56f655f73bf4d21db6eabf (patch)
treedcba27b112b871bfdc5ad500741200644361c3cd /docs/CMakeLists.txt
parent56aeeae66abcb2053f5c39df03bdbfec9393e9db (diff)
Fix in-tree build problem with Sphinx
Diffstat (limited to 'docs/CMakeLists.txt')
-rw-r--r--docs/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/docs/CMakeLists.txt b/docs/CMakeLists.txt
index b67b537..9aa0daf 100644
--- a/docs/CMakeLists.txt
+++ b/docs/CMakeLists.txt
@@ -9,7 +9,7 @@ if(SPHINX)
if (WITH_MANUAL)
set(input_dir ${CMAKE_CURRENT_SOURCE_DIR}/manual)
- set(output_dir ${CMAKE_CURRENT_BINARY_DIR}/manual)
+ set(output_dir ${CMAKE_CURRENT_BINARY_DIR}/manual/html)
file(GLOB_RECURSE sphinx_source ${input_dir}/*.rst)
@@ -17,12 +17,12 @@ if(SPHINX)
configure_file(${input_dir}/${file} ${output_dir}/${file} COPYONLY)
endforeach()
- add_custom_command(OUTPUT ${output_dir}/html/index.html
+ add_custom_command(OUTPUT ${output_dir}/index.html
COMMAND ${SPHINX} -b html ${input_dir} ${output_dir}
DEPENDS ${sphinx_source}
COMMENT "Build Sphinx HTML")
- add_custom_target(manual ALL DEPENDS ${output_dir}/html/index.html)
+ add_custom_target(manual ALL DEPENDS ${output_dir}/index.html)
add_dependencies(manual ufo)
endif()