summaryrefslogtreecommitdiff
path: root/docs
diff options
context:
space:
mode:
authorMatthias Vogelgesang <matthias.vogelgesang@kit.edu>2013-11-15 12:41:32 +0100
committerMatthias Vogelgesang <matthias.vogelgesang@kit.edu>2013-11-15 12:41:32 +0100
commit4a04d07dcfbb7058af70aebbbe5ef57dbe9f33f1 (patch)
tree22c95948251fd681aa769d7213e544b0047e49ff /docs
parent5d868f93afed068bca90f13e7aca2416ab5fdaeb (diff)
Generate manual without configuring conf.py
Diffstat (limited to 'docs')
-rw-r--r--docs/CMakeLists.txt9
-rw-r--r--docs/manual/conf.py56
-rw-r--r--docs/manual/conf.py.in202
3 files changed, 57 insertions, 210 deletions
diff --git a/docs/CMakeLists.txt b/docs/CMakeLists.txt
index ab90d6e..b67b537 100644
--- a/docs/CMakeLists.txt
+++ b/docs/CMakeLists.txt
@@ -12,21 +12,14 @@ if(SPHINX)
set(output_dir ${CMAKE_CURRENT_BINARY_DIR}/manual)
file(GLOB_RECURSE sphinx_source ${input_dir}/*.rst)
- list(APPEND sphinx_source "${output_dir}/conf.py")
-
- set(sphinx_static
- _static/ufo-logo.png)
-
- configure_file(${input_dir}/conf.py.in ${output_dir}/conf.py)
foreach(file ${sphinx_static})
configure_file(${input_dir}/${file} ${output_dir}/${file} COPYONLY)
endforeach()
add_custom_command(OUTPUT ${output_dir}/html/index.html
- COMMAND ${SPHINX} -b html -c ${output_dir} ${input_dir} html
+ COMMAND ${SPHINX} -b html ${input_dir} ${output_dir}
DEPENDS ${sphinx_source}
- WORKING_DIRECTORY ${output_dir}
COMMENT "Build Sphinx HTML")
add_custom_target(manual ALL DEPENDS ${output_dir}/html/index.html)
diff --git a/docs/manual/conf.py b/docs/manual/conf.py
new file mode 100644
index 0000000..ea0d8b0
--- /dev/null
+++ b/docs/manual/conf.py
@@ -0,0 +1,56 @@
+# -*- coding: utf-8 -*-
+
+import time
+import re
+
+
+def get_version():
+ patterns = [
+ r'^set\(UFO_VERSION_MAJOR "(\d*)"\)',
+ r'^set\(UFO_VERSION_MINOR "(\d*)"\)',
+ r'^set\(UFO_VERSION_PATCH "(\d*)"\)'
+ ]
+ version = ["0", "0", "0"]
+
+ with open('../../CMakeLists.txt', 'r') as f:
+ lines = f.readlines()
+ major_pattern = r'^set\(UFO_VERSION_MAJOR "(\d*)"\)'
+
+ for line in lines:
+ for i, pattern in enumerate(patterns):
+ m = re.match(pattern, line)
+
+ if m:
+ version[i] = m.group(1)
+
+ return '.'.join(version)
+
+
+project = u'UFO'
+copyright = u'%s, UFO Development Team a Collaboration of KIT, SCI and TPU' % time.strftime('%Y')
+version = get_version()
+release = version
+
+extensions = ['sphinx.ext.pngmath']
+templates_path = ['_templates']
+
+master_doc = 'index'
+source_suffix = '.rst'
+source_encoding = 'utf-8'
+
+primary_domain = 'c'
+
+add_function_parentheses = True
+pygments_style = 'default'
+
+html_theme = 'default'
+html_logo = "_static/ufo-logo.png"
+html_static_path = ['_static']
+html_use_smartypants = True
+
+htmlhelp_basename = 'UFOdoc'
+
+latex_documents = [
+ ('index', 'UFO.tex', u'UFO Documentation',
+ u'Matthias Vogelgesang', 'manual'),
+]
diff --git a/docs/manual/conf.py.in b/docs/manual/conf.py.in
deleted file mode 100644
index 8f7dac8..0000000
--- a/docs/manual/conf.py.in
+++ /dev/null
@@ -1,202 +0,0 @@
-# -*- coding: utf-8 -*-
-#
-# UFO documentation build configuration file, created by
-# sphinx-quickstart on Mon Apr 18 12:10:11 2011.
-#
-# This file is execfile()d with the current directory set to its containing dir.
-#
-# Note that not all possible configuration values are present in this
-# autogenerated file.
-#
-# All configuration values have a default; values that are commented out
-# serve to show the default.
-
-import sys, os, time
-
-# If extensions (or modules to document with autodoc) are in another directory,
-# add these directories to sys.path here. If the directory is relative to the
-# documentation root, use os.path.abspath to make it absolute, like shown here.
-#sys.path.append(os.path.abspath('.'))
-
-# -- General configuration -----------------------------------------------------
-
-# Add any Sphinx extension module names here, as strings. They can be extensions
-# coming with Sphinx (named 'sphinx.ext.*') or your custom ones.
-extensions = ['sphinx.ext.todo', 'sphinx.ext.coverage', 'sphinx.ext.pngmath' ]
-
-# Add any paths that contain templates here, relative to this directory.
-templates_path = ['_templates']
-
-# The suffix of source filenames.
-source_suffix = '.rst'
-
-# The encoding of source files.
-source_encoding = 'utf-8'
-
-# The master toctree document.
-master_doc = 'index'
-
-# General information about the project.
-project = u'UFO'
-copyright = u'%s, UFO Development Team a Collaboration of KIT, SCI and TPU' % time.strftime('%Y')
-
-# The version info for the project you're documenting, acts as replacement for
-# |version| and |release|, also used in various other places throughout the
-# built documents.
-#
-# The short X.Y version.
-version = "${UFO_VERSION_MAJOR}.${UFO_VERSION_MINOR}"
-# The full version, including alpha/beta/rc tags.
-release = "${PACKAGE_VERSION}"
-
-primary_domain = 'c'
-
-# The language for content autogenerated by Sphinx. Refer to documentation
-# for a list of supported languages.
-#language = None
-
-# There are two options for replacing |today|: either, you set today to some
-# non-false value, then it is used:
-#today = ''
-# Else, today_fmt is used as the format for a strftime call.
-#today_fmt = '%B %d, %Y'
-
-# List of documents that shouldn't be included in the build.
-#unused_docs = []
-
-# List of directories, relative to source directory, that shouldn't be searched
-# for source files.
-exclude_trees = []
-
-# The reST default role (used for this markup: `text`) to use for all documents.
-#default_role = None
-
-# If true, '()' will be appended to :func: etc. cross-reference text.
-add_function_parentheses = True
-
-# If true, the current module name will be prepended to all description
-# unit titles (such as .. function::).
-#add_module_names = True
-
-# If true, sectionauthor and moduleauthor directives will be shown in the
-# output. They are ignored by default.
-#show_authors = False
-
-# The name of the Pygments (syntax highlighting) style to use.
-pygments_style = 'default'
-
-# A list of ignored prefixes for module index sorting.
-#modindex_common_prefix = []
-
-
-# -- Options for HTML output ---------------------------------------------------
-
-# The theme to use for HTML and HTML Help pages. Major themes that come with
-# Sphinx are currently 'default' and 'sphinxdoc'.
-html_theme = 'default'
-
-# Theme options are theme-specific and customize the look and feel of a theme
-# further. For a list of options available for each theme, see the
-# documentation.
-html_theme_options = {
- 'stickysidebar': 'true'
-}
-
-# Add any paths that contain custom themes here, relative to this directory.
-#html_theme_path = []
-
-# The name for this set of Sphinx documents. If None, it defaults to
-# "<project> v<release> documentation".
-#html_title = None
-
-# A shorter title for the navigation bar. Default is the same as html_title.
-#html_short_title = None
-
-# The name of an image file (relative to this directory) to place at the top
-# of the sidebar.
-html_logo = "_static/ufo-logo.png"
-
-# The name of an image file (within the static path) to use as favicon of the
-# docs. This file should be a Windows icon file (.ico) being 16x16 or 32x32
-# pixels large.
-#html_favicon = None
-
-# Add any paths that contain custom static files (such as style sheets) here,
-# relative to this directory. They are copied after the builtin static files,
-# so a file named "default.css" will overwrite the builtin "default.css".
-html_static_path = ['_static']
-
-# If not '', a 'Last updated on:' timestamp is inserted at every page bottom,
-# using the given strftime format.
-#html_last_updated_fmt = '%b %d, %Y'
-
-# If true, SmartyPants will be used to convert quotes and dashes to
-# typographically correct entities.
-html_use_smartypants = True
-
-# Custom sidebar templates, maps document names to template names.
-# html_sidebars = {
-# 'index' : 'indexsidebar.html'
-# }
-
-# Additional templates that should be rendered to pages, maps page names to
-# template names.
-# html_additional_pages = {
-# 'index' : 'indexcontent.html'
-# }
-
-# If false, no module index is generated.
-#html_use_modindex = True
-
-# If false, no index is generated.
-#html_use_index = True
-
-# If true, the index is split into individual pages for each letter.
-#html_split_index = False
-
-# If true, links to the reST sources are added to the pages.
-#html_show_sourcelink = True
-
-# If true, an OpenSearch description file will be output, and all pages will
-# contain a <link> tag referring to it. The value of this option must be the
-# base URL from which the finished HTML is served.
-#html_use_opensearch = ''
-
-# If nonempty, this is the file name suffix for HTML files (e.g. ".xhtml").
-#html_file_suffix = ''
-
-# Output file base name for HTML help builder.
-htmlhelp_basename = 'UFOdoc'
-
-
-# -- Options for LaTeX output --------------------------------------------------
-
-# The paper size ('letter' or 'a4').
-#latex_paper_size = 'letter'
-
-# The font size ('10pt', '11pt' or '12pt').
-#latex_font_size = '10pt'
-
-# Grouping the document tree into LaTeX files. List of tuples
-# (source start file, target name, title, author, documentclass [howto/manual]).
-latex_documents = [
- ('index', 'UFO.tex', u'UFO Documentation',
- u'Matthias Vogelgesang', 'manual'),
-]
-
-# The name of an image file (relative to this directory) to place at the top of
-# the title page.
-#latex_logo = None
-
-# For "manual" documents, if this is true, then toplevel headings are parts,
-# not chapters.
-#latex_use_parts = False
-
-# Additional stuff for the LaTeX preamble.
-#latex_preamble = ''
-
-# Documents to append as an appendix to all manuals.
-#latex_appendices = []
-
-# If false, no module index is generated.
-#latex_use_modindex = True