summaryrefslogtreecommitdiff
path: root/ufo/meson.build
diff options
context:
space:
mode:
authorMatthias Vogelgesang <matthias.vogelgesang@kit.edu>2017-07-13 11:35:09 +0200
committerMatthias Vogelgesang <matthias.vogelgesang@kit.edu>2017-07-13 11:35:09 +0200
commit3fba32ee294017f3db7ae0d43b8e4ef7945be0c2 (patch)
tree586c479fbf98d2120336fc3f646221a23b4021f5 /ufo/meson.build
parent23a8520810451bff7f4cc85e69b3cfdb9b405ede (diff)
Fix header installation with meson
Diffstat (limited to 'ufo/meson.build')
-rw-r--r--ufo/meson.build5
1 files changed, 3 insertions, 2 deletions
diff --git a/ufo/meson.build b/ufo/meson.build
index 6178a4f..3676a1e 100644
--- a/ufo/meson.build
+++ b/ufo/meson.build
@@ -35,6 +35,7 @@ sources = [
]
headers = [
+ 'ufo.h',
'ufo-base-scheduler.h',
'ufo-basic-ops.h',
'ufo-buffer.h',
@@ -72,8 +73,8 @@ enums = gnome.mkenums('ufo-enums',
sources: headers,
h_template: 'ufo-enums.h.template',
c_template: 'ufo-enums.c.template',
- # install_header: true,
- # install_dir: '', # this is horrible but works and prefixes correctly
+ install_header: true,
+ install_dir: '@0@/@1@'.format(get_option('includedir'), header_subdir),
)
enums_c = enums[0]