summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorivan baktsheev <dot.and.thing@gmail.com>2017-07-27 15:51:34 +0300
committerGitHub <noreply@github.com>2017-07-27 15:51:34 +0300
commite0b3c16a81564d3d7be638f4ff77bdadc2d591d6 (patch)
tree94e622bc7c191edf8fed68694cdf58a4469dbb3d
parent93173f612a231d808f19f27428d8c87c05975ba4 (diff)
Added formula for homebrew
-rw-r--r--Formula/uhubctl.rb16
1 files changed, 16 insertions, 0 deletions
diff --git a/Formula/uhubctl.rb b/Formula/uhubctl.rb
new file mode 100644
index 0000000..440b1cd
--- /dev/null
+++ b/Formula/uhubctl.rb
@@ -0,0 +1,16 @@
+class Uhubctl < Formula
+ desc "control USB hubs powering per-port"
+ homepage "https://github.com/mvp/uhubctl"
+ head "https://github.com/mvp/uhubctl.git"
+
+ depends_on "libusb"
+
+ def install
+ system "make"
+ bin.install "uhubctl"
+ end
+
+ test do
+ system "#{bin}/uhubctl", "-v"
+ end
+end