summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Preud'homme <robotux@celest.fr>2013-01-03 19:04:37 +0100
committerThomas Preud'homme <robotux@celest.fr>2013-01-04 15:00:38 +0100
commit9903534add3cdcc5e8c6225791c05bc271a945e0 (patch)
treeb832c7503db7ec95619d42f6e788e347aa40205a
parentad5afada4e6a4fc2d6db1fefd8f00f9970b71b05 (diff)
Set QMAKE_CXXFLAGS_{RELEASE,DEBUG} for qmake
-rw-r--r--debian/changelog2
-rwxr-xr-xdebian/rules8
2 files changed, 5 insertions, 5 deletions
diff --git a/debian/changelog b/debian/changelog
index 04092fa..52a6a29 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -15,6 +15,8 @@ ultracopier (0.3.0.5-1) unstable; urgency=low
plugins-alternative/Themes/Teracopy via a symlink to
plugins/Themes/Oxygen/resources/player_pause.png.
+ Stop making i18n files executable.
+ + Set QMAKE_CXXFLAGS_RELEASE and QMAKE_CXXFLAGS_DEBUG from CPPFLAGS and
+ CXXFLAGS when invoking qmake.
* debian/control:
+ Bump Standards-Version to 3.9.4 (no changes needed).
+ Update build dependency version on debhelper to reflect compatibility.
diff --git a/debian/rules b/debian/rules
index a75cddd..8133fb0 100755
--- a/debian/rules
+++ b/debian/rules
@@ -3,13 +3,11 @@
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
-export CPPFLAGS:=$(shell dpkg-buildflags --get CPPFLAGS)
-export CFLAGS:=$(shell dpkg-buildflags --get CFLAGS)
-export LDFLAGS:=$(shell dpkg-buildflags --get LDFLAGS)
-
override_dh_auto_configure:
ln -s -f ../../../../plugins/Themes/Oxygen/resources/player_pause.png plugins-alternative/Themes/Teracopy/resources
- dh_auto_configure --buildsystem=qmake -- build.pro
+ dh_auto_configure --buildsystem=qmake -- \
+ QMAKE_CXXFLAGS_RELEASE="$(CXXFLAGS) $(CPPFLAGS)" \
+ QMAKE_CXXFLAGS_DEBUG="$(CXXFLAGS) $(CPPFLAGS)" build.pro
clean:
rm -f build