summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Paul Adrian Glaubitz <glaubitz@physik.fu-berlin.de>2014-12-30 13:13:08 +0100
committerJohn Paul Adrian Glaubitz <glaubitz@physik.fu-berlin.de>2014-12-30 13:13:08 +0100
commitef1a1a4c5d10825b01a8eeec28782fcfa08202e3 (patch)
treeb36293642eb3c0a47ea00c8fd0c162279bf30a4a
parent2abb9daa1bb0f16bbb8177528bb65f28ce8eec35 (diff)
Imported Debian patch 3.9.1-4.1
-rw-r--r--debian/changelog8
-rw-r--r--debian/patches/https-verifyhost-fix.diff22
-rw-r--r--debian/patches/series1
3 files changed, 31 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 96ae0cd..81d6b02 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+urlgrabber (3.9.1-4.1) unstable; urgency=medium
+
+ * Non-maintainer upload.
+ * Add debian/patches/https-verifyhost-fix.diff taken from upstream
+ to fix https connection issues (Closes: #715416, #722191).
+
+ -- John Paul Adrian Glaubitz <glaubitz@physik.fu-berlin.de> Tue, 30 Dec 2014 13:13:08 +0100
+
urlgrabber (3.9.1-4) unstable; urgency=low
* Add two patches created from upstream development version. Closes: #587575.
diff --git a/debian/patches/https-verifyhost-fix.diff b/debian/patches/https-verifyhost-fix.diff
new file mode 100644
index 0000000..7e6788e
--- /dev/null
+++ b/debian/patches/https-verifyhost-fix.diff
@@ -0,0 +1,22 @@
+--- a/urlgrabber/grabber.py
++++ b/urlgrabber/grabber.py
+@@ -1193,6 +1193,9 @@ class PyCurlFileObject(object):
+ if not opts:
+ opts = self.opts
+
++ # keepalives
++ if not opts.keepalive:
++ self.curl_obj.setopt(pycurl.FORBID_REUSE, 1)
+
+ # defaults we're always going to set
+ self.curl_obj.setopt(pycurl.NOPROGRESS, False)
+@@ -1236,7 +1239,8 @@ class PyCurlFileObject(object):
+ self.curl_obj.setopt(pycurl.CAPATH, opts.ssl_ca_cert)
+ self.curl_obj.setopt(pycurl.CAINFO, opts.ssl_ca_cert)
+ self.curl_obj.setopt(pycurl.SSL_VERIFYPEER, opts.ssl_verify_peer)
+- self.curl_obj.setopt(pycurl.SSL_VERIFYHOST, opts.ssl_verify_host)
++ if opts.ssl_verify_host: # 1 is meaningless to curl
++ self.curl_obj.setopt(pycurl.SSL_VERIFYHOST, 2)
+ if opts.ssl_key:
+ self.curl_obj.setopt(pycurl.SSLKEY, opts.ssl_key)
+ if opts.ssl_key_type:
diff --git a/debian/patches/series b/debian/patches/series
index 1c4a57a..d8581d4 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,2 +1,3 @@
grabber_fix.diff
progress_fix.diff
+https-verifyhost-fix.diff