summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules16
1 files changed, 6 insertions, 10 deletions
diff --git a/debian/rules b/debian/rules
index a72d839..d30d0dd 100755
--- a/debian/rules
+++ b/debian/rules
@@ -9,8 +9,6 @@
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
-PYVERS = $(shell pyversions -r)
-
configure: configure-stamp
configure-stamp:
dh_testdir
@@ -20,10 +18,13 @@ build: patch build-stamp
build-stamp: configure-stamp
dh_testdir
- for py in $(PYVERS); do \
- $$py setup.py build; \
+ python setup.py build
+ifeq (,$(findstring nocheck,$(DEB_BUILD_OPTIONS)))
+ # we should set -e, but all the tests fail.
+ for py in $(shell pyversions -r); do \
$$py test/runtests.py; \
done
+endif
touch build-stamp
clean: clean-patched unpatch
@@ -32,9 +33,6 @@ clean-patched:
dh_testdir
dh_testroot
-rm -f build-stamp configure-stamp
- for py in $(PYVERS); do \
- $$py setup.py clean; \
- done
python setup.py clean
find $(CURDIR) -name "*.pyc" -exec rm -f '{}' \;
dh_clean
@@ -54,9 +52,7 @@ install: build
dh_clean -k
dh_installdirs
# Add here commands to install the package into debian/urlgrabber.
- for py in $(PYVERS); do \
- $$py setup.py install --prefix=/usr --root=$(CURDIR)/debian/python-urlgrabber; \
- done
+ python setup.py install --prefix=/usr --root=$(CURDIR)/debian/python-urlgrabber
# remove unneeded documents installed by setup.py
-rm -rf $(CURDIR)/debian/python-urlgrabber/usr/share/doc/urlgrabber-3*