summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStéphane Graber <stgraber@ubuntu.com>2014-03-20 17:48:43 -0400
committerStéphane Graber <stgraber@ubuntu.com>2014-03-20 17:48:43 -0400
commitc8a07d63a49fda0f763e8a7888d85c0728b8a850 (patch)
tree5873bbaa7372862a06f53ec6dc8920fe11b99125
parent0ad25d9a7d7a595a622cc86d1edae2bd21511cdf (diff)
Import Debian changes 1.9-3ubuntu10
vlan (1.9-3ubuntu10) trusty; urgency=medium * Only create VLANs for the interface we are processing. (LP: #1295371)
-rw-r--r--debian/changelog6
-rw-r--r--debian/vlan-network-interface7
2 files changed, 12 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 34d2c0a..4c8e812 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+vlan (1.9-3ubuntu10) trusty; urgency=medium
+
+ * Only create VLANs for the interface we are processing. (LP: #1295371)
+
+ -- Stéphane Graber <stgraber@ubuntu.com> Thu, 20 Mar 2014 17:48:43 -0400
+
vlan (1.9-3ubuntu9) saucy; urgency=low
* Transition from iproute to iproute2.
diff --git a/debian/vlan-network-interface b/debian/vlan-network-interface
index 5ded09f..836b707 100644
--- a/debian/vlan-network-interface
+++ b/debian/vlan-network-interface
@@ -25,5 +25,10 @@ for IFACE in $(ifquery --list --allow auto); do
# Now that the environment is ready, call the pre-up script to create the vlan
export IFACE IF_VLAN_RAW_DEVICE
- /etc/network/if-pre-up.d/vlan
+
+ # Create the VLANs related to the interface
+ if [ "$IF_VLAN_RAW_DEVICE" = "$INTERFACE" ] || \
+ echo $IFACE | grep -q $INTERFACE; then
+ /etc/network/if-pre-up.d/vlan
+ fi
done