summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Shadura <andrewsh@debian.org>2014-03-23 14:42:43 +0100
committerAndrew Shadura <andrewsh@debian.org>2014-03-23 14:42:43 +0100
commitf118e1000ca02c6fcb7ff9cc1ea1f485fec6b2c2 (patch)
treec48f75e49f245bd1f4660bdc4d4dd5530a09c02d
parentd9fd17038aa60353549663c0e7bda59d1d96c2a0 (diff)
Import Debian changes 1.9-3.1
vlan (1.9-3.1) unstable; urgency=medium * Non-maintainer upload. * Don't act on VLAN interfaces already supported by ifupdown (Closes: #705456) * Don't depend on iproute, depend on iproute2 instead.
-rw-r--r--.gitignore6
-rw-r--r--debian/changelog9
-rw-r--r--debian/control2
-rw-r--r--debian/network/if-post-down.d/vlan4
-rw-r--r--debian/network/if-pre-up.d/vlan10
-rwxr-xr-xvconfigbin0 -> 8224 bytes
-rw-r--r--vconfig.h0
-rw-r--r--vconfig.obin0 -> 27944 bytes
8 files changed, 22 insertions, 9 deletions
diff --git a/.gitignore b/.gitignore
deleted file mode 100644
index 7543c93..0000000
--- a/.gitignore
+++ /dev/null
@@ -1,6 +0,0 @@
-debian/files
-debian/vlan.substvars
-debian/vlan
-vconfig
-vconfig.h
-vconfig.o
diff --git a/debian/changelog b/debian/changelog
index 8927805..c4382b3 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,12 @@
+vlan (1.9-3.1) unstable; urgency=medium
+
+ * Non-maintainer upload.
+ * Don't act on VLAN interfaces already supported by ifupdown
+ (Closes: #705456)
+ * Don't depend on iproute, depend on iproute2 instead.
+
+ -- Andrew Shadura <andrewsh@debian.org> Sun, 23 Mar 2014 14:42:43 +0100
+
vlan (1.9-3) unstable; urgency=low
* Add XS-Vcs-Git and XS-Vcs-Browser fields to control.
diff --git a/debian/control b/debian/control
index 41fcbce..4fd484c 100644
--- a/debian/control
+++ b/debian/control
@@ -10,7 +10,7 @@ XS-Vcs-Browser: http://git.debian.org/?p=collab-maint/vlan.git
Package: vlan
Architecture: any
-Depends: ${misc:Depends}, ${shlibs:Depends}, iproute
+Depends: ${misc:Depends}, ${shlibs:Depends}, iproute2
Section: misc
Description: user mode programs to enable VLANs on your ethernet devices
This package contains the user mode programs you need to add and remove
diff --git a/debian/network/if-post-down.d/vlan b/debian/network/if-post-down.d/vlan
index 89b16fb..bade97f 100644
--- a/debian/network/if-post-down.d/vlan
+++ b/debian/network/if-post-down.d/vlan
@@ -10,9 +10,13 @@ case "$IFACE" in
exit 0
;;
eth*.0*|bond*.0*|wlan*.0*)
+ # Silently ignore interfaces which ifupdown handles on its own
+ [ -z "$IF_VLAN_RAW_DEVICE" ] && exit 0
IF_VLAN_RAW_DEVICE=`echo $IFACE|sed "s/\(eth[0-9][0-9]*\)\..*/\1/;s/\(bond[0-9][0-9]*\)\..*/\1/;s/\(wlan[0-9][0-9]*\)\..*/\1/"`
;;
eth*.*|bond*.*|wlan*.*)
+ # Silently ignore interfaces which ifupdown handles on its own
+ [ -z "$IF_VLAN_RAW_DEVICE" ] && exit 0
IF_VLAN_RAW_DEVICE=`echo $IFACE|sed "s/\(eth[0-9][0-9]*\)\..*/\1/;s/\(bond[0-9][0-9]*\)\..*/\1/;s/\(wlan[0-9][0-9]*\)\..*/\1/"`
;;
# Test for vlan raw device (#196890, #292648)
diff --git a/debian/network/if-pre-up.d/vlan b/debian/network/if-pre-up.d/vlan
index b977be8..391c2ec 100644
--- a/debian/network/if-pre-up.d/vlan
+++ b/debian/network/if-pre-up.d/vlan
@@ -16,11 +16,15 @@ case "$IFACE" in
VLANID=`echo $IFACE|sed "s/vlan0*//"`
;;
eth*.0*|bond*.0*|wlan*.0*)
+ # Silently ignore interfaces which ifupdown handles on its own
+ [ -z "$IF_VLAN_RAW_DEVICE" ] && exit 0
vconfig set_name_type DEV_PLUS_VID
VLANID=`echo $IFACE|sed "s/eth[0-9][0-9]*\.0*//g;s/bond[0-9][0-9]*\.0*//;s/wlan[0-9][0-9]*\.0*//"`
IF_VLAN_RAW_DEVICE=`echo $IFACE|sed "s/\(eth[0-9][0-9]*\)\..*/\1/;s/\(bond[0-9][0-9]*\)\..*/\1/;s/\(wlan[0-9][0-9]*\)\..*/\1/"`
;;
eth*.*|bond*.*|wlan*.*)
+ # Silently ignore interfaces which ifupdown handles on its own
+ [ -z "$IF_VLAN_RAW_DEVICE" ] && exit 0
vconfig set_name_type DEV_PLUS_VID_NO_PAD
VLANID=`echo $IFACE|sed "s/eth[0-9][0-9]*\.0*//g;s/bond[0-9][0-9]*\.0*//g;s/wlan[0-9][0-9]*\.0*//g"`
IF_VLAN_RAW_DEVICE=`echo $IFACE|sed "s/\(eth[0-9][0-9]*\)\..*/\1/;s/\(bond[0-9][0-9]*\)\..*/\1/;s/\(wlan[0-9][0-9]*\)\..*/\1/"`
@@ -51,8 +55,10 @@ if [ -n "$IF_VLAN_RAW_DEVICE" ]; then
echo "$IF_VLAN_RAW_DEVICE does not exist, unable to create $IFACE"
exit 1
fi
- ip link set up dev $IF_VLAN_RAW_DEVICE
- vconfig add $IF_VLAN_RAW_DEVICE $VLANID
+ if [ ! -e "/sys/class/net/$IFACE" ]; then
+ ip link set up dev $IF_VLAN_RAW_DEVICE
+ vconfig add $IF_VLAN_RAW_DEVICE $VLANID
+ fi
fi
# This is not vlan specific, and should actually go somewhere else.
diff --git a/vconfig b/vconfig
new file mode 100755
index 0000000..8cfcbcd
--- /dev/null
+++ b/vconfig
Binary files differ
diff --git a/vconfig.h b/vconfig.h
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/vconfig.h
diff --git a/vconfig.o b/vconfig.o
new file mode 100644
index 0000000..8e8da0e
--- /dev/null
+++ b/vconfig.o
Binary files differ